Forums > Jitter

Unibrain Fire-I Troubleshooting/Bugs in Jitter

Feb 07 2006 | 9:17 pm

I have Unibrain board camera with the Fire-I software. It’s all up to date and works fine by itself. The problem is in Max when I am doing the help patch for jit.dx.grab to try and test my setup and when I hit ‘open’ it crashes Max. No ‘quit’ message or anything, it just flat out closes itself. I’ve tried every different video mode in Fire-I, I’ve tried screwing with the inputs and device lists, but nothing works to make it stay open on ‘open’. Every time I hit ‘open’ it automatically closes Max. In jit.qt.grab it gives a ‘quit unexpectedly’ message but still crashes it.

It was working a week or two ago before I did a reformat. I’m wondering if I’m missing software somewhere?

Unibrain board camera
Max/MSP 4.5.5 and Jitter 1.5

Feb 07 2006 | 9:35 pm

*since I can’t edit I’ll reply*

Error information:
AppName: max.exe AppVer: ModName: quicktime.qts
ModVer: Offset: 001122fd

It seems like it has something to do with quicktime… I’ll reinstall 6.5 and see if that solves the problem.

Feb 07 2006 | 9:53 pm

Reinstalled QT 6.5.2 — I made my own patch and it still won’t work. Might have to port this over to my friend’s Mac to eliminate the headache.

Feb 07 2006 | 10:28 pm

not exactly the same set up, and not the same problem, but just a few
weeks ago i was using unibrain(s) firewire (fireI) web cams on a mac
(+ latest maxmsp& jitter) and found that using the unibrains software
i had crashes (when using more than 1 cam)

uninstalling the software made everything work super well (i just can
not name my cameras)

might be somehow related



Kasper T. Toeplitz
noise, composition, bass, computer

Feb 08 2006 | 3:33 pm

Do you mean the drivers for the camera or the application to use the cameras? And if you do mean the drivers are there alternate drivers (provided by windows or third party)?

Feb 08 2006 | 3:40 pm

i mean the drivers provided on the CD with the cams (or found on the
web site) – since i use those cams only with jitter (and soft VNS) I
don’t know about the application…. and , as I told you, i work on a
mac, so it’s certainly different in terms of drivers

I found some alterbnate drivers (IOXexperts) – which are really cheap
(but not free) but i had the same problems. I trashed all the
drivers, and it works – once again it’s on mac OSX, so i might be

but the point is than the unibrain drivers did not impressed me as my
maxcrashed with them (and not anymore without)



Kasper T. Toeplitz
noise, composition, bass, computer

Feb 08 2006 | 4:12 pm

I tried it out in macintosh and the open command works fine in jit.qt.grab. I don’t know if it’s my hardware setup on my PC or what – it’s the open function in both jit.dx.grab and jit.qt.grab that makes it crash. It’s not driver dependent (tried it with default and with Fire-I) and I reinstalled directx. I can’t for the life of me figure out what the problem is. I may reformat with a vanilla install of windows xp to see if that solves the problem.

Edit: I uninstalled the fire-i drivers and program and it still wouldn’t work. I was using basiccapture provided with abstract plane’s software. I think that using it with another application while trying to open it in max crashes it. I need the advanced input options (uyuv) and the like so I’m going to try to reinstall the drivers on my windows computer. If it doesn’t work at least I know what to do! Thanks for getting me on the right track, at least now I can get a good start on my project.

Feb 09 2006 | 10:21 am

I use a Fire-i regularly for testing on Windows and don’t experience
these problems. It’s particularly odd, since (as you mention) it was
working until recently for you. Did the crashing begin with an
install of QuickTime 7?


Feb 09 2006 | 2:50 pm

I recently reinstalled windows using a homemade unattended install – I’m thinking this may have caused some conflict with the software somewhere. It’s back up and working now though, thankfully. It was incredibly odd. I think it had to do with accessing it using another application (Fire-I or Abstract Plane’s software) and then trying to access it through Max (while it was already in use).

Feb 15 2006 | 4:33 pm

Sorry for the late reply. I’ve had this problem on Mac OS X (various
versions). The problem seems to be that you install a Fire-i, and it
shows up in jit.qt.grab with the name that you chose for it when you
installed it, but if the device isn’t attached, because for example you
installed a second Fire-i which is attached but you acccidentally
selected the first Fire-i device from the jit.qt.grab devicelist, max
just crashes. The fix is to only select the Fire-i device that is
attached, or look in /Library/Components and delete the fire-i device
files that you’re not going to use again.

Be aware that you will need to re-install the drivers and set up a new
device name for every new Fire-i that you want to use on that computer.
And no, I don’t work for Unibrain :)


Viewing 10 posts - 1 through 10 (of 10 total)

Forums > Jitter