Forums > MaxMSP

uninstalling max 5


Nov 13 2009 | 7:23 am

i need to uninstall max 5 runtime so that i may install 4 (to run a max app that doesnt work in 5).

when i delete the max 5 folder and the library->pref folder in osx, then try and run the max4 package installer i receive a notice saying that i can not install because a newer version of max has been found on the computer. how do i remove max5 runtime so that i can install an older version?

it might be important to note that max5 is currently installed in a subfolder of my applications folder on osx.

Oct 17 2010 | 1:52 pm

I’m having the same problem.
I deleted Preferences, The max pkg file in the Receipts folder and edited the plist. I’m not sure what else to do. Thanks for any help.

Oct 17 2010 | 3:51 pm

When installing Max5 as well as Max4 all I did was rename the containing folder temporarily so there wasn’t a clash, install the newer version and then re-rename the folder again. I’m not sure if it will work the other way around but it might be worth a try.

lh

Oct 18 2010 | 12:48 am

The first thing I did was delete the application folder if that’s what you mean. There have got to be some deeply hidden files and spotlight in osx isn’t helping.

Is there any kind of logger I could run? So that I could re-install the max 5 runtime and see what is going where?

Oct 18 2010 | 7:24 am

Hi
But the folder names don’t clash Max5 vs MaxMSP 4.6 . . .
Mind you it does seem to be having quite a problem with the Interlok extensions, got sent to their website dl’d and installed and 4.6.3 does not want to run, Interlok extension problem although the runtime appears to be working.
This is on osx 10.6.4 on an iMac 2.8g QC i7 . . .
But it installed without an issue . .

Oct 18 2010 | 8:38 am

You should be able to run 4 and 5 on the same machine. Just install them both. No renaming necessary – I’ve been doing this for several years without hitch.

HTH

A.

Oct 18 2010 | 9:14 am

Likewise, but only just went to install 4.6.3 on my new machine – i7 quadcore and it seems Interlock extension is a problem. They suggest going back to app developers if it continues which it seems to be, tho I have not restarted so maybe they have not loaded the kext yet – will hope it works later or will report it to Cycling.

Oct 18 2010 | 9:26 am

Download the lastest interlok from PACE and install it. Max4 should then work fine, it does on my i7.

p

Oct 18 2010 | 9:55 am

Yeah I followed the redirect the app gave me but it didnot work then Max5 would not either, Damn. Uninstall downloaded again direct from site and all seems good now, Minor ghost in the machine it would seem, thanks.
Strange because they both appear to be the same version – oh well, no harm no foul . .
Thanks Patrick
MM

Oct 20 2010 | 3:31 pm

It’s odd that the full version works, but not the runtime. I tried installing them newest version interlock from pace, but it still doesn’t work. I emailed support, but they haven’t gotten back to me. I guess I’ll have to re-install os x. :(

Oct 20 2010 | 7:26 pm

The Max 4.6 Runtime-only download sometimes exhibits the aforementioned conflict with Max 5. It is recommended that the Max 4 Runtime that comes with the full install is used instead.

Mar 30 2013 | 10:20 pm

I just encountered this problem on OS X 10.8.3 and here’s what worked for me: I installed the Max 5 runtime, then removed a file from inside the MaxMSPRuntime46.pkg bundle and unarchived it to get the 4.6.3 runtime…

More specifically:
– Install Max 5 Runtime
– Mount maxmspruntime463.dmg
– Right-click MaxMSPRuntime46.pkg and choose ‘Show Package Contents’
– In the new finder window, look in the ‘Contents’ folder and drag ‘Archive.pax.gz’ to your desktop
– Double-click ‘Archive.pax.gz’ to unarchive it
– On your desktop, look in the newly created ‘Applications’ folder
– Drag ‘MaxMSP Runtime 4.6’ to your normal Applications folder

You should now have two working runtimes in your applications folder, one for Max 4 and the other for Max 5.

Cheers.

Viewing 12 posts - 1 through 12 (of 12 total)

Forums > MaxMSP