Forums > MaxMSP

Unlocking thispatcher locks?

Mar 24 2008 | 9:29 pm

I’ve noticed that some patches, the window size, scrollbars, etc are turned off (locked). How do I disable this? So that I can resize the window, scroll around, etc. It’s not always the case that the thispatcher object is visible, making it really difficult to edit/pick apart a patch when I can’t even scroll around.

Copying (cmd-a) and pasting seems to copy the setting with it, making editing difficult.

Is there a way to ignore this behavior, at least in edit mode? It’s very annoying that it’s "locked" even in edit mode.

Mar 25 2008 | 12:08 am

Open the original patcher, chose select all, then copy. Chose New > Text file and hit paste. The contents of the patcher should be pasted as code. Find the thispatcher line and remove it, then copy everything to an empty patcher window.

Mar 25 2008 | 6:09 am

Worked like a charm, thanks.

Mar 25 2008 | 10:37 pm

Or simply add another thispatcher object and send messages to that.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums > MaxMSP