Forums > MaxMSP

USB hot plug with hi?

June 25, 2008 | 9:34 am

Hi C74…

is there any chance to see hot plug support for USB interface handled by
[hi] in Max 5 ?

On windows, it seems possible to do so by re-instanciating the hi object.
On the other hand, one has to restart Max on Macintosh…

It is a super handicap to have to restart Max because of only one interface
that has been unplugged from a USB hub, and it really becomes a hell
when working with *many* interfaces, with a heavy-long-to-load patch.
I think super collider has it working right…

Would be a super great improvement, and spare a lot of stress with these
so baaaaaaaad USB plugs… [Who the hell is the engineer who designed
such a plug?]

BTW, does anyone has idea where to find secure USB connector (e.g. with
clips like XLR)?
(Neutrik has the ethernet format but no USB…)

thanks for any hint..

June 26, 2008 | 4:39 pm

i’ve gone through a LOT of hell with this sort of problem, mostly with USB MIDI devices. for a while i was using a setup that featured 2 midi controllers, each routed to different programs, with max routing midi to Reason via a loopback. every time anything got unplugged, i’d have to completely restart the program.
as far as the hi stuff, from what i know about the windows device driver system, it should, in theory, be possible to hot plug somehow, but that feature is rarely implemented. i don’t know a whole lot about the osx implementations, but i imagine the same problem might exist.
so… in short, as far as i know there is no good solution to this. personally, i use a lot of electrical tape.

June 27, 2008 | 11:10 am

Viewing 3 posts - 1 through 3 (of 3 total)

Forums > MaxMSP