Forums > MaxMSP

Using serial device for a remote control

Dec 12 2013 | 10:47 am

I just got a USB enable IrDA device. I installed the proper driver and I’m using the max serial object which is correctly recognizing it on port a. I don’t see any data coming in however when I point a tv remote control at it. Any ideas?

thanks for the help!;74;109&PLine=74

Dec 13 2013 | 9:48 am

can not see serial data format on this link

did you try as HID on max

Dec 16 2013 | 9:52 am

Hey Balam,
Yea, I’ve tried the ‘hi’ object multiple times and I’m just not getting any kind of reading. Like I said, the ‘serial’ object prints that it recognizes it in port A, but nothing. I’m using a tv remote control to send data in that way.

Appreciate the help.


Dec 16 2013 | 1:16 pm

bit hard to help
with out the hardware.
by default serial objetc in my Mac shows 2 ports
serial: port a: Bluetooth-Incoming-Port
serial: port b: Bluetooth-Modem

If add a ftdi device like an arduino duemilanove
a 3th port shows up. ( Port C )

try this patch and see if you get a hardware listed in the max window

may need to change baud rates in the patch .

ps you can use an arduino to emulate a remote controller reciver
I have use it in the past and works really nice .

(google it )

-- Pasted Max Patch, click to expand. --


Dec 18 2013 | 1:06 pm

Yea so yea the IrDA shows up in port a with your patch. But still no data when I send out of the serial object with either baud rates. Maybe this device is supposed to send out information rather than receive like I had thought. I’m getting a bit confused now, haha.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums > MaxMSP