Forums > MaxMSP

Window Settings in a Patcher


Aug 06 2008 | 4:58 pm

Hello all,

Like most of my questions, this is probably really straightforward, but I can’t seem to find a way to do this…

I have a Max patch that has several patches (‘p’ objects) within in. Some of these are editable, and I’ve used ‘pcontrol’ with an ‘open’ message to allow me to open these up.

However, every time they open, the window size and view are not what I’d like them to be. Is there a way to customize the view and windowsize when opening a ‘p’?

Thanks in advance,
Joel

Aug 06 2008 | 5:31 pm

check the

subpatcher in the helpfile for the

object, i’m pretty sure it’s got what you need

Aug 06 2008 | 5:57 pm

Hi.
You can also arrange them as you want and then save the main patch.
Their positions options (as well as their opened/closed state) will be
saved with main patch.

Ciao

Aug 06 2008 | 6:00 pm

Quote: RabidRaja wrote on Wed, 06 August 2008 13:31
—————————————————-
> check the

subpatcher in the helpfile for the

object, i’m pretty sure it’s got what you need
—————————————————-

Hi there,

Thanks for this, I’ll take a close look!

Cheers,
Joel

Aug 06 2008 | 6:02 pm

Quote: gusanomaxlist wrote on Wed, 06 August 2008 13:57
—————————————————-
> Hi.
> You can also arrange them as you want and then save the main patch.
> Their positions options (as well as their opened/closed state) will be
> saved with main patch.
>
> Ciao
>
—————————————————-

Hola,

This is what I thought as well, but it definitely isn’t working that way. I think it was like this in MAX 4, but it’s not getting the same results in MAX 5.

Regardless, thank you for responding…

Cheers,
Joel

Aug 06 2008 | 6:16 pm

joelsquare wrote:
> This is what I thought as well, but it definitely isn’t working that
> way. I think it was like this in MAX 4, but it’s not getting the same
> results in MAX 5.

It does save the patchers windows positions here (osx, 5.04).

Ciao

Aug 06 2008 | 6:19 pm

Hmmm… that is odd… is there something that I could be doing wrong? It definitely isn’t doing that here. I wish it would. :(

Are you in Presentation Mode or are you saving while locked/unlocked?

Cheers,
Joel

Aug 06 2008 | 6:19 pm

P.S.

I’m also on OSX, vers 5.04

Aug 06 2008 | 6:26 pm

This is weird indeed.
It works for me regardless of presentation mode or locked/unlocked state of the patch…

Ciao

Aug 07 2008 | 3:18 pm

Weird… I wonder what about my set up prevents that (is there a bug)? I expected the behaviour you described, but it definitely isn’t happening here.

Thanks so much for weighing in though…

Cheers,
Joel

Viewing 10 posts - 1 through 10 (of 10 total)

Forums > MaxMSP