Trace/Step doesn't work fine?


    Jun 24 2006 | 10:07 am
    Hi list,
    This might be discussed before but I can't find it....
    My problem is: The blinking patch cord and the information in Max window are not displayed when I trace/step the patch that has metro object. For example: toggle -> metro -> counter -> numberbox
    I can trace/step well with the patch that has no metro. For example: button -> counter -> numberbox
    My environment is MaxMSP 4.5.7, Jitter 1.5.2, Mac OS X 10.4.6.
    Thank you for you advices.
    Masayuki Akamatsu
    p.s. Please check it as below.

    • Jun 24 2006 | 10:52 am
      On 24-Jun-2006, at 12:07, Masayuki Akamatsu wrote: > The blinking patch cord and the information in Max window are not > displayed when I trace/step the patch that has metro object. > For example: toggle -> metro -> counter -> numberbox > > I can trace/step well with the patch that has no metro. > For example: button -> counter -> numberbox
      Your second approach is more appropriate for trace.
      Normally metro will send bangs far faster than you can trace through all the messages triggered by a single bang. This may confuse the scheduler. Or maybe not, but it sure has confused me when trying to debug a patch. So I put a button next to my metro, connect it to the same object[s], use that for tracing. Once I'm sure the patch is correct, I remove the button and use the metro.
      Hope this helps, Peter
      -------------- http://www.bek.no/~pcastine/Litter/ ------------- Peter Castine +---> Litter Power & Litter Bundle for Jitter Heavy-Duty Mathematics for Everyday Use iCE: Sequencing, Recording & Interface Building for |home | chez nous| Max/MSP Extremely cool |bei uns | i nostri| http://www.dspaudio.com/ http://www.castine.de