waves and max msp


    May 26 2010 | 7:39 am
    Hi,
    Is there a way that someone has used Waves with Max MSP? Any examples? I would like to know if Waves fit like a hand in a glove with Max MSP before I buy it ...
    Thanks ahead,
    Ana

    • May 26 2010 | 8:23 am
      Hi Some years ago I used some Waves in Max 4 within vst~, on a Windows XP machine.
      It worked perfectly well, with only one issue: since Waves worked as a VST via a wrapper, I could not directly load the desired plugin, but I had to load the wrapper and then manually select the plugin you wanted - at the time, I did not find a way to make this process automatic.
      But maybe things have changed in the meantime, and on a Mac it could be different.
      Cheers aa
    • May 26 2010 | 11:59 am
      @anamaria
      if I remember right, since MaxMSP v 5.0.7 the vst-object supports waveshell and there was a patch posted how to do, search for "waveshell" in the forum (I works for me on OS X)
      sepp
    • Oct 22 2010 | 9:54 am
      I'm trying to use my Waves reverb plugins in a MaxMSP patch as well.
      I know I have to first open the "WaveShell-VST 7.0.vst", using the "plug" message to vst~. This works fine.
      But then how do I now load the actual plugin? I tried sending messages vst~ with the name or the full path of the plugin, but that didn't work.
      I'm using Max 5.1.5, OS X 10.6.4, Waves 7
      Any hints would be greatly appreciated!
      Thanks in advance, Alexandra
    • Oct 22 2010 | 10:14 pm
      "plug" should load the VST, "open" should pop up the plug-in for use...or just double-click the vst~ object.
      Watch the Max window for errors (if there are any) when loading, I'm not sure it works for every last VST out there.
    • Oct 23 2010 | 3:15 pm
      Thanks for the feedback!
      But Waves plugins use a "Waveshell" wrapper to turn their plugins into VST's, if I'm not mistaking. If I double click on the vst~ I'm just getting a blank window, not the plugin.
      I'm loading the Waveshell, but I don't know how to then select and open the actual plugin I want to use...
    • Oct 23 2010 | 3:35 pm
      This is what I was looking for:
      (For any others, make sure that the path in the patch above is correct for your VST Waveshell. I had to change it to mine)
      Thanks!