wclose -> thispatcher no longer crashes


    Oct 02 2008 | 10:02 am
    hi list !
    when sending wclose to thispatcher, i get an error saying "method wclose
    called on invalid object".
    why ?
    cheers
    g

    • Oct 02 2008 | 10:41 am
      I think this was fixed in the new version...
    • Oct 02 2008 | 11:32 am
      nop, i use the new version... this message wasn't there in the previous one.
      g
      2008/10/2 mHatsys
      >
      > I think this was fixed in the new version...
      >
      > http://www.cycling74.com/version/version_5_0_5.html
      >
      >
      >
      >
    • Oct 03 2008 | 7:59 am
      Guillaume Evrard schrieb:
      > when sending wclose to thispatcher, i get an error saying "method wclose
      > called on invalid object".
      can't reproduce, works fine here on PPC OS X 10.4.11 and 5.0.5.
      Does your window actually close? If so, I'd suspect you send that
      message to some other object as well somewhere in your patch...
      Stefan
      --
      Stefan Tiedje------------x-------
      --_____-----------|--------------
      --(_|_ ----|-----|-----()-------
      -- _|_)----|-----()--------------
      ----------()--------www.ccmix.com
    • Oct 03 2008 | 9:31 am
      yes my window closes. i tested with a simple patch containing (thispatcher)
      and the close message.
      i just find this message strange.
      g
      2008/10/3 Stefan Tiedje
      > Guillaume Evrard schrieb:
      >
      >> when sending wclose to thispatcher, i get an error saying "method wclose
      >> called on invalid object".
      >>
      >
      > can't reproduce, works fine here on PPC OS X 10.4.11 and 5.0.5.
      > Does your window actually close? If so, I'd suspect you send that message
      > to some other object as well somewhere in your patch...
      >
      > Stefan
      >
      > --
      > Stefan Tiedje------------x-------
      > --_____-----------|--------------
      > --(_|_ ----|-----|-----()-------
      > -- _|_)----|-----()--------------
      > ----------()--------www.ccmix.com
      >
      >
      >
    • Oct 03 2008 | 10:01 am
      Confirmed, happens also with poly.
      seems to me you cannot send a wclose message without its "target" anymore.
      wclose works fine if it finds a true corresponding window open.
      If not it gives this "error"
      although everything works from a practical point of view.
      Problem introduced with version 5.0.5, not present before.
      Macbook Intel system 10.4.11
      Max 5.0.5
      ciaoo
    • Oct 03 2008 | 10:15 am
      i reinstalled 5.0.5
      i no longer have this message with thispatcher.
      g
      2008/10/3 Jabbo
      >
      > Confirmed, happens also with poly.
      >
      > seems to me you cannot send a wclose message without its "target" anymore.
      > wclose works fine if it finds a true corresponding window open.
      > If not it gives this "error"
      >
      > although everything works from a practical point of view.
      >
      >
      >
      > Problem introduced with version 5.0.5, not present before.
      >
      >
      >
      > Macbook Intel system 10.4.11
      > Max 5.0.5
      >
      >
      >
      > ciaoo
      > --
      > www.lan-muzic.com
      > www.myspace.com/jacopocarreras
      >
    • Oct 07 2008 | 9:23 am
      reinstalling doesn't solve this 'strangeness' on my computer...
      matteo
      osx 10.5.5
      MaxMsp 5.0.5
      Jitter 1.7
    • Oct 16 2008 | 7:55 am
      Any news on this?
      I keep on receiving thsi error message in combination with poly, or thispatcher.
      From the poly help documentation:
      "When used without the number argument, wclose will close the patcher window with the highest index number"
      I would expect that if no window has been opened yet the wclose message would just do nothing, but if i send a wclose 0 (so to close all windows) until the latest update it worked, now i get this error message.
      I won
    • Oct 16 2008 | 9:48 pm
      this error will be fixed for the next incremental.
      -Ben