We upgraded the forum software!


    May 13 2013 | 8:47 am
    This past weekend we migrated all the data to updated forum software. All feedback is appreciated, especially if you find a bug!
    Ben

    • May 13 2013 | 9:07 am
      Hey, looking nice! I'm missing the post dates though. Kinda useful to know whether you're looking at something that's 5 days or 5 years old...
    • May 13 2013 | 9:18 am
      I suppose this explain why there are now forum posts on the c74 general feed.
      And also why the forum feeds don't work anymore.
      Is there a way to get the same behavior as before (i.e. a way to subscribe to the forum feeds I want).
      It's a pity it's not possible anymore to log in directly from a post: you now need to log in using the link in the upper right corner of the browser window, and then jump back to the post you were reading.
      In Safari (5.1.9 under X.6.8), the "backspace" key in the text field (the one where I'm typing right now) doesn't backspace when the cursor is at the beginning of a line, but moves the cursor to the beginning of the field. This happens in Visual mode, not in Text mode.
      I personnaly think there is too much wasted space, especially because the "freshness" column is now formatted on 2 lines... And also because the avatar icons are too big, as is the spacing between lines.
    • May 13 2013 | 9:32 am
      we can't access our private messages (and the link private message this user_link) since the update!
      firefox_ver20.0.1, adblock plus, noscript are deactivated on cycling74.com generally
      this should be solve now...
    • May 13 2013 | 9:54 am
      This seems jumbled, see screenshot.
      Also, I agree on the too much white space (both in post listing as thread view). Also the font seems bigger. Not very efficient use of screen real estate.
    • May 13 2013 | 9:55 am
      Screenshot again.
    • May 13 2013 | 9:56 am
      Where's the edit post button?
    • May 13 2013 | 10:29 am
      What's up with the page buttons? If I click the '2' at the bottom RH corner in the 'All' category (is it me, or is there a less generous allocation of posts per page than before?), instead of taking me to the second page of 'All', it takes me to the second page of the'Beta' category (eventually - it's running v-e-r-y s-l-o-w-l-y atm), Cheers Roger
    • May 13 2013 | 11:02 am
      After I login from the forum home it takes me to the main homepage, not the forum.
    • May 13 2013 | 11:08 am
      I'd suggest a 14px font for the listing (see screenshot), more threads listed on one page and no line breaks in the 'Last Poster' column.
    • May 13 2013 | 12:44 pm
      I confirm the Login going to the homepage (weird) and the absence of RSS feeds (very annoying) and I can add that it seem much slower than the previous one...
      Is there any plan to bring back the RSS feed?
    • May 13 2013 | 12:57 pm
      I confirm it's now extremely slooooooooooowwwwwwwwwwwwwwwwww.
    • May 13 2013 | 1:10 pm
      Me too for slowness and login to homepage, also forum posts are now filling up my mailbox from the general C74 RSS feed but my favourite threads feed is dead. Speaking of which, didn't there used to be an 'add to favourites' button?
    • May 13 2013 | 1:41 pm
      Hi - thanks for all the feedback.
      @TST private messages coming back soon.
      @DTR thanks for the screenshot. If you refresh the page, does it refresh the CSS cache and fix itself? If not, what browser are you using
      @DTR you don't see the post dates in the bottom right hand corner of each message? eg: http://cl.ly/image/1B2F2z090h39
      re: login redirecting to home page, verified and we will fix. re: RSS feeds, we'll restore them ASAP. re: slowness, we'll figure out why it's slow and get it going faster.
    • May 13 2013 | 2:08 pm
      > @DTR thanks for the screenshot. If you refresh the page, does it refresh the CSS cache and fix itself? If not, what browser are you using
      No, also the posting bit seems off
    • May 13 2013 | 2:08 pm
      > @DTR you don’t see the post dates in the bottom right hand corner of each message? eg: http://cl.ly/image/1B2F2z090h39
      No, but I think I know where they went...
    • May 13 2013 | 2:12 pm
      OSX 10.8.2 Firefox 20.0
      Add ons: Adblock plus 2.2.4 Dictionnaires Français 4.10 DoNotTrackMe 2.2.8.307 Firebug 1.11.3 (not active) And just noticed now this rogue plugin crawled its way in unsolicited... Savings-Slider 2.5
    • May 13 2013 | 2:18 pm
      linebreaks in the date and time should be banned, too. 20 px more would probably fix it, but no px limit for the cell will also be ok. safari 4.
    • May 13 2013 | 2:22 pm
      My situation 's the same with all plugins disabled.
    • May 13 2013 | 2:46 pm
      Hi there,
      posted a question in the Jitter forums but it doesn't appear in the ALL section. Is this a bug ?
    • May 13 2013 | 2:49 pm
      @Andro, yes that does appear to be a bug. Thanks for letting us know!
    • May 13 2013 | 3:21 pm
      Bug: Whenever I press the button "2" or the arrow for next page on the "All" forum page it brings me to the second page of another forum... Now it brings me to the "MAXMSP" forum page, before it was to the "BETA" forum page
    • May 13 2013 | 3:22 pm
      From inside the All tab clicking to move to second page bumps me into the MAXMSP tab instead of the second page of All.
      Firefox 20.
      OS 10.6.8
    • May 13 2013 | 3:42 pm
      Thanks @Guib and @Rick -- noted earlier in the thread, we'll fix ASAP.
    • May 13 2013 | 6:07 pm
      Hi all! Thanks for all the feedback!
      So far:
      • @DTR, we've updated the issues with Firefox. Please check again and let me know if you are still having trouble with the Forums front page and if you are still missing the post dates and links.
      • We've bumped up the number of topics/replies per page to reduce the amount of pages.
      • Logging in should now redirect you back to the previous page, not the homepage.
      I'll be making more adjustments throughout. Thanks for everyone's input and patience!
    • May 13 2013 | 7:13 pm
      Hi @Andro, I see your topic when I go to "All." Here's a screenshot. Your topic is highlighted yellow:
      Are you seeing something different?
    • May 14 2013 | 12:00 pm
      I... honestly can't remember if this existed before or not, but it'd be nice if I'm browsing the 'All' tab to tell what posts are coming from what subforum.  A column with 'forum' as the title would be great.
    • May 14 2013 | 12:01 pm
      What happened to the favourites ? I used this a lot instead of bookmarks in my browser...
    • May 14 2013 | 12:16 pm
      One unfortunate change is you can't see attachments unless your logged in. That diminishes the google-ability of the forum in terms of finding examples of stuff.
      Also it's not obvious where to log in. At the bottom of the page it says "you must be logged in to reply" but nothing is a link there. The login button is tiny, and at the very very top/right of the page (as far as physically possible from the message telling you to log in).
    • May 14 2013 | 1:49 pm
      @mushoo we'll consider that.
      @stephane-morisse favourites show up on your profile page, but you're right, i don't think there's currently an easy way to add a topic to the list. we'll make that happen.
      @rodrigo good analysis. thanks.
    • May 14 2013 | 5:03 pm
    • May 15 2013 | 1:12 am
      Hi. On the top right hand corner of the page, you should now be able to mark topics as favourites or subscribe/bookmark them.
    • May 15 2013 | 1:51 am
      @Rodrido, there should now be a link to log in at the bottom of the page.
    • May 15 2013 | 10:19 am
      Unordered list formatting
      don't work.
      Does
      ordered list work better?
    • May 15 2013 | 10:44 am
      No it doesn"t!
    • May 15 2013 | 11:09 am
      An url doesn't open in another window/frame even if the option is checked (Safari 5.1.9).
      And align center doesn't work neither.
    • May 15 2013 | 12:10 pm
      re : favorites - it's odd, because you can see someone else's favorites/started/followed topics by clicking his name, but not yours by clicking your name at the top of the page. But, you can see yours indeed by clicking your name in a message you posted !
    • May 15 2013 | 4:42 pm
      @Patrick, you should now be able to add ordered and unordered lists to your posts. The links should also now open in new windows as well.
    • May 15 2013 | 4:43 pm
      I miss being able to click my login name and seeing the threads I started or contributed to - its the first thing I check normally.
    • May 15 2013 | 4:51 pm
      @vichug:
      re : favorites – it’s odd, because you can see someone else’s favorites/started/followed topics by clicking his name, but not yours by clicking your name at the top of the page. But, you can see yours indeed by clicking your name in a message you posted !
      Do you mean clicking your name on the login section in the header? We also have a few more updates to the header soon, so I'll definitely put that in the list of things to consider.
      @basvlk
      I miss being able to click my login name and seeing the threads I started or contributed to – its the first thing I check normally.
      Sounds like the same feedback as @vichug. Is this right?
    • May 15 2013 | 7:46 pm
      ...my avatar looks well-cool now :¬)
    • May 15 2013 | 9:45 pm
      Forum search is broken for me in Chrome but not Firefox - by that I mean that in firefox I see a search box, but in Chrome I see a message saying "loading" that is never replaced by an actual search box.OS X Mountain Lion 10.8.3, Chrome 27.0.1453.81 beta, Firefox 15.0.1,
      Screenshots of each behaviour are attached.
    • May 16 2013 | 12:17 am
      Personally, I believe there is excessive use of whitespace. That combined with a generous-sized font and fixed width layout makes for excessive scrolling, paging, and clicking.
      On my 1920x1080 screen... Chrome browser on Windows 7... when a thread is opened...
      • about 930px is fixed width used by messages in the center; leaving 1000px (more than half) of the screen unused/white
      • 51 px is likely too generous between the bottom of the date stamp and the top of the first line of next reply. There already exists a horizontal rule, extra whitespace is not needed
      • 116 px between the right of the avatar and the left of the text is far too excessive
      • There is 75 white usused pixels between the top nav (products, community, supports, shop) and the breadcrumbs (forms * misc). Visually distracting and also excessive whitespace
      • The breadcrums are not sized appropriately in relation to the size of the other text on the page. I recommend they be same or larger font as top nav and likely at least as large as the default text font size of messages yet
      • bookmark and heart at top left are positioned oddly. Yes they are left in your dov container, but there is nothing else left and they look out of place.
      • rollover of bookmark and heart are unrecognizable. Seems a bug.
      • The size of the (submit reply) button is excessive. Its 50% the width of the typing box. Waaay crazy big. Migth be nice to align it vertically with something. Or align the text to its right with itself.
      • I like the clearer instructions and usage of the tags allowed. Might be nice to link to a "how to" in the wiki for those not familiar with usage.
      • I like the idea of the blue attachment section. I recommend you not show the (add another file) button until they have first added a 1st file using the existing (choose file) button
      Additionally in the main list of threads...
      • Forum Guidelines at the top is misplaced top-aligned to the Welcome text and right aligned with no space form the text
      • search box is floating all alone aligned with no one
      • Where can I see all my posts? I can no longer click on my name top right to see the list. I miss that.
    • May 16 2013 | 12:19 am
      After just posting, I also see that the CSS is causing excessive whitespace between unordered lists and the previous/next paragraph. This I highly suggest be condensed.
    • May 16 2013 | 1:21 am
      about 930px is fixed width used by messages in the center; leaving 1000px (more than half) of the screen unused/white
      I'm OK with this.  Would you prefer that forum post body text wrap only at the edge of your 1920 pixel display?  Eyes don't easily find the 'next' line of text from that distance.
      bookmark and heart at top left are positioned oddly. Yes they are left in your dov container, but there is nothing else left and they look out of place.
      They're positioned directly underneath the path-to-post stuff.  That said, that stuff looks very out of place too. I'd suggest a line underneath them, something to draw your eye over to them. Or - a navbar of the main forum pages at the top of forum posts.  I think you've been calling them breadcrumbs, and I think the navbar I mentioned used to be present between the breadcrumbs and the site nav in the old forum.
      116 px between the right of the avatar and the left of the text is far too excessive
      Agreed!
      Also, I'll add one more gripe - I can't seem to find a way to 'preview' a forum post. So, uh, I have no idea if this post will look as I intended it to.
    • May 16 2013 | 1:35 am
      Back by popular demand:
      You can now access your favourite posts and subscriptions by clicking on your name on the top right hand corner.
    • May 16 2013 | 8:16 am
      Just a few observations
      When browsing at maximum width the Gravatar image icons are displayed with about 306 x 306 px. The originals have 100  x 100 px. I'd prefer smaller images at a maximum of about 200 x 200 px. This would reduce whitespace with short posts and make the image look better, as they are way too much interpolated at this size.
      I think the quotations, especially when posted by staff members, are overdone with
      a) indenting with a bar on the left b) bold font c) white background
      Maybe just choose one. I’d recommend indenting and maybe also italic, but not bold as the quotation becomes more important than the reply.
      Seems like no one else gets confused by the large font size in the forum post thread listings like i do. At least i would recommend to use as few as possible different fonts and sizes.
      In general it would be great if the design of the website had a more strict (but still fluid) grid layout. I overlayed red lines at the many different vertical positions of elements on the frontpage.
      Thanks for considering.
    • May 16 2013 | 8:24 am
      @ginger - woo! great.
      Seems like no one else gets confused by the large font size in the forum post thread listings like i do. At least i would recommend to use as few as possible different fonts and sizes.
      @Karl Kliem - no, I agree with you about the 14 pt font size on the thread overview... (and also the weird vertical spacing on the front page)
      There's always Stylebot, I suppose, if it's only us two.
    • May 16 2013 | 8:30 am
      @parkingsun -- I love this stylebot thing.
    • May 16 2013 | 12:11 pm
      @ginger yes it is the same :-)
    • May 16 2013 | 2:05 pm
      (Correct thread now): It (the new forum software) seems to have limited or stopped the flood of spam each (EDT) morning… :)…he said hopefully….
    • May 16 2013 | 2:16 pm
      just unsubscribing
    • May 16 2013 | 2:58 pm
      Hey @parkingsun, is the search function still not loading for you? Do let me know. Thanks.
    • May 16 2013 | 3:07 pm
      Re: styling suggestions
      Thanks for all the thoughts and feedback. There is a plan to roll out more refreshes in the different parts of the site, so we'll put all of these into consideration.
      If it counts for anything, it would be awesome to get more feedback about how you guys are currently using the site, and how you are interacting with the content.
      Are certain parts of the site more difficult to access?
      Is there a type of routine you go through while checking the forums? How can we make this process easier for you?
      These will then be more helpful in how we decide things like placement, how big fonts should be, and other spacing/structure issues. Qualitative info is always best.
      @Karl @parkingsun, can you let me know why the front page listings are confusing at that font size?
      @Charles, shh. The spambots might hear you. :)
    • May 16 2013 | 4:23 pm
      Thanks @ginger - no, I fixed it in the end - turns out my Ghostery settings were too aggressive.
      re: front page. Not "confusing" so much as "jarring". The font is 18px, which is a size not used anywhere else that i could see. So the text is suddenly randomly bigger than the text of the posts themselves - which are presumably not too small because otherwise we couldn't read those, right? Also it means the page has to be pretty wide to fit all the headings in. More generally, there are enough different font sizes, capitalisation conventions, different amounts of spacing around headings, and font-weights around the front pages and inner pages of the forums that the site, despite all the white space, feels "busy" to me. YMMV, of course.
    • May 16 2013 | 6:07 pm
      Hi Ginger,
      the thing that distracts me the most is indeed the font size of the topic column. It should be smaller for better readability. It seems like the tracking is too small for the large font as well. (The relation of the letter width to the distance between each letter). And, as Parkingsun described, there are just too many font variations. Different fonts, font sizes, font colors, some upper-case, some normal. Some left aligned, some right aligned. Voices and posts i would align right i guess.
      Reduce complexity and assign relevance to the remaining parts. Every distinction that has no relevance distracts somehow. I would try to use the same font, font weight and size for the most part. And just use different colors for links, hover and visited links. The alternating background colors in the listing are very good for readability i think.
    • May 17 2013 | 10:27 am
      Hi , would be practical in sense of UE and ergonomy to place the link FORUMS e.g. here: FORUMS>MISC also on the down of a topic-page, to avoid to have to re-scroll on top again.
      Best, Helmuth
    • May 17 2013 | 11:50 am
      In using the system a bit more, I have a few more pieces of feedback
      • How can I report spam? The "this is spam" link is gone.
      • Having the date of a post at the bottom of the post reply confuses me. I believe the date should be at the top of a reply like all other frequently used tools like email systems, facebook, google plus. Having it at the bottom causes cognitive dissonance for needed to relearn, remember to switch between all the common communication tools, as well as confusing does the date go with the post above (even though there is a large amount of whitespace separate it from that post) or under (in which it is closer to)
      • On the main post listing page, top column headers, I do not prefer "voices". I get that someone wants to create a more warm fuzzy "we all have voice" feeling...however...its more relearning and I doubt in the end will really help much. When we write an email or facebook message, we have "to, cc, bcc" not "voices". Additionally, the column headers should match intention. Currently, is listed "voices" yet the 3rd column lists "last poster". While I don't suggest you continue "voices", if you were, then I think it should read "last voice"
      • I have always been curious on how a post gets moved into one of the topic groups like "gen" "dev" or "misc". I usually apply tags to my posts but those tags don't seem to directly related to the groupings. This, while not causing me distress, has puzzled me.
      • A cool to heave feature might be to provide some hover/preview functionality in the lists of posts page. Perhaps, if you were to mouse over a post, then the title of that link (techy talk) could be several lines of the original or last post on that topic. It -maybe- can help us more quickly look through posts for those of interest of ones in which we want to contribute.
      • I'm not a fan of all caps. Isn't there a good amount of research showing our eyes/minds (for those using greco-roman character sets) perfer the upper/lower mix? If so, I would prefer the "last poster" column to not be all caps for easier reading/scanning.
      • In the forums, top right-ish, enter a search. click search to get results. Now at the top are two search boxes at the top right. One is probably enough. ;-)
      • In the main posts list, I greatly prefer the attachment-clip to be to the right of the title. Putting it on the left makes for difficult scanning of the topic titles. Also, the visual weight of the graphic is overwhelming compared to the light thin nature of the font being used
      • In several forum/help/customer support systems, I have seen the system automatically show previous topics/FAQs after a person types the title or post text. I could imagine something like that here to help people find there answers immediately + reduce redundant posts.
    • May 17 2013 | 1:05 pm
      As I am clicking (accidentially) on the favorite and bookmark icons at the top, it strikes me that the current distinction/idea is a little odd to me.
      First, the icon for subscription doesn't work for me. The icon, to me, is a bookmark (or an award, prize, or medal). And cognitively, the bookmark implies only that...not a subscription. Therefore, the two icons at the top represent the same idea to me and require me to think about the difference between a bookmark and a heart. Which is nonsense. So then I have to think deeper and that's too much thinking. I suggest a better icons be created to represent a subscription.
      It seems, the bookmark (aka subscription) is a way for the forum system to notify me when someone posts on a topic.
      The favorite (heart) is a way for the system to keep in a list topics that I choose and can access them in my profile settings.
      Here's the oddity. I can not think of a real-world situation where I have a topic that is NOT a favorite yet *I DO* subscribe to it. For me, the important thing is that it is a favorite. Then, there is a subset of favorites to which I subscribe. Consider in the future...I want to stop receiving notifications for a post yet I want to keep it as a favorite. I have to remember to do the switchover...and then do a lot of clicking to switch the post from one to the other.
      Consider how Microsoft's MSDN forums does it. They keep a list of threads in which I've posted. They don't have favorites. However, for the posts in which I've participated, they have the choice for me to be "alerted" on that post. They have a ringing bell to represent the alert. I could image a similar metaphor.
      I like the distinction of favorites. I like that my profile also lists all the posts in which I've participated. I suggest that the bookmark/subscription be changed to be something like an alert. Then I can be alerted on posts which I have marked as favorites -or- posts I haven't.
    • May 17 2013 | 1:39 pm
      The firefox display issues seem to be fixed indeed.
      Another thing: reply notifications are enabled by default for all my new posts. I'd like that off. Really don't need to be notified about all the topics I post in. Default on for my own new topics makes sense though.
      I also didn't see where you can unsubscribe from a topic. (edit: seems that works through editing a post)
    • May 17 2013 | 3:12 pm
      @diablodale, thanks for all the great feedback. I agree with a lot of it.
      @dtr, thanks for the suggestion. You can unsubscribe from a topic at the top, the icon that currently looks like a little bookmark (but may change to a bell based on the good suggestion of diablodale.)
    • May 17 2013 | 3:24 pm
      I think I see the icon but I can't click it. My cursor doesn't change into the link graphic and nothing happens when clicked. Seems my browser doesn't see the link.
      FF 20.0 on OSX 10.7.5 this time.
    • May 17 2013 | 11:10 pm
      Found an issue. When you copy compressed from Max and then paste it into a message, the new board software isn't dealing with the encasing 
       well. It is just leaving it as literal plain text and within it dong the nitfy clicking oicon thing.
    • May 17 2013 | 11:12 pm
      Also, that link I just pasted directly above in the reply...the forum didn't change it to be a link. Must we do that manually from now on? I hope not.
    • May 18 2013 | 12:03 am
      Hey dudes
      You'll notice an update of the site. Thanks again for the great feedback. We've tried our best to address everyone's concerns, especially suggestions and ideas regarding the forum.
      As many of you know, the C'74 site's been around for a while, and of course with that comes a lot of updating older code, adapting to new frameworks and kicking tires along the way. There will always be lots of details to consider, and I appreciate everyone's patience (and enthusiasm!) as we iron these out.
      Quick overview:
      • Max Patcher code: this is a known bug and happens when the patch is pasted via the Visual editor. When the patch is pasted via the Text editor, the
       and  tags are stripped.
      • Subscription notifications are now represented by a bell instead of the vague bookmark/prize/lizard tongue shape.
      • Dates for posts now shown above the content, not below.
      • Adjustments on type size and spacing throughout the site.
      • Firefox issue of users not being able to click on the topic icons (Subscribe/Favorite) now fixed. If you are subscribed to the topic, the bell should be a filled in shape. If not, it shows an outline. Same with the heart.
      • Added breadcrumbs/links to the bottom of the topic pages for easier navigation back to forums.
      • Search results page should only now show one search box.
    • May 18 2013 | 12:12 am
      @ginger Also, you are now MC Hammerhead Shark.
    • May 18 2013 | 1:25 am
      @mushoo knows what's up.
    • May 18 2013 | 5:19 am
      not sure if this is forum related, but it's website-related:
      The new navigation menu on top - the links are only highlighted if I point my cursor directly on the words - however, once the word is highlighted, the whole box of that word remains highlighted.
      would make much more sense if the whole box was a link?
      On Chrome 26, MacOSX 16.8.
    • May 18 2013 | 5:24 am
      Any ETA for the return of RSS feeds?
    • May 18 2013 | 8:53 am
      I like the new minimalist layout and menu bar on the website. And i think it was a good idea to put the forum link to the top hierarchy level.
      Please check the website on the iPhone now. The menu takes half of the screen.
      It would be nice to have dropdown menus again, as the website is not the fastest loading and this way one could get quicker to the next hierarchy level.
      Thanks for changing the font size to 15 px in the forum thread listing. It looks much better to me. (But don’t forget to change the font size of the voices and posts columns as well)
      It took a while until i found out about the C74 blog. I always thought it deserved a more prominent place, but i can’t tell where that would be.
      Thanks for the quick implementations of suggestions overall.
    • May 18 2013 | 8:57 am
      RSS is working for me (for forums themselves, at least), although I don't know if the feed titles have been fixed.
    • May 18 2013 | 12:04 pm
      It seems I've lost 2 years of great favourite threads :(((((((( Is there a way to recover them ? please please please ?
      edit : found them if I click on my name next to the post but this is not reflected if I click on 'Hi, my name' in the upper menu bar. Hence my confusion. Two years of roaming on the forum are back !
    • May 18 2013 | 1:54 pm
      I'm having real problems unsubscribing from email updates: it's unclear in the interface. I suspect the tickbox below should unsubscribe me ("   NOTIFICATIONS? ") but I"m sure it doesnt actually do anything unless you subsequentlly.... .... ... submit a reply? go to a different page?
      it would be great if the email notifications themselves had a clear instruction on how to unsubscribe: right now it just says
      "You are receiving this email because you subscribed to a forum topic. Login and visit the topic to unsubscribe from these emails."
      But when you log in it is not clear where to go to unsubscribe. I've never had email updates before, I don't really want them either but I've been getting a lot since the forum update.
      apologies if this has been posted already - I did not go through this thread before posting this
    • May 18 2013 | 3:42 pm
      thanks for the feedback everyone!
      @laonikoss yes. @chrismuir still working on redirecting old RSS links, but the new RSS links are working well. suggest you migrate to those if it's not too difficult to do with your reader. (not sure how many different feeds you're subscribed to.) @stephanemorisse when i click on your name to go to your profile i can see a lot of favorites. are those what you mean? or do you mean something else? @basvlk good suggestion. clicking the bell icon at the top of the topic should unsubscribe you.
    • May 18 2013 | 6:47 pm
      @Karl, that screenshot looks buggy to me. I've made some adjustments to the mobile nav again. The nav should just be a bar up top, with a dropdown option.
      Should look like this:
      Let me know if that is still not showing for you.
      Also, the voices and posts should be the same font size as the topic title. Are you seeing something different as well?
    • May 18 2013 | 6:51 pm
      OK, I've changed my RSS url, and the new one seems to work fine,
    • May 19 2013 | 10:49 pm
      Hi, apologies if this has already been mentioned somewhere in this thread, but if you have a stupidly long username with no gaps in it, the text overreaches the grey box under the user pic, causing ugliness.
      <<<< Look!
    • May 19 2013 | 10:58 pm
      ...also, I've noticed that if you hover the cursor over the user name, some - not all - reveal the associated email address in the bottom left hand corner of the screen. "cycling74.com/forums/users/somebodyhotmailcouk"
      Seems like a bug
    • May 20 2013 | 2:23 pm
      @goodparleyandorfing the transformed email address you see there is your username. It appears that some % of people have a username that's derived from their email address. Have a look through this thread and you'll see that not everybody is like this.
      Unfortunately changing usernames is not something that is possible for you to do yourself, but we can change it for you.
    • May 20 2013 | 3:34 pm
      @Ben
      could you clarify which bell means "unsubscribed"? The hollow or the filled?
      Ta ta
      Brendan
    • May 20 2013 | 3:50 pm
      hollow
    • May 20 2013 | 3:52 pm
      and f*ck... by replying i subscribed myself again. defaulting to notification's a real pita!
    • May 20 2013 | 6:54 pm
      TMenu bar is a disaster ubder Android ICS. Avatar alignnent umpinges on text vox.
      cant see my text either
    • May 20 2013 | 6:57 pm
      Hey @noob_meister, can you post a screenshot? Thanks.
    • May 20 2013 | 7:32 pm
      Hi Ginger
      Curiouser and curiouser. On my smartphone, when I access the forum by clicking the post link in the related email notification, the web layout behaves itself: the forum menu bar appears as a dropdown menu and everything seems fine. If I browse to the forum via DuckDuckGo, the layout is banjanxed (a technical term in web-design and html, it means "fubar"). A screenshot would be tricky - unless there's an Android screenshot app. I'm not really that dependent on my Android browser anyway......
      Brendan
    • May 20 2013 | 8:15 pm
      The toolbox icon isn't clickable for me (as in, under the user avatar/name). Actually none of those icons are clickable for me.
    • May 22 2013 | 12:10 am
      @Rodrigo, that's fixed now. Thanks.
      @Brendan, interesting. I looked into DuckDuckGo. Might be something to do with their customizable browser options.
    • May 22 2013 | 8:20 am
      The spambots have found us.
      Can we get a "report" button? I'd prefer a "deliver me the head of the person responsible for this garbage" button, but...
    • May 22 2013 | 1:34 pm
      @ben and @ginger, good work on all this!
      This may have already been answered, and I may have just missed it in the previous 88 posts to this thread: How can I see "subscribed topics" (aka "replied to" threads) that date from before this latest batch of forum updates?
      Also, FWIW, page changes still take a long time (ca. 10 seconds) for me, using Chrome 26 on Mac OS 10.7.5.
    • May 22 2013 | 1:44 pm
      Painfully slow response times and I guess this also explains why I haven't seen any RSS entries recently
    • May 22 2013 | 2:00 pm
      @Peter thanks for the spam report. We're working on getting the spam report button back asap.
      @Christopher I believe subscribed-to topics from the previous forum software were marked as "favorites", but when I click on your profile I see that no favorites came through... puzzling. Maybe I'm wrong and there's still a whole category of meta-data left to import. Let me investigate.
      @dhjdhjdhj RSS feed links have changed, redirects not yet in place. Coming, although I understand that many reader softwares won't follow redirects, so you may just want to update your feed links.
      Finally, yes it's too slow! Sadly didn't realize this in testing because the database is under much less strain on our test server. Working to make it faster.
    • May 24 2013 | 2:40 am
      One other cosmetic thing I notice: next to 'logout' at the top of the page, the username - mine, at least - overreaches the allocated space. It is a similar issue to the one I mentioned earlier..
    • May 24 2013 | 11:13 am
      Apart  from the slow speed (any insights into that yet?) I find the fact that almost every RSS entry starts with "Reply-To" very annoying.
      Sorry for complaining but to me, this new upgrade feels like a serious step backwards.
    • May 24 2013 | 11:59 pm
      There is now a spam reporting link installed. To mark a post as spam, simply click the "SPAM" link on the bottom right corner and it will be immediately removed from the thread and reported to admins.
    • May 25 2013 | 12:01 am
      Hey @goodparleyandorfing, I am currently doing adjustments to the header. I've made a quick change that will fit more characters up there, but I'm definitely working on making everyone's username look awesome up there. Thanks.
    • May 27 2013 | 12:02 pm
      Hey,
      the SPAM button is really problematic for me : you just see it at the right bottom of a post, yet you can click it anywhere in the width of the reading area, and i made disappear two non-spam posts i was reading here : https://cycling74.com/forums/jit-mgraphics-alpha-drawing-on-transparent-background/ (there was also one spam post) because i sometime click everywhere where there is no button, and it turns out the button is active where i thought it would not be. Also, i got a message saying something like "ERROR : you are not allowed to perform this action" - yet the message had indeed disappeared , i find no way to undo this. The previous behaviour had a confirm box with a "reason for spam reporting" which was better, but maybe there should be a confirm button - which would be not working at the moment ?
    • May 27 2013 | 1:46 pm
      Thanks for the feedback @vichug - working on it.
    • May 27 2013 | 4:55 pm
      currently the form almost freezes my browser. on heavy load the order of posts seem to get scrumbled.
      and i just ran into the html versus comparison operators trap: https://cycling74.com/forums/cube-root-of-negative-number-is-nan
      last but not least ... thanks for bringing /pluggo back to url and search.
    • May 27 2013 | 8:55 pm
      Hi,
      first of all thank you for your update efforts!
      And thanks for integrating the forumlink on the bottom of the topic page.
      another (in my sense) elegant feature would be a link on the top right of a topic page to jump immediatly down to the last entry.  If I follow a topic, like this one (we upgraded the forum software), I'm interested on the latest entries (ok, I could subscribe, but not wanting to subscribe every interesting topic...), so it would be a cool UE to jump directly to the latest (and not to have to scroll down like in the actual version); furthermore, when I log in then, actually I am placed back on top again, meaning I have to scroll down once more...
      Best ,
      Helmuth
    • May 27 2013 | 9:14 pm
      Hi Helmuth,
      We discussed that idea. Myself I prefer to use keyboard shortcuts to quickly navigate to the bottom of a page. On mac use fn + right arrow. On PC I think it's Ctrl + Page down.
    • May 28 2013 | 5:11 am
      Hey Helmuth,
      Another way (if you are coming from the forum's front page) is to click on the "freshness" link on the far right hand side of the topic.