Max 5 Lion Compatibility

Jul 22, 2011 at 7:10pm

Max 5 Lion Compatibility

Hi Folks,

We are aware of an issue with Max5 and some sound cards on Macintosh under OS X 10.7, including built in audio. The sound from inputs appears bizarrely distorted and will render the audio in your patch unusable.

We are currently working on the issue in engineering. Expect the fix for the Max 5.1.9 update, or possibly an incremental download before 5.1.9 ships.

If you rely on your Mac’s built in audio for sound we recommend you do NOT upgrade to Lion at this point.

Cheers

Andrew

#58150
Jul 26, 2011 at 4:35am

Hi
Apparently it is not just Lion that has issues . . .
10.6.8 updates to prepare for Lion are doing bad things to various audio devices . . .
I am experiencing bizarre distorted echo modulation degradation all of a sudden . . .
Hope this helps some people . . .
MM

#208809
Jul 26, 2011 at 5:02pm

Here’s an alternative ad_coreaudio driver. Please try it out and let us know if it works any better.

Cheers

Andrew

#208810
Jul 27, 2011 at 1:11am

Hi, Andrew!
This alternative ad_coreaudio driver worked for me. Thanks!
Daniel Puig

_ _ _

MacBook Pro 15″, 2.66 GHz Intel Core i7, MacOS 10.7 (Lion)

#208811
Jul 28, 2011 at 4:40pm

My suckah has completely broke since upgrading to Lion. It used to be spotty before because of some bug involving the graphics card I think. I’ve went back and added that Lion breaks it to the previous forum, but I figured it was also worth a mention here.

Link to original post: http://cycling74.com/forums/topic.php?id=31841

#208812
Jul 28, 2011 at 4:47pm

Also, a question relating to Lion. When I open up Max now, it opens up whatever was open before. If I open a patch, quit Max, then open the same patch again, when Max opens, the patch is open twice.

And then it’s stuck, I can close both the patches, then quit Max. But when I just open Max, they both open up again. Is there a way Max can not do this? My patch breaks if two versions are opened simultaneously due to messaging as well as trying to use the webcam.

#208813
Jul 28, 2011 at 8:17pm

Just found the option to disable the restoring feature for ALL apps (In System Prefs>General), perhaps Max could get some sort of personal preference in 5.1.9?

#208814
Jul 29, 2011 at 12:57am

If you Shift+Click on the Max Icon in your dock, it will load Max without loading any of the previously opened patches. This works for all apps on lion.

#208815
Jul 29, 2011 at 1:14am

Clearpicts and deletepict messages to jit.lcd are no longer working in Lion for me. I can read & draw perfectly, but can’t clear or delete.

If you open the jit.lcd help file (jit.lcd.maxhelp), and open the object [p images], you can confirm this behavior. If you look in the apple developer support pages, you can see that quickdraw.h has undergone a number of changes. If you release a compatibility update, I would appreciate this being fixed, as it makes it hard to use LCD with images.

#208816
Jul 29, 2011 at 4:07pm

@mattboch – thanks I can confirm this one.

#208817
Jul 29, 2011 at 4:41pm

ok – Actually this does not seem broken to us.

Iin jit.lcd, you will not see any visual difference by clicking clearpicts or deletepict. It just removes them from the list of possible picts to draw, not what is already drawn.

So the sequence:

readpict schmacks chilis.jpg
deletepict schmacks
clear
drawpict schmacks

Should result in a white screen, not chilis.

Cheers

Andrew

#208818
Jul 29, 2011 at 6:36pm

Has anyone found Jit.desktop to be working in Lion?

#208819
Jul 29, 2011 at 9:21pm

Jit.desktop is busted in Lion in 5.1.8 but it has been fixed for 5.1.9

Thanks

-A

#208820
Aug 3, 2011 at 3:50am

Any ETA for 5.1.9?

#208821
Aug 4, 2011 at 5:18pm

Update: Found out I had lost my Arial font – this has solved the issue. Thanks to the other post I found (GUI Text) for the clue. I am up and running!

Hi all -

I’m a brand new Max user – just upgraded from Max for Live this morning! This seemed like the appropriate thread to ask this question, so apologies if you have to redirect me elsewhere.

Running on a MBP (2011) with Lion and Max 5.1.8, and after updating the Pace authorization system, I’m up and running – BUT – when I open the Max Preferences all of the panes are blank. The grids are there, and the controls (like checkboxes, etc.) show up, but none of the labels are visible.

Is this a Lion compatibility issue, or have I got something else going on?

Any help you can render would be greatly appreciated!

Looking forward to being a positive contributor to the community,

Rob West

#208822
Aug 4, 2011 at 5:42pm

This is probably a font issue. In your empty prefs dialog, look for the font popups by the popup arrows. They are the first popup in the list, and the fourth popup down.

Change them to something that works.

#208823
Aug 25, 2011 at 10:39pm

OK folks,

MaxMSP 5.1.9 is our Mac OS 10.7 aka “Lion” compatible release

Cheers

Andrew

#208824
Aug 26, 2011 at 12:26am

Thanks Andrew (et al)…downloading now!

#208825

You must be logged in to reply to this topic.