Forums > MaxMSP

Max 5 Lion Compatibility

July 22, 2011 | 7:10 pm

Hi Folks,

We are aware of an issue with Max5 and some sound cards on Macintosh under OS X 10.7, including built in audio. The sound from inputs appears bizarrely distorted and will render the audio in your patch unusable.

We are currently working on the issue in engineering. Expect the fix for the Max 5.1.9 update, or possibly an incremental download before 5.1.9 ships.

If you rely on your Mac’s built in audio for sound we recommend you do NOT upgrade to Lion at this point.

Cheers

Andrew


July 26, 2011 | 4:35 am

Hi
Apparently it is not just Lion that has issues . . .
10.6.8 updates to prepare for Lion are doing bad things to various audio devices . . .
I am experiencing bizarre distorted echo modulation degradation all of a sudden . . .
Hope this helps some people . . .
MM


July 26, 2011 | 5:02 pm

Here’s an alternative ad_coreaudio driver. Please try it out and let us know if it works any better.

Cheers

Andrew


July 27, 2011 | 1:11 am

Hi, Andrew!
This alternative ad_coreaudio driver worked for me. Thanks!
Daniel Puig

_ _ _

MacBook Pro 15", 2.66 GHz Intel Core i7, MacOS 10.7 (Lion)


July 28, 2011 | 4:40 pm

My suckah has completely broke since upgrading to Lion. It used to be spotty before because of some bug involving the graphics card I think. I’ve went back and added that Lion breaks it to the previous forum, but I figured it was also worth a mention here.

Link to original post: http://cycling74.com/forums/topic.php?id=31841


July 28, 2011 | 4:47 pm

Also, a question relating to Lion. When I open up Max now, it opens up whatever was open before. If I open a patch, quit Max, then open the same patch again, when Max opens, the patch is open twice.

And then it’s stuck, I can close both the patches, then quit Max. But when I just open Max, they both open up again. Is there a way Max can not do this? My patch breaks if two versions are opened simultaneously due to messaging as well as trying to use the webcam.


July 28, 2011 | 8:17 pm

Just found the option to disable the restoring feature for ALL apps (In System Prefs>General), perhaps Max could get some sort of personal preference in 5.1.9?


July 29, 2011 | 12:57 am

If you Shift+Click on the Max Icon in your dock, it will load Max without loading any of the previously opened patches. This works for all apps on lion.


July 29, 2011 | 1:14 am

Clearpicts and deletepict messages to jit.lcd are no longer working in Lion for me. I can read & draw perfectly, but can’t clear or delete.

If you open the jit.lcd help file (jit.lcd.maxhelp), and open the object [p images], you can confirm this behavior. If you look in the apple developer support pages, you can see that quickdraw.h has undergone a number of changes. If you release a compatibility update, I would appreciate this being fixed, as it makes it hard to use LCD with images.


July 29, 2011 | 4:07 pm

@mattboch – thanks I can confirm this one.


July 29, 2011 | 4:41 pm

ok – Actually this does not seem broken to us.

Iin jit.lcd, you will not see any visual difference by clicking clearpicts or deletepict. It just removes them from the list of possible picts to draw, not what is already drawn.

So the sequence:

readpict schmacks chilis.jpg
deletepict schmacks
clear
drawpict schmacks

Should result in a white screen, not chilis.

Cheers

Andrew


July 29, 2011 | 6:36 pm

Has anyone found Jit.desktop to be working in Lion?


July 29, 2011 | 9:21 pm

Jit.desktop is busted in Lion in 5.1.8 but it has been fixed for 5.1.9

Thanks

-A


August 3, 2011 | 3:50 am

Any ETA for 5.1.9?


August 4, 2011 | 5:18 pm

Update: Found out I had lost my Arial font – this has solved the issue. Thanks to the other post I found (GUI Text) for the clue. I am up and running!

Hi all -

I’m a brand new Max user – just upgraded from Max for Live this morning! This seemed like the appropriate thread to ask this question, so apologies if you have to redirect me elsewhere.

Running on a MBP (2011) with Lion and Max 5.1.8, and after updating the Pace authorization system, I’m up and running – BUT – when I open the Max Preferences all of the panes are blank. The grids are there, and the controls (like checkboxes, etc.) show up, but none of the labels are visible.

Is this a Lion compatibility issue, or have I got something else going on?

Any help you can render would be greatly appreciated!

Looking forward to being a positive contributor to the community,

Rob West


August 4, 2011 | 5:42 pm

This is probably a font issue. In your empty prefs dialog, look for the font popups by the popup arrows. They are the first popup in the list, and the fourth popup down.

Change them to something that works.


August 25, 2011 | 10:39 pm

OK folks,

MaxMSP 5.1.9 is our Mac OS 10.7 aka "Lion" compatible release

Cheers

Andrew


August 26, 2011 | 12:26 am

Thanks Andrew (et al)…downloading now!


Viewing 18 posts - 1 through 18 (of 18 total)