"MaxLua load command 5 unknown cmd field"

May 3, 2011 at 4:08pm

"MaxLua load command 5 unknown cmd field"

Hello,

i have an external (with jitter API) that i compiled fine with 5.1.1 SDK that i can not compiled now with 5.1.7 SDK ; i have this message : “MaxLua load command 5 unknown cmd field” ; i really don’t have any idea of what’s happened ; anybody ?

XCode 2.5 / OS X.4.11

EDIT : to be more precise i get this problem (corresponding for log2.txt) :

“warning can’t open dynamic library: @executable_path/../Frameworks/MaxLua.framework/Versions/A/MaxLua referenced from: /Users/jeantoto/MaxSDK-5.1.7/my_externals/november/../../c74support/msp-includes/JitterAPI.framework/JitterAPI (checking for undefined symbols may be affected) (No such file or directory, errno = 2)”

;-)

Attachments:
  1. log.txt
#56819
May 3, 2011 at 7:29pm

Did you try to remove the MaxLua framework? As Joshua mentioned it shouldn’t be here.

#203629
May 3, 2011 at 7:29pm

Did you try to remove the MaxLua framework? As Joshua mentioned it shouldn’t be here.

#203698
May 4, 2011 at 5:45am

Hello Emmanuel Jourdan,

if i remove MaxLua framework from max-includes :

warning can’t open dynamic library: @executable_path/../Frameworks/MaxLua.framework/Versions/A/MaxLua referenced from: /Users/jeantoto/MaxSDK-5.1.7/my_externals/november/../../c74support/msp-includes/JitterAPI.framework/JitterAPI (checking for undefined symbols may be affected) (No such file or directory, errno = 2)

#203631
May 4, 2011 at 5:45am

Hello Emmanuel Jourdan,

if i remove MaxLua framework from max-includes :

warning can’t open dynamic library: @executable_path/../Frameworks/MaxLua.framework/Versions/A/MaxLua referenced from: /Users/jeantoto/MaxSDK-5.1.7/my_externals/november/../../c74support/msp-includes/JitterAPI.framework/JitterAPI (checking for undefined symbols may be affected) (No such file or directory, errno = 2)

Attachments:
  1. log.txt
#203699
May 4, 2011 at 6:18am

Hello,

so finally i resolved my problem ; i restricted Xcode’s framework search path to SRCROOT max-includes / jit-includes only ; i don’t know why i had msp-includes in the search path ;-)

is it normal to have twice the jitterAPI.framework ; one in jit-includes and one in msp-includes ?

#203632
May 4, 2011 at 6:18am

Hello,

so finally i resolved my problem ; i restricted Xcode’s framework search path to SRCROOT max-includes / jit-includes only ; i don’t know why i had msp-includes in the search path ;-)

is it normal to have twice the jitterAPI.framework ; one in jit-includes and one in msp-includes ?

#203700

You must be logged in to reply to this topic.