Mac 10.9 Mavericks Support

Oct 22, 2013 at 12:11pm

Mac 10.9 Mavericks Support

Max 6 users are advised to NOT update to Mavericks at this stage. We have found a problem with audio which results in crashing when switching audio on. This will be addressed in a forthcoming Max application update which we shall endeavor to release as soon as possible.

At this point, our testing shows that Live 9/Max 6 based MFL is working fine.

If you have any information for us regarding Mac 10.9 support , please email it to

support@cycling74.com

#268778
Oct 22, 2013 at 12:33pm

I’ve been running the GM of mavericks for a while now with Max, let me know if you need help testing specific things !

#268781
Oct 23, 2013 at 9:49am

Is it too much arm-twisting if I ask when? I happened to (stupidly) upgrade without checking the forums first… If it’s gonna take about a week, I will not bother to downgrade since I am so much happier with Mavericks and too keep away for a while from Max will also clean my head a bit (Yes I am a Max addict). But if it seems like it’ll take quite a while, I need to go back to the mountains since I’ve got some projects with a deadline coming in a couple of weeks.

t.

#268910
Oct 23, 2013 at 9:53am

We can’t commit to a release date, because we want to make sure we get this as good as possible for 10.9, but we’re thinking days rather than weeks.

You should be able to get by on 10.9, just don’t try switching audio on and off too fast or changing drivers or DSP settings on the fly.

Cheers

#268912
Oct 23, 2013 at 11:01am

Will Live 8/Max 6.0.8 get/need an update?

#268921
Oct 23, 2013 at 11:24am

We haven’t seen any problems with Max for Live, so Live 8/Max 6.08 should be cool.

Please let us know if you find otherwise

-A

#268927
Oct 23, 2013 at 3:41pm

tempted to jump, reading Andrew’s word :)

#268944
Oct 23, 2013 at 7:12pm

please DO NOT jump. read my words.

#268956
Oct 23, 2013 at 10:18pm

Finally Mavericks has arrived!

#268966
Oct 24, 2013 at 3:45am

Hello,
for me is now impossible to use Max6 in Mac Os X, every time I open the program, It crashes immediately.

#268981
Oct 24, 2013 at 5:38am

What about Max4 and Max5 under X.9? Did somebody try already?

p

#268986
Oct 24, 2013 at 6:32am

Max 5 seems to work just fine in X.9 (no crash when turning audio on :-)

#268990
Oct 24, 2013 at 7:01am

No problems for me, MacBook Pro 13″ 2010

#268996
Oct 24, 2013 at 7:12am

Max 5.1.9 works perfectly fine on Mavericks

#269000
Oct 24, 2013 at 7:47am

@Luis Sanz

Sounds like a prefs problem. If you don’t know how to fix that, please send an email into support with your OS details

Cheers

-A

#269008
Oct 24, 2013 at 9:24am

Just so you know, Under Mavericks, Max crashes when I try to edit a bpatcher.

- Crash with Max 6.1.4 and 6.1.3
- Works fine with 6.1.2

So using MAX 6.1.2 is my solution for now.

#269011
Oct 24, 2013 at 11:12am

How can I get 6.1.2 in the mean time? I don’t see download links for older versions…

#269021
Oct 24, 2013 at 1:14pm

hi , on Max 6.1.4

when i open a patcher a 3d setup

tell me “to open Max you need a Java se 6 runtime”
and ask me if i’d like instal now ?

what do ?

#269034
Oct 24, 2013 at 3:25pm

@Luxi

Install it. It is likely that you are using Jitter.

Cheers

-A

#269045
Oct 24, 2013 at 4:29pm

BTW, if you are experiencing crashes, please email details including crash reports to

support@cycling74.com

Thanks

-A

#269049
Oct 25, 2013 at 12:47pm

just to be specific. for me the case is that I cannot even turn on the audio

#269118
Oct 25, 2013 at 9:49pm

In the Max window at startup: No midi driver folder or default driver?!

#269171
Oct 27, 2013 at 4:05am
#269246
Oct 27, 2013 at 4:06am

jit.gl.hap crash when loading HAP compressed movie

#269247
Oct 27, 2013 at 9:59am
#269267
Oct 28, 2013 at 1:46am

I know 6.1.4 went out some days ago, but I really hope cycling74 updates Max to solve this in a matter of days and doesn’t wait until the release of the next, regular, update.

If we can help testing a beta please let us know.

#269319
Oct 28, 2013 at 3:37am

@YOANN
thanks!!

#269325
Oct 30, 2013 at 3:48am

under 10.8 and 10.9:

[vst~] when receiving “write” msg complains

“write: requires preset name”

instead of opening dialog window

#269569
Oct 30, 2013 at 6:16am

Hi all,

To supplement the previous posts about Java, and if someone encounters the same problems: after (too quickly, I should have red this post first) upgrading to Mavericks, I had two problems:

. Max5 didn’t launch at all, the console gave me:
30/10/2013 13:54:22,858 com.apple.launchd.peruser.503[647]: (com.cycling74.Max.39632[4628]) Exited with code: 97

. Max6 launched, but jitter made it crash, with a similar error message

“Exited with code: 97″ means that the JVM is missing. I had indeed once a fugacious about Max requiring Java and asking me to upgrade, but it did not. Mavericks has a known bug requiring this automatic installation of Java (http://stackoverflow.com/questions/19533528/installing-java-on-osx-10-9-mavericks). You need to install Java manually, but Java 6 (http://support.apple.com/kb/DL1572) as installing only Java 7 seems to be useless for Max.

Now Max5 starts, and Max6 loads Jitter. I have indeed the bug (spinning wheel), if I switch on and off the DAC too quickly, but at the moment I can live with it. Downgrading to Mountain Lion seems to be a real pain, so I prefer to avoid it, and to wait for the next minor update of Max6.

#269586
Oct 31, 2013 at 7:07pm

it seems like it’s gonna take ‘weeks’ though :(

#269809
Nov 3, 2013 at 4:21am

Just updated to Mavericks. Running Max 6.1.2.

Max crashes any time I hold “alt/option” and hover over a selected patch-cord. Crashes before displaying the “+” icon.

Anyone else finding a similar problem?

#269991
Nov 3, 2013 at 7:49am

@JEREMYSTEWART87 yes, this is known and fixed for the next incremental.

#270008
Nov 4, 2013 at 1:47am

Don’t know if it’s related but a friend of mine who just upgraded couldn’t launch a standalone video player I made for him, even after installing max runtime. It seems he gets a “no application to open this” message.

#270074
Nov 4, 2013 at 7:31am

Hi, I’m ready to commit suicide. When will there be an update to get MAX back to life under Mavericks? Thanks.. N

#270090
Nov 4, 2013 at 2:58pm

Hey all,

I’ve also just installed Max on my new Macbook Pro (Retina, late 2013 model) and the jit.grab and jit.qt.grab functions don’t seem to be working (error code 9403).

Is this a known Mavericks bug, or could it be system related?

#270150
Nov 5, 2013 at 9:35am

Please note that we have released Max 6.1.5 which fixes audio-related crashes and hangs on Mac OS 10.9 (Mavericks).

You can download it here:

http://cycling74.com/downloads/

See the forum post for a list of other fixed bugs:

http://cycling74.com/forums/topic/max-6-1-5-released/

Thanks,
-Ben

#270224
Nov 5, 2013 at 3:37pm

@Stephane:

I would not be suprised that your problem with the video player not starting on Mavericks is due to the absence of Java. Ask your friend to double-Check with the OsX Console and see there are any messages that match the one I posted earlier for this topic.

Alexis

#270257
Nov 5, 2013 at 8:54pm

Hi. I just installed 6.1.5 and jit.grab and jit.qt.grab still don’t work:

jit.qt.grab: could not create video channel -9405
jit.qt.grab: error opening device for grab.

This is using Max for Live in Live 9.1 beta.

Also, I don’t know if it’s a Mavericks issue but I just upgraded to a late 2013 Macbook Pro Retina with Nvidia GPU, and Max’s OpenGL Status says version 2.1 and GLSL version 1.20. Doesn’t Mavericks support OpenGL version 4.1? I figured that with the new hardware and OS I could finally try out all the V-Module shaders that require a higher GLSL version.

#270279
Nov 8, 2013 at 1:44am

@Andrew

I hope you’ve receive and read my last sent emails,

what is now the actual status to get proper working with Mavericks?

at this time, I’ve not order yet my next computermachine (MB Pro 13″), because unfortunately some sellers and distributors told to me that the newer models are not equipped with ML 10.8 (and the other point is under the several ultrabooks, none of these machines are equipped with thunderbolt (except the older acer 5 ub?))

let me know, if the signal is set to “green” for Max/Msp 6 and 10.9 or if you have other suggestions

TSt

#270516
Nov 8, 2013 at 2:10am

@CODY GARNER here I am exposing the same issue with jit.qt.grab (and kinect related objects as well)

http://cycling74.com/forums/topic/max-6-1-5-released/

I does not seems a mavericks issue but maxMSP with the late 2013 Retina Macbook pros

#270517
Nov 10, 2013 at 5:33am
#270688
Jan 16, 2014 at 3:22pm

Hey All

I’m running Mavericks and Max 6.1.3 on a 12 month student licence and i’m having the issue with max crashing every time i turn on the audio. Is there currently an update that can fix this and will I need to purchase it again or will the download work with my existing licence?

Thanks

#278413
Jan 16, 2014 at 11:53pm

Try to update to Max 6.1.6, it’s free.

p

#278428
Jan 17, 2014 at 2:26am

Is there a list of known issues with 10.9 using 6.1.6?

I occasionally have max crashing, just editing patches.
(Nothing specific unfortunately – though one did seem to keep reoccurring when editing comment of outlets in inspector)

Crash logs show it’s in juce main thread.
Should I send these reports somewhere?

Feature request: can we please have some kind of auto save/recovery. I’ve lost count of the number of times I’ve lost 15 mins of work due to a crash.

Thanks
Mark
Ps I’ve only just started using max ‘in anger’ , so may be unrelated to 10.9/6.1.6 – though it does seem a little less stable.

#278435
Feb 9, 2014 at 1:01pm

Just thought I’d mention that I have been running Mavericks 10.9.1 with 32-bit Max 6.1.6 on a core i7 MBP with no problems at all. A friend is running a beta version of 32-bit Max 6.1.7 with no problems either… In fact, I have actually noticed general improvements in system performance since changing (faster startup & load times, etc).

ymmv

#280507
Feb 18, 2014 at 1:58am

Mavericks is A okay on my system, I’d dare say it even seems to be running smoother ;-)

#281434

You must be logged in to reply to this topic.