Max 6.1.5 Released

Nov 5, 2013 at 9:30am

Max 6.1.5 Released

Hi all,

We are happy to announce the release of Max 6.1.5. Although there are a few other fixes, the primary focus of this release is for Mac OS 10.9 Mavericks compatibility. This release fixes audio-related crashing and hangs with the new Mac OS.

You can download it here:

http://cycling74.com/downloads/

Thanks,
-Ben

FIXED BUGS:

• Mac OS 10.9 Support: fixes for crashing on audio start/stop
• capture~: ‘write’ message no longer crashes
• genexpr: MRT no longer is being detected as dead code
• gl.window: no longer posts erroneous warnings
• Jitter Gen: gen patcher export naming fix
• kslider: recalls parameter/pattr properly
• Max startup: fixed crashing and improved error checking/reporting when creating temp files
• multislider: fix for hang on set/select
• OpenGL: gl texture memory use improvements
• patching: fix for crash when clicking on patch cord handles
• vst~: ‘get’ message works properly
• waveform~: improved fix for refresh/redraw

#270218
Nov 5, 2013 at 12:35pm

Standing ovation

thanks

#270243
Nov 5, 2013 at 11:32pm

I write just to make sure if it is really 6.1.5? I reported an error with ad_rewire in standalone apps on both mac and windows three weeks ago and looking into bug fixes no solution to this yet?

#270287
Nov 5, 2013 at 11:42pm

The ad_rewire bug is still outstanding. Max 6.15 was primarily released to fix incompatibilities with Mac OS 10.9. We will be looking at the ad_rewire bug and others for future updates.

-Ben

#270292
Nov 6, 2013 at 2:23am

Hi i just got my new macbook 15″.
jit.qt.grab can’t open the i sight
i also tried it with macam and PS3 comera and it open it, but freezes on first frame
before i had 10.9 on an macbook 13″ from 2010, and none of these problems where there.

#270302
Nov 6, 2013 at 2:24am

i had to buy a new computer because of i big project i have to do in a month…
but with no jit.qt.grab…

#270303
Nov 6, 2013 at 3:10am

Hello! I have the same issue with new macbook pro 15″ retina display. MaxMSP can’t open isight (precisely it tells: COULD NOT CREATE VIDEO CHANNEL -9405 and ERROR OPENING DEVICE FOR GRAB). Also, when I tried with a ps3eye (external webcam, with the madam drive) it was “opening” it and freeze the image immediately.

I install quicktime (7 pro and the default one) and java. Also, photoboot and quicktime and imovie apps can open the isight with no problem.

#270305
Nov 6, 2013 at 3:42am

grab works! but just with 64 bits.

#270309
Nov 6, 2013 at 3:54am

confirm, it only works with 64 bits… but I need to use the 32 one..

#270310
Nov 6, 2013 at 6:01am

On my, non-retina MacBook Pro [jit.qt.grab] works fine with Max 6.1.5 in 32 bit mode (in 64 bit mode too).

(
Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2,2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
System: Maverics
)

#270317
Nov 6, 2013 at 6:28am

Yeah I do not think is a maverics problem…

my model specifics:
MacBook Pro Retina 15″, late 2013

Model Identifier : MacBookPro11,3
Processor : 2.3 GHz Intel Core i7
Graphic : NVIDIA GeForce GT 750M 2048 MB
Cache L2 (per Core): 256 KB
Cache L3: 6 MB
Memory : 16 GB 1600 MHz DDR3
Software OS X 10.9

#270320
Nov 6, 2013 at 6:33am

ya it worked too on my 2010 macbook 13″ with 10.9
but not anymore with my new computer:

MacBook Pro
MacBookPro11,3
intel core i7
2.3 GHz
processors n = 1
cores n = 4
cacheL2 = 256 kb
cacheL3 = 6 MB
memory = 16 gb
OS 10.9

#270321
Nov 6, 2013 at 9:36am

yay! gotta say, it seems mavericks manages resources quite a bit better than ML -fresh installed the other day, and after turning off the bells and whistles with onyx, i was pleasantly surprised.

#270334
Nov 6, 2013 at 10:12am

So I did some more tryings, here what I found out so far:

kinect:
jit.freenect with 32bits only camera works (means no depth map possible), same with 64bits (it is also very slow) (help file use 106% of CPU!)
jit.openni with 32 bits works (camera, depth, skeleton) but it is very slow (help file use 106% of CPU!)

synapse we do not have yet, we will try asap

webcams:
isight just opens with 64bits, with 32 does not
ps3eye webcam with 32bits opens but freeze immediately the image, with 64 bits does not read it (probably the madam driver is not supporting the 64)

#270337
Nov 6, 2013 at 11:24am

i think there is a major problem with the new processor…
made some comparisons between old and new macbook (both with 10.9)
running example patch phys.multiple.mesh
macbook 13″ 2010 runs at 55 fps
new macbook 15″ runs at 26 fps

#270342
Nov 6, 2013 at 1:48pm

I still have the same problems with 6.1.5 on Maverick (MacPro 2009):
- It crashes when I turn on the audio
- It crashes if I use Mira.frame object

#270361
Nov 6, 2013 at 1:50pm

Hi MBM,

Please drop a note to support at cycling 74 dot com and we will help you sort this out there.

-Ben

#270362
Nov 6, 2013 at 3:54pm

Thank you very much, Ben, I´ve sent just a while ago.

Best regards.

#270373
Nov 6, 2013 at 9:45pm

(user error)

#270381
Nov 7, 2013 at 8:34am

Yes, exact same problem here, with Max 6.1.5 (32 bit), OSX 10.9 and a brand new retina 15″ MBP –
attempting to open a jit.qt.grab with the eyesight camera gives the errors:

jit.qt.grab: could not create video channel -9405
jit.qt.grab: error opening device for grab.

#270431
Nov 7, 2013 at 11:01am

Hi, is this version fully compatible on an older 10.6.8 OSx? Is there also a new version for PC? I’ve got problems on a PC using a new motherboard with a UEFI Bios…
best regards. italo

#270455
Nov 8, 2013 at 1:37am

@Joseph Hyde yes, still problem unsolved for me. Hope to get answers how to solve it because I try with Processing and there isight opens with no problem! It just does not work (as listed before from my tests) with MaxMSP and PureData

#270515
Nov 13, 2013 at 12:15am

nur 2 Fragen:

ist endlich an die Möglichkeit der private messages gedacht worden, die normalerweise in jedem Forum zur Verfügung steht?

wie lange müssen wir noch warten, bis endlich wieder die Realisierung von vst vsti ermöglicht wird?

merci u. Gr.

#271052
Nov 13, 2013 at 3:22am

ich würde nicht hoffen für vst/vsti (es ist möglich, um code zu exportieren mit gen~ und etwas zu tun mit das). Aber ich frage mich auch über der private messages !
(not so good german, sorry ;) )

#271061
Nov 16, 2013 at 7:25am

Is there any way to downgrade to 6.1.4?
Can’t send OSC messages from Max to iPad/Lemur)
Receiving works, but can’t send :(
(Right after the update)

#271371
Nov 16, 2013 at 1:15pm

I really don’t understand why C74 makes it a matter of guessing, if that new download of 6.1.5. will serve as an updater to 6.1.2. – I’d recommend more clear stating of this to (new) registered users :D However, it works, and flawlessly :) Thank you!

P.S.: OH and i second TST on his request to reenable VST Plugin export. Thank you again.

#271407
Nov 22, 2013 at 1:30pm

I just downloaded the latest version and I see many crashes and dysfunction with OSX 10.9 64 Bits.
Example: with an application RokVid – the application does not detect the camera MacBookPro! + Many crashes (change screen resolution, etc) ….
Thank you to react quickly to correct problems with the use OSX10.9.

#272097
Nov 22, 2013 at 2:02pm

There are some known issues with jit.qt.grab and java with 10.9 Mavericks and Max. We hope to address these issues in the next update.

-Ben

#272105
Nov 28, 2013 at 6:00am

As of Max 6.1.5 reported problem with pattrstorage ram issue is not solved. I’m second on this one. Please let me know if you have a ticket in your system concerning this problem, because other user on this forum reported it as a subject post.

Briefly problem is in interpolating between presets, when you interpolate ram increasing and is not released after a while.

I’m currently testing it with a test patch posted in the subject and experience this problem.

#274019
Nov 29, 2013 at 1:22am

Hello Ruslan
The problem is more serious if you think
that even a simple preset change of pattrstorage causes a small RAM increase!
This increase of RAM it s not so obvious
as in the case of interpolation
but if you have to deal with a big number of parameters
and tweek presets continuously is noticable.
(and ofcourse it depends from how long you run the patcher).

Also Tobias notices in this post that this bug exists also on mac

http://cycling74.com/forums/topic/max-6-1-4-released/

i would be very glad if at least could i know approximatelly
when this bug will be solved as i have reported this issue before 5 months

below i repost a more clear example

<code>

– Pasted Max Patch, click to expand. –

</code>

#274096
Dec 4, 2013 at 5:06am

Downloaded the latest version, and now Max crashes every time I open a help file. Not so very handy, I must admit…

#274680
Dec 4, 2013 at 4:00pm

I gave up on Max quite a while ago, but thought I’d download this latest version to see what’s what…

One oft-requested feature, that was given special mention in the promotion leading up to Max 6′s first release, was improved resampling in [groove~]. This is still completely broken. I’m not impressed. 2 and a half years later and you still haven’t delivered on your promises. People paid for this, damnit. MSP’s bitwise operators are still broken, rendering much of my signal-domain logic completely unusable. These problems were reported long ago yet nothing has been done. Instead the focus is on selling rubbish new iPad apps for an all-new way to control a piece of broken software.

Max 6.1.5 still crashes randomly when doing very basic things (duplicating patch cords, opening help files, turning audio on/off… the list goes on).

Too many new features on top of an ancient code base (pd). Time for a complete rewrite. Until then, Max is just clinique on a pig.

#274759
Dec 4, 2013 at 4:24pm

Hi Chris,

I can confirm that there are still some problems with groove~ resampling that we are aware of.

I cannot see any problems with MSP bitwise operators in Max 6.1.5, can you elaborate?

Also, if you have any specific ways to reproduce the crashing that you mentioned, we would be very interested in hearing about them.

-Ben

#274765
Dec 4, 2013 at 4:32pm

<code>

– Pasted Max Patch, click to expand. –

</code>

Re: Crashing…
Are you serious? Over the years, across at least 5 computers, running Windows XP, Windows 7 (32 & 64 bit), and several different Mac OS’s, I have experienced endless frustrating and unreproducible crashes with every version of Max since 5.

How to make Max crash? Simple, really…

Fire it up. Start patching. Maybe open a help patcher or two along the way. Sure enough, she’ll crash sooner or later.

#274766
Dec 4, 2013 at 4:40pm

I don’t have any problems with the patch you posted, bitor~ is just putting out a 0 signal here.

-Ben

#274768
Dec 4, 2013 at 4:56pm

Tested on OS 10.6.8 and Windows 7 x64 – bitor~ makes a hideous continuous distorted square-like tone at full blast. Nearly blew my monitors.

#274770
Dec 4, 2013 at 5:06pm

Hi Chris,

Could you send a note to support with your system specs and Max’s ‘Support Information’, which you can get by going to Max->About Max->Copy support information to clipboard?

I’ve tried on both OSes and arches with no difference in behavior.

Thanks,
-Ben

#274771
Dec 4, 2013 at 5:38pm

Will do. The problem randomly comes and goes, as well, but it affected two older machines of mine when v6 was new. Given that the noise is periodic, I suspect it’s some sort of denormal-killing square injection code (which shouldn’t belong in a bitwise operator like that anyway) that didn’t get converted to 64 bit.

#274772
Jan 28, 2014 at 9:53pm

I have some weird issues with

I get errors :
jit.qt.grab jit.qt.grab: doesn’t understand “codecquality”
jit.qt.grab: doesn’t understand “getinput”
print: vdevice 0
jit.qt.grab: doesn’t understand “vmode”
jit.qt.grab: doesn’t understand “mode”

But the camera is working. I can not get any settings. I am running Maverick on 2013 Retina 15″

#279410

You must be logged in to reply to this topic.