ag.granular.suite


    The granular suite is a collection of MAX/Msp patches for generalised granular sound processing and microsound composition written using FTM/Gabor libraries (developed at IRCAM) and encapsulated as Jamoma modules.
    Main features include:
    • subsample accurate scheduling,
    • multichannel output (up to 64),
    • granulation of multiple soundfiles at the same time (with interpolation of two sources per grain),
    • parameter randomisation and sequencing,
    • control via OSC,
    • preset management,
    • multiple presets mixing with an interface for live performance
    Its modular architecture makes it possible to easily extend it with new algorithms for grain scheduling and parameter control.
    A short video demonstrating the suite in action:
    A set of video tutorials covering all the features of the software can be found here: http://vimeo.com/channels/205096

    • Jun 18 2012 | 8:36 pm
      This is insane... imagine mapping a joystick on it.
    • Jan 11 2013 | 10:27 am
      Amazing tool. Is there a forum or feedback channel for it somewhere? Trying to track down a bug: position isn't being rescaled when a new source is selected.
    • Jan 11 2013 | 2:39 pm
      hi. Thanks for the feedback, I'd be happy to fix this asap. there is no dedicated forum btw but I get notification about posts here so I guess it should be enough :)
      Could you please explain in what is the problem and describe steps I should follow to replicate it? You can post it here or send me an email directly.
      best
      Adrian
    • Jan 12 2013 | 4:27 am
      fixed and pushed to github. Get the latest version here: https://github.com/adrian-gierakowski/ag.granular.suite/archive/master.zip
    • Feb 23 2013 | 5:50 am
      Hi, I love the look of this but my cant seem to get it to work. When I load sounds nothing happens. Sorry I am a Max noob :-( no wave sows up in the ftm.editor
    • Feb 25 2013 | 8:38 am
      there is a bug in the one on my website and I haven't had time to update it.
    • Feb 25 2013 | 4:38 pm
    • Mar 04 2013 | 2:38 am
      Hey, thanks a million for sharing this Adrian. This is without a doubt one of the most beautiful patches i have ever seen and heard. Unfortunately i can`t use the term "used" as i also have problems with it. When opening in my MAX 5 and following all your steps from the very nice and detailed tutorial video, no audio is playing, there seems to be no audio activity at all in the engine~ section, as also nothing is shown on the meters. the only warning in the max window i get is "jcom.hub: can't find preset 0" but i guess this has nothing to do with it. When opening the patch in MAX 6 Runtime i have the same problem as Ragz13, no wave is displayed in the ftm.editor. It`s really a pity, i`d love to get started an sweeten my lifetime with this patch. Maybe you have any idea what could be the problem? Kind regards, Flo
    • Mar 04 2013 | 8:00 am
      hi Mahakals,
      have you downloaded the version of the patches from github linked in my previous comment? also, which version of Jamoma and FTM have you got installed?
      yes, the “jcom.hub: can’t find preset 0″ error is harmless have you checked for error after trying to load the sounds? are you loading your own samples or the ones used in the tutorials?
      In the case of max 6 runtime, are you sure you have FTM and Jamoma installed in the Max6 application folder? Could you check if there ar any errors displayed in Max window (when you run it in the runtime)? Could you send me a screenshot of the sample manager panel?
      some other things to check\do: turn up green volume dial on the output module. switch max audio on\off switch of the limiter on the output module
      let me know if this helped in any way
      best
      adrian
    • Mar 04 2013 | 4:00 pm
      hi Mahakals,
      have you downloaded the version of the patches from github linked in my previous comment? also, which version of Jamoma and FTM have you got installed?
      yes, the “jcom.hub: can’t find preset 0″ error is harmless have you checked for error after trying to load the sounds? are you loading your own samples or the ones used in the tutorials?
      In the case of max 6 runtime, are you sure you have FTM and Jamoma installed in the Max6 application folder? Could you check if there ar any errors displayed in Max window (when you run it in the runtime)? Could you send me a screenshot of the sample manager panel?
      some other things to checkdo: turn up green volume dial on the output module. switch max audio onoff switch of the limiter on the output module
      let me know if this helped in any way
      best
      adrian
    • Apr 28 2015 | 6:47 pm
      Hello Adrian, i have problems with jcom.ui. I attach a screenshot of the patch. Help!!! Andrea
    • Apr 28 2015 | 6:51 pm
      hello Adrian, i have problem with the jcom.ui (have installed ftm 2.6.0 and jamoma 0.6). I attach the screenshot... Help!
      Andrea
    • Sep 17 2015 | 6:08 pm
      Hi Adrian,
      First of all, this looks amazing!
      I also have a problem using this and I think the difficulty is with using Max 7 and Jamoma 0.6. I understand from the Jamoma website that any modules made in 0.5 need to be updated to work in 0.6. Sadly, I don't know a lot about Jamoma. Do you happen to know how to do this?
      Thanks, Simon
    • May 27 2016 | 7:52 pm
      Does this work for PC?
    • Mar 12 2017 | 3:17 pm
      Works only on OSX.
      Has dependencies.
      Essential information not given above.