aka.wiiremote crashes

    Sep 29 2009 | 5:52 pm
    Mac OS 10.4.11 Max 5.0.8
    Thought I'd post this in case anyone else has the same problem, but aka.wiiremote now crashes Max. Downloaded disis.aka.wiiremote and it seems to work fine.
    Phew! - cheers to Ivica Ico Bukvic for saving my show!

    • Oct 14 2009 | 2:04 am
      Well, I'm unfortunately not having as much luck. After upgrading to Leopard and Max 5.0.8, I'm having more difficulty connecting to [aka.wiiremote] (not that it was always reliable before), but no crashes. It was crashing on 5.0.7, though. I tried out [disis.aka.wiiremote] with high hopes, but it never connects! Strangely, if I have [aka.wiiremote] in my path, then trying to connect to [disis.aka.wiiremote] causes a crash. But if I take [aka.wiiremote] out of the path, then I just sit there with flashing leds when trying to connect. Anyone have similar issues/advice?
    • Nov 03 2009 | 6:26 pm
      I can't get the wii to work again either. I had it working on Max 4 and the old object, but now nothing. Googling seems to suggest my problem meant i needed new batteries (no, tried that) or that i needed to sync, but sync i can not as i only own a wii remote.... My mote shows up in the blootooth menu, but it wont connect. What do you do if you have the four blinking lighs and no connect?
    • Nov 03 2009 | 9:00 pm
      Hello all,
      I did some work on aka.wiiremote this summer (to make ajh.wiiremote I guess):
      There were several things I was working on:
      1 - Much enhanced stability - and more verbose description (so you can tell whether things are working or not).
      I totally revamped the connection process and how it's dealt with, and found the tedious dropped connection issue, which I have worked around, so as far as the end user is concerned it doesn't exist - I'd hate to say 100% reliable connection here (because I know I'll be proved wrong), but pretty damn close.
      The main problem with the old version is that when things don't connect it can leave the wiiremote in a state where it is partially connected, and you have to use the red button inside the case to reset it. But you don't KNOW that, because you can't really tell what's going on.
      2 - No decoding outside the object (the data is internally decoded for buttons etc.)
      3 - WiiMotionPlus Support
      4 - full 10bit accelerometer values (rather than the 8 bit values)
      So. I need it testing - but I'm also not totally done with it yet. I was going to wait till I had more time to get it ready. However, seeing as this has come up. I'm happy for people to test it, as long as they understand it's as is, and other than simple bug fixes I'm not able to work on it right now. I can't remember exactly how I left it, but I think all the aka.wiiremote features still work, but stuff works a bit differently.
      Also, I'm on Tiger here, so I can't address Leopard specific issues easily, but I have a feeling that what I've done so far my eliminate a lot of issues - then again, it might not...
      There's not a help patch yet, but I think I have an example patch which is easy to figure out.
      If you're interested contact me offlist - you can get my address here:
    • Jun 07 2010 | 6:26 pm
      Hello, AlexHarker. Did you finished your re-writing of this damn object?
      I'm also having crashes, not Max crashes but OSX kernel ones. "Need to restart your computer..." I'm using the disis.aka.wiiremote with m4L (latest Max version) in Live 8.1.1 on OSX 5.8. Crashes happen when trying to connect the wiimote to my m4L patch. Sometimes no problem, sometimes crash. Anyone as any information about this problem? Thanks