Compiling HelloWorld Error


    Feb 18 2006 | 5:26 pm
    Hi,
    I'm going back to doing some JAVA now but have moved to a new version
    of Xcode since my last mxj forays. I'm using Xcode 2.2 on 10.4.4.
    When I open the HelloWorld project and hit build, I get the following
    error:
    command .Developer/Private/jam failed with exit code 1
    cd "/Applications/MaxMSP 4.5/java-doc/ide/Xcode/HelloWorld"
    setenv ASCII_OUTPUT_ANNOTATION YES
    setenv ENABLE_APPLE_JAM_EXTENSIONS YES
    setenv ENABLE_APPLE_JAM_OUTPUT_ANNOTATION YES
    setenv GROUP wesleysmith
    setenv NATIVE_ARCH ppc
    setenv USER wesleysmith
    /Developer/Private/jam -d1 -j1
    JAMBASE=/Developer/Makefiles/pbx_jamfiles/ProjectBuilderJamb ase
    JAMFILE=/Applications/MaxMSP
    4.5/java-doc/ide/Xcode/HelloWorld/build/HelloWorld.build/Dev elopment/HelloWorld.build/HelloWorld.jam
    build ACTION=build _DEFAULT_GCC_VERSION=4.0 GCC_VERSION_IDENTIFIER=4_0
    CONFIGURATION=Development BUILD_STYLE=Development
    CPP_HEADERMAP_FILE=/Applications/MaxMSP
    4.5/java-doc/ide/Xcode/HelloWorld/build/HelloWorld.build/Dev elopment/HelloWorld.build/classes.hmap
    SRCROOT=/Applications/MaxMSP 4.5/java-doc/ide/Xcode/HelloWorld
    OBJROOT=/Applications/MaxMSP 4.5/java-doc/ide/Xcode/HelloWorld/build
    SYMROOT=/Applications/MaxMSP 4.5/java-doc/ide/Xcode/HelloWorld/build
    DSTROOT=/tmp/HelloWorld.dst
    Anyone else get this? Solutions?
    thanks,
    wes

    • Feb 18 2006 | 6:50 pm
      hi,
      the HelloWorld project example project that comes with the max-
      package is still using the old Xcode project path structure.
      so, using:
      cp build/Development/classes/*.class "/Library/Application Support/
      Cycling '74/java/classes"
      instead of:
      cp build/classes/*.class "/Library/Application Support/Cycling '74/
      java/classes"
      as a "Run Script" to automatically move your compiled class to the
      cycling folder solved the problem for me.
      you might want to try it and see if it solves you problem.
      bye,
      volker.
    • Feb 18 2006 | 6:56 pm
      Thanks,
      That worked, but now I can't load it in the mxj object. I get these error:
      • error: java.lang.UnsupportedClassVersionError: HelloWorld (Unsupported major.minor version 49.0)
      • error: at java.lang.ClassLoader.defineClass0(Native Method)
      • error: at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
      • error: at com.cycling74.max.MXJClassLoaderImpl.doLoadClass(MXJClassLoa derImpl.java:119)
      • error: at com.cycling74.max.MXJClassLoader.loadClazz(MXJClassLoader.ja va:88)
      • error: Could not load class 'HelloWorld'
      I just changed to JAVA 1.5. Would this be causing problems?
      thanks,
      wese
    • Feb 18 2006 | 7:00 pm
      So, To answer my own question. Yes, that was the problem. I just
      rememered an old thread about changing the JVM preferences in a text
      file somewhere. Will look into that.
      thanks,
      wes