Mxj Win bug ?

    Mar 02 2006 | 12:29 pm

    • Oct 09 2006 | 3:12 pm
      I'm searching for a solution to a similar problem and came across yours.
      We're installing Max/MSP on a group of WinXP machines in a student lab. The college's PC security measures include hiding the C: drive from students' view. This is problematic for a number of things but I've managed to work round most of the problems. One thing I can't do (which seems to relate to your issue) is using mxj.
      The students do have access to another local disk (D:) and I've put a java/classes folder on there. I have set up the config file with a path to the classes folder on the D drive and when the JVM starts up it reports this path in the max window. The mxj class also work perfectly fine. But when I try to 'viewsource' the Max window reports that that the path can't be found BUT the path it reports to be looking for has had the D: replaced with C:
      the max window reports:
      MXJ System CLASSPATH: C:Program FilesCommon FilesCycling '74javalibjode-1.1.2-pre-embedded.jar C:Program FilesCommon FilesCycling '74javalibmax.jar MXJClassloader CLASSPATH: C:Program FilesCommon FilesCycling '74javaclasses D:Extra Program FilesCycling '74javaclasses (mxj) Unable to locate C:Extra Program FilesCycling ' Decompiling with JODE • error: (mxj) Unable to decompile whywhy • error: message: C:Extra Program FilesCycling ' (The system cannot find the path specified)
      I've just tried it on another machine using much simpler paths (i.e. putting a 'classes' folder in the root of my H: drive) still the same problem.
      This seems to be a mxj issue.
      We're on Max 4.5.7 (the problem may be fixed in 4.6.2 although we need Pluggo which isn't updated to work with that yet).
      Can anyone help or confirm this problem?
      Regard, Martin