Forums > Java

Permission denied error=13

Nov 03 2011 | 1:59 am

Trying to compile firsttime class with quickie, from the tutorial. Getting the following error message:
Unexpected Error During Compile:

Cannot run program "/System/Library/Java/JavaVirtualMachines/1.6.0.jdk": error=13, Permission denied

See Max console for stack trace.

Following settings in the compile window:
Source file: /Applications/Max6/Cycling ’74/java/classes/

Compiler command: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk

Build Directory: /Applications/Max6/Cycling ’74/java/classes

Classpath: /Applications/Max6/Cycling ’74/java/lib/jitter.jar:/Applications/Max6/Cycling ’74/java/lib/jode-1.1.2-pre-embedded.jar:/Applications/Max6/Cycling ’74/java/lib/max.jar:/Applications/Max6/Cycling ’74/java/classes/

Running Max 6.0.0, OSX 10.6.8, javac 1.6.0_26

Can anyone help me with how I can set the correct permission setting?

Nov 14 2011 | 12:52 am

Still haven’t figured out how to set the permissions correctly. Anyway, using Eclipse it’s no problem.

Nov 17 2011 | 1:06 pm

On which system are you working? If you are an OsX could be that you have to change the the file’s permission to make it executable.


Nov 17 2011 | 1:14 pm

one way of setting permission on Osx is using the terminal and use the command [sudo] chmod command. The commands are mostly identical with the linux/unix commands.

here is a cheat sheet:

Nov 17 2011 | 1:42 pm

…also on windows maybe you must run max as administrator(vista,windows 7)

Dec 14 2011 | 11:21 am

I’ve tried setting the permission with chmod, still no luck. But when using Eclipse, all is compiling nicely. So no problem really.

Oct 12 2012 | 5:20 am

I’m having exactly the same problem here, and file permissions don’t seem to fix it.

Max 6.0.7; OS X 10.8.2; JDK 1.6.0_29-b11-402

Viewing 7 posts - 1 through 7 (of 7 total)

Forums > Java