Unable to create JVM


    Sep 04 2010 | 3:30 pm
    I wanted to use mxj to parse an XML file... never used java with max before.
    I am on Windows 7 64bit, I have java installed on C:Program Files (x86)Javajdk1.6.0_21 and if I type java or javac on a Command Prompt the command is recognized by the OS.
    Nevertheless Max complains about my JVM:
    mxj: could not find Java 2 Runtime Environment.
    Error loading:
    (mxj) mxj_platform_init failed. Could not initialize the Java Runtime Environment.
    Please check your Java installation. http://java.sun.com
    Unable to create JVM
    Is there anyone with the same problem?

    • Oct 15 2010 | 11:06 am
      hi
      i get the same config and the same problem here... with JRE 1.6_22.
      did you solve it ?
      g
    • Oct 15 2010 | 4:23 pm
      I don't remember exactly how I solved it. I had both JRE and JDK, I had to uninstall/install one or both of them.
      Sorry, but I can't be more precise.
    • Oct 18 2010 | 9:20 am
      i've tried reinstalling java and max with no success...
      i would really appreciate some help from you C74 guys :)
    • Oct 18 2010 | 12:59 pm
      ok here is the thing.
      installing the 32 bits version of jre resolved my problem. it looks like max doesn't care about the 64 bits version...
      is this normal ?
      g
    • Aug 11 2011 | 1:25 am
      I just tried a 64-bit JRE with an standalone Max Application, and I saw the exact same errors as the originator of the forum post. Switching to a 32-bit JRE does solve the problem. Has there been an update since?
    • Dec 05 2012 | 7:02 pm
      For Max 5, you have to install Java runtime 6 x86