[.talktome]: adaptive/dynamic audio prototyping for video games

Hello everyone,

So this is the official demo presentation I showcased tonight in Berklee College of Music, as part of my senior project in Electronic Production and Design. This is a software prototype for a game audio middleware that I built entirely in Max/MSP and is controlled by Unity3D. What lies beyond in the future, is to look into creating a patent out of this prototype, of course, after I improve the source code and implement more transitional techniques and most importantly, user-input. The goal for the future is to create the most user-friendly indie middleware for most game engine platforms that won’t be a burden for the client-side.

The demo game is Unity’s tech demo, AngryBots.

The project files are up for you to download, in a semi-open-source form. It’s still for educational use only, but if somebody wants to do something based on that or think they can improve the tool in its current form, please feel free to drop me an e-mail from my website.

For more info on the project: gameaudiomiddleware.tumblr.com

Thank you!
Yiannis Ioannides


How did this project use Max?

Max was used to built the entire audio-front end of this project, which is the game audio middleware itself.

January 28, 2013 | 10:25 am

hi Yiannis ,
i ‘m trying to unzip the 135M "TalkToMe" file , and get an error from the finder (MacOs 10.7.5) .
saying i don’t have permissions .
i have tried some "get info" and modify to read and write , that sort of things ,
but can’t get it unzipped .
would you say the problem is , for sure , on my CPU , may you check the zip file ?
sorry for the totally uninteresting feedback ,

January 28, 2013 | 4:39 pm

Hi Matthieu,

Hmmmm… That’s interesting… Well, first of all, the zip should be 1.4GB, instead of 135MB, so maybe you didn’t download it properly! But other than that, I tried unzipping it on Lion too, and you’d be pleased to know that it works just fine.

Thank you for the interest!


January 29, 2013 | 1:01 am

ha !
it seems "some" data is just missing !
downloading again …

Viewing 3 posts - 1 through 3 (of 3 total)