-1 midinote message problem


    Feb 03 2010 | 5:12 pm
    I'v been trying to figure this problem out, but I'm stuck. If you send poly~ the midinote message -1 it will not turn off all voices, could someone explain to ,e why this is so?
    I’v made a test patch. I would appreciate any feedback. Thank you.
    main Patch:
    poly patch, save as problem1

    • Feb 04 2010 | 9:01 am
      I think it is a bug in poly allocation. If you send the -1 to several voices it will not set velocity to zero except for the first one.
      Is this a bug or I’m i completely off tracks here?
      This with Chris Muir's poly patch.
      Main patch:
      poly: save as problem4
    • Feb 08 2010 | 2:40 pm
      Why do you assume that -1 should switch off all notes? This is a wild and pretty wrong speculation, instead it will switch on the "-1" note which would be a less wild speculation... The easiest way to switch off all notes, is to send an extra noteoff command to all instances. without the midinote command, either by target 0 or by a separate send/receive pair.
      Stefan
    • Feb 08 2010 | 4:12 pm
      hmmm, I think you misunderstood me. I do not assume that -1 will switch of all notes. How did you conclude that? I'm simply stating that if you send a set of midinotes to the poly, it will not turn off the instance that has received -1, if several. Did you test the patches?
    • Feb 08 2010 | 4:14 pm
      I can see why you thought so, but. my bad english. What I ment was that all the instances that has recived -1 will not be switched off if you send a -1 and note off to poly.
    • Feb 09 2010 | 12:45 pm
      Ok, got it. I can confirm the behavior. Why do you use -1 as note number? I tried all kinds of positive integers without problem...
    • Feb 09 2010 | 11:55 pm
      midinote needs a positive value as a pitch, just like in MIDI.