139809: unknown argument combination

    Jun 28 2013 | 10:38 pm
    Is anyone familiar with this error message? I build and external a while back for someone which worked fine until 6.1 when it started generating this error for one specific method signature: 2 long + 4 float. There is nothing special about this method compared to the others, except for this specific signature.
    I am hoping it rings a bell, since I can't post the source.

    • Jun 29 2013 | 8:26 am
      I don't fully remember but at some point with more than n arguments you might encounter problems. You should update your method to A_GIMME.
    • Jul 03 2013 | 7:14 pm
      I vaguely remember it used to be either 7 or 9. Still, this error would indicate that the behavior of the API has changed around the 6.1 release. It's the only method in my object which uses 7 arguments with proxy inlets. Including the inlet number the method has 7 arguments as its signature.
      I'll update it to A_GIMME then, that's a safe bet.
    • Jul 03 2013 | 7:31 pm
      Frankly, I'm a little surprised that a signature like A_LONG, A_LONG, A_FLOAT, A_FLOAT, A_FLOAT, A_FLOAT, 0 ever worked at all. There has been a longstanding problem—going back to late Max 3 days—with signatures of more than four elements including floats that returned garbage to your new object method. You may have been lucky (floats first? floats last?). In any case, standard advice for any signature with more than four items including floats was to A_GIMME.
    • Jul 03 2013 | 7:35 pm
      I guess I was lucky then. The signature is as you described, floats last. I have several other methods which are *long long float float float* that still seem to work fine > 6.1.
      I'll stick with A_GIMME from now on. Thanks for the advise.