a - inside a umenu becomes a separator line

    Jan 29 2013 | 7:15 pm
    ...which is annoying when working wiht jit.op. I noticed that in my max version, in the jit.op helpfiles, the problem is here and you can't select the - operator from the umenus because they are changed to a separator line. Is it normal ? Any workaround ? max 6.0.8 ; osx 10.6.8

    • Jan 29 2013 | 7:27 pm
      typically one would "escape" such things by doing - instead of - does that work?
    • Jan 30 2013 | 3:08 pm
      i tried several things, none worked :/
    • Jan 30 2013 | 4:28 pm
      Oooh, wonderful ! lesson of the day : if isn't enough, add a to the !
    • Jan 30 2013 | 6:15 pm
      Minus as an indicator for a dividing line has been around since 1984. Nothing new.
      Depending on how many levels of parsing are going on, you may need to add multiple backslashes: when specifying full paths in C via calls on MS-DOS/Windows by passing strings to the OS you may have to write something like C:\\System\\Folder\\File.ext.
      Depending on where the backslashes are, you may find that if you edit and save the file, that you will have to re-escape the escape characters (ie, go back and re-insert the multiple backslashes). This is the real PITA.
    • Jan 30 2013 | 7:39 pm
      MS-DOS whut???
    • Jan 31 2013 | 12:11 am
      indeed, all of the - –— family are resolving as dividerline, thats what i learned when playing around with a resource editor on mac os 7 and it is still true until today. how else should a dividerline be made? it must be one of the symbols on your keyboard :)