ADC noise bug? (sounds like bitcrusher under certain CPU spike-y circumstances)

    Nov 19 2012 | 7:59 pm
    The other day I noticed that after a bit, my ADC would start sounding like it was permanently bitcrushed, but everything else in my patch sounded fine. The CPU got a bit hot (up in the 80% (activity monitor) range). Even if I let my polys go back to being muted and the CPU came down to 40% or so, the bitcrush sound stayed until I restarted Max.
    When speaking to some colleagues today (PA Tremblay and Alex Harker) they commented that they had experienced something similar, and that it was really difficult to pinpoint for them. They suspected it was some kind of bug, but hadn't gotten further than that with it.
    It happened to be about 3 times in a row on the same day, and since my patch can really suck up the CPU I attributed it to that, but they said the experienced it under much lower CPU loads.
    I've pushed Max into broken sound before, but usually all of it goes weird, but in this case it was literally only incoming ADC audio that got jacked. Everything internal sounded/worked fine.
    I'm using the latest Max6 on Mountain Lion running my patch (The Party Van) ( and using a MOTU Microbook II as my interface.
    Anyone experience anything like this?

    • Nov 20 2012 | 11:15 am
      Is it possible the ADC~ is dropping samples? would that account for it? I presume you mess around with the in out buffer size and that it all matches the MOTU? or the sample rate on MAX and the MOTU are out of sync somehow (although that shouldnt be possible right?) I havent had this problem myself I dont think though so just musing on it...
    • Nov 20 2012 | 11:16 am
      That would explain the bitcrushy sound. Everything is fine until things get rough, but again, Harker/Tremblay were able to create the circumstances without overloading the CPU.
      I tried different IO settings (not exhaustively) and it still happened.
    • Nov 20 2012 | 5:25 pm
      I had something similar today, running a big patch with the Scheduler in Audio Interrupt unchecked, might be worth having a toggle about...
    • Nov 20 2012 | 5:59 pm
      I've had the same happen but interrupt generally turns everything into sludge, not just ADC stuff.
      In either case interrupt was off.
    • Nov 20 2012 | 6:00 pm
      Wait, your saying turning it on fixed it?
    • Nov 20 2012 | 6:48 pm
      yes It did but I think our issues probably differ.
    • Apr 02 2013 | 1:11 pm
      I have the problem here too, now on a regular basis, which is quite annoying... Rodrigo I think we made a patch that isolated the problem, do you still have it?
    • Apr 02 2013 | 2:31 pm
      I didnt have anything that isolated the problem, but i did isolate the cause, or rather, a work around.
      It seemed to be caused by cpu spikes specifically. My dirt was 8x oversampled, so it would often happen in conjunction with that being turned on. It's now at 4x oversampled and ive not had the problem happen again.