ajh.wiiremote: unable to load object bundle executable

    Mar 04 2014 | 4:32 pm
    I have some bluetooth troubles vith AJH.wiiremote :
    ajh.wiiremote: unable to load object bundle executable 2014-03-04 17:26:38.433 Max[655:707] Error loading /Applications/Max 6.1/extras_objects/AHarker_Distribution_v1.0/AHarker Externals/Miscellaneous/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote:  dlopen(/Applications/Max 6.1/extras_objects/AHarker_Distribu tion_v1.0/AHarker Externals/Miscellaneous/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote, 262): Symbol not found: _IOBluetoothL2CAPChannelWriteSync Referenced from: /Applications/Max 6.1/extras_objects/AHarker_Distribution_v1.0/AHarker Externals/Miscellaneous/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote Expected in: /System/Library/Frameworks/IOBluetooth.framework/Versions/A/IOBluetooth
    Have I missed something or can't we trust in  this object ??
    ....................... jerome

    • Mar 04 2014 | 8:49 pm
      ajh.remote is not compatible with Max OS 10.8+. OSCulator is the most reliable solution with the Wii.
    • Mar 05 2014 | 12:56 am
      I'm not glad, but am glad to hear someone else has this problem, I was worried that I had deleted a framework (computer has had some harsh crashes lately that has caused a small amount of data loss). I had recently opened up a piece I wrote last year with Wii-Remotes only to find it non-functioning. The thing is, I swear I wrote the piece on a version of OS 10.8... I think the problem has stemmed from an incremental update to 10.8.
      The problem with the OSCulator solution is that it is not free. A before people get up in arms about that comment, I want to point out that I don't mind paying for the software... what I do mind is asking other people who may want to perform my composition written for Wii-Remote to purchase OSCulator. I provide my Max patch as a runtime software for free, the code is available as well, and I am already requiring the performer get access to a Wii-Remote (which can be borrowed free of charge, and were so prevalent at one point that access to them should be easy), but I don't want to require another software to run my piece when that software is not free.
      This seems to be a problem with using the Wii-Remote in Max... every time I find an object I like that works well (originally aka.wiiremote, and then ajh.wiiremote), a Mac OS update prevents its use.
    • Mar 06 2014 | 8:23 am
      Don't know which features of the Wii remote you need, but DFRobot has recently put on the market - as a separate component - the infrared camera used in the remote. Either with a wired or a wireless connection (XBee) you could bypass the Bluetooth connection to the Mac using an Arduino or a Raspberry Pi.
    • Mar 09 2014 | 11:27 pm
      Hey, i wrote an eMail to Alex Harker and he sent me an update for the ajh for Mavericks. Thanx so much Alex....
      Here it is...
      Cheers Peer
    • May 25 2014 | 6:42 pm
      I got the 'Starting search' message but no connection. Does any of you guys have a clue on this? Best!
    • Aug 13 2014 | 12:56 pm
      Hey there
      I'm on Mavericks too - just downloaded these updates - I get a connection - and I can activate the vibrations on the Wiimote via the helpfile patcher - but I can't get any data from the Wiimote… any suggestions?
    • Oct 22 2014 | 2:34 pm
      Sorry to bring this thread back to life - but I'm also on Mavericks (10.9.4) and I get the following errors ajh.wiiremote 1.2 by Alex Harker (based on aka.wiiremote by Masayuki Akamatsu) partial rewrite by Timo Rozendal to fix incompatibility with Mountain Lion and to add support for the TR version (2013) can't get Bluetooth version.
      even using the new version downloaded above kindly supplied by Peter. Also - I am a little confused - there are two downloads but they are the same .mxo object? Any thoughts? Thanks
      Sorry fixed it - just needed to turn Bluetooth on :)
    • Aug 29 2015 | 11:39 am
      I am having trouble getting the ajh.wiiremote to work, I tried replacing the mxo with the files that Jazzisfaction kindly posted (although they are confusingly called older and older 1?).
      I get a error message that reads:
      ajh.wiiremote: unable to load object bundle executable 2015-08-29 12:32:39.231 Max[525:9979] Error loading /Users/Shared/Max 7/Library/AHarker wiimote/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote: dlopen(/Users/Shared/Max 7/Library/AHarker wiimote/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote, 262): no suitable image found. Did find: /Users/Shared/Max 7/Library/AHarker wiimote/ajh.wiiremote.mxo/Contents/MacOS/ajh.wiiremote: mach-o, but wrong architecture
      Please can someone advise (and share!) if there is a version that works with 7.0.5 on mavericks? Hoping to avoid bugging Alex.