App crash on at least on windows machine

    Jul 13 2013 | 11:02 am
    Hi everyone,
    I'm nearly finished developing an app I've been working of for the past 9 months to help kids with special needs and disabilities make music. It's basically a set of 4 over-dubbers that can be activated with switches, key-presses or mouse clicks.
    I've never had a crash on my mac or any of the PC's that I've tested it on but since rolling it out to beta testers I've had one crash report come in on windows Vista. Apparantly the crash occurs if the app is left running in the background for more than five minutes, no sound playing, no interaction. I've attached the screen shot they sent me.
    If you fancy testing the app, here are the download links:
    To use it, make sure you have a mic set up (not the built in mic, has to be an external one or you'll get comedy feedback). There are 4 "modes" at the top of the screen, Record, Play, Length and Delete, click a mode and then click on the circle in the middle of the screen to make it record, play, alter length or delete. You can drag samples on the the circles, use the keyboard numbers 1,2,3,4 to add/remove circles. If you click and hold down the mode buttons another option will appear.
    If anyone has any insight into what this crash might mean I would be hugely grateful.
    Many thanks.

    • Jul 14 2013 | 7:02 pm
      Anyone had a chance to try the app yet? Any idea what this crash might be? The beta tester is remote, I can;t get to his computer to see what is going on. Any feedback would be more than welcome.
    • Jul 15 2013 | 10:02 am
      Hi Barry
      I can test your application (seems to be very interesting...) a bit on my computers. I'll write about the results in a day or two.
    • Jul 15 2013 | 10:09 am
      You are a star! Thanks Yanki.
    • Jul 16 2013 | 10:53 am
      Hello Barry (and whole world...)
      Today I downloaded your app. I started from OSX (using MacBook Pro '17, latest Mountain Lion), as typically more stable... But I can't even start the app. After double click nothing happens (I was trying several times, with reloads, etc.) - nothing I can report as clue for bug-hunting. So I go to the LooperDooper package content manually and was trying to open the project in Max (v. 6.1.3) installed on my computer, and this time project started, showed the first screen (information about the manual how to use microphone) and crashed.
      I have some Windows machines in my lab and I can do some tests on Windows later, but I see, there is an issue on OSX - maybe we should try to start the tests from the Max project's level, before application build?
    • Jul 16 2013 | 10:08 pm
      Thanks for taking the time so far to test this. I am running Mac 10.8.4 and the app is running with out crashes on my system, but I would really value you looking over the Max project to see if you can find any clues regarding the instability. Once again thank you for taking the time out to look at this, I have put in an huge amount of work on this and really want it to be as stable as possible!
      You can download everything you might need for the max app here:
      (this has been replaced with this latest download:
      Just run the LooperDooper.maxpat file.
      The only third party externals that it employs are unlist.mxo from Lobjects and changelist.mxo from Jasch Objects.
    • Jul 16 2013 | 10:29 pm
      Hi Barry,
      I tried the application and it didn't open.
      When I did the close application to sort your mic out thingy it didn't open again. Was it supposed to?
      I've had trouble in the past on Vista with Max applications - it's probably only useful for using the spray can in Paint.
      Attached are Max windows(5 and 6) with plenty errors.
    • Jul 16 2013 | 11:27 pm
      Hi, thanks for the error list. Most of the Max 6 errors are due to you not having changelist.mxo and unlist.mso installed. I have included the missing externals in this download:
      (this has been replaced with this latest download:
      The HI errors are nothing to worry about. I've sorted a few of the other error messages now. The "info~ patchcord outlet out of range: deleting patchcord" does worry me, not sure what that is! Any ideas? If you have the time to test the download above it would be much appreciated.
      In regard to closing the app to go through our set up guide, in the standalone app a PDF opens automatically to instruct you how to set up a mic with your computer. You then have to manually restart the app after everything is set up. No one on here will need the set up guide, just go ahead and click "yes" to say you've gone through the guide.
    • Jul 16 2013 | 11:46 pm
      I downloaded onto mb pro osx 10.6.8 and it wouldn't open; before deleting it I noticed it had not been built with the latest version of Max.
    • Jul 17 2013 | 6:23 am
      Thanks Floating Point, how far did you manage to get? Did it open at all? Here is a new version built with the latest version of Max:
      (this has been replaced with this latest download:
    • Jul 17 2013 | 7:36 am
      Just tried your Mac app on my X.6.8 system. It doesn't open, but this reminded me an old problem I complained about many many years ago: sometimes the modes of the files included in the package are incorrect: the execute bit is not set. This happened when the standalone wasn't built on the startup disk. I don't know if this is now corrected, but I wouldn't be surprised if it isn't.
      So I checked your package and indeed, the execute bit of / is not set. I changed it with a chmod u+x . Now the app does start but crashes after a couple of seconds. So I suspect other mode bits to be uncorrectly unset, like the ones in the /Framework folder...
      Try to rebuild the app on your startup disk.
    • Jul 17 2013 | 8:52 am
      Okay so here are the latest versions (mac only at the moment).
      The latest build of the app can be found here:
      @Patrick thanks very much for your help and insight. This does open up unfamiliar territory for me. When I navigated to I found the UNIX file but was unsure about how to verify the execute bit. Indeed I'm really sure what the execute bit is, I'm presuming we're talking file permissions? How would I go about verifying, and then setting the execute bit of those files?
    • Jul 17 2013 | 9:48 am
      Same thing with the new version.
      I changed the execute bit of LoopedDooper, and replaced the whole /Framework folder (the bits arent"t set correctly neither, and the aliases aren't correclty defined anymore) and now your .app does launch. I can even tell you there is a typo in the welcome screen: you wrote 'miniute" instead of "minute". There are also many errors in Max' console (see attachment).
      To verify the execute bit, I use the Terminal and the ls -l command. To set the bits, I use chmod a+x in the terminal:
      [PAt-iMac:~] pdelges% cd /Users/pdelges/Desktop/ [] pdelges% ls -l total 53408 -rw-------@ 1 pdelges staff 27343020 8 jul 18:49 LooperDooper [] pdelges% chmod a+x LooperDooper [] pdelges% ls -l total 53408 -rwx--x--x@ 1 pdelges staff 27343020 8 jul 18:49 LooperDooper [] pdelges%
      But you shouldn't have to do that, there must be something wrong in the building process. Or maybe you transfered the unzipped .app with a USB key from the Mac to another computer?
    • Jul 17 2013 | 10:56 am
      The only difference I can think of is that previously I have zipped files at my end before distributing them and not received any comment regarding problems opening it. I've done that with the latest build, if you have the time you can find the zipped file here:
      Most of the errors are expected, though a few are unexpected and unfamiliar:
      [Cg.framework: no such file in collective] [newobj: no such file in collective]` [jitter-config.txt: no such file in collective]
      no idea what those are or what they refer to?
      Thanks for flagging up the typo! Hope the rest is as easy to fix!
    • Jul 17 2013 | 2:11 pm
      I just downloaded an uncompressed copy (with compression provided by dropbox) and a pre-compressed version. As I suspected, the uncompressed version didn't work but the pre-compressed version did. I will redo to windows build later today but this version is working on three macs that I have tested it on today:
      (Typo included ;) )
    • Jul 17 2013 | 3:20 pm
      Sorry for the delay… The lastest version works for me too now. The new icon is nice.
    • Jul 18 2013 | 9:43 am
      Yes, now everything seems to be ok on my computers. They were not very extensive tests, but the program works great.
      Departing for a moment from the technical issues:
      I really like it your project, Barry It is of course nice conceived in technical terms, and as Max application. But the most important thing for me is for whom and why this program exists. This project remind me that what we do with new designs is not an activity purely technical and functional but creating a better future.
    • Jul 18 2013 | 12:50 pm
      Here is a link to a wonderful young musician using the software: You can see it in context then.
      I have compiled and compressed a new Windows version so it should open now, still keen to get to the bottom of this strange crash after 5 minutes of inactivity on Vista. Also really keen to get other Windows users to try it out and report back any problems they have, so if you use windows please please give it a test drive!
      So the latest versions:
      Thank you all for your help and support. :)
    • Jul 18 2013 | 10:10 pm
      Anyone had a chance to test this on a windows machine yet?
    • Jul 19 2013 | 9:06 am
      Yes. Tomorrow in my lab. 2 brand new PCs and one old, crappy PC.
    • Jul 19 2013 | 3:59 pm
      Will be particularly interested in how it works with the crappy one! :)