Audio interface acting strange

    May 13 2013 | 11:14 am
    This is not directly Max related, still open for advice.
    Since a couple of days my MOTU 828mk2 firewire interface started acting strange. Every hour or so it glitches for a couple of minutes. I'm hearing crackles that sound like clock sync issues. It's only there when there's a sound signal, not in silence. It only happens on sound running through software (both Max and ABleton), not when I route my hardware synth's audio straight to the outputs on the MOTU, bypassing any software. Ie. the glitches occur when signals are passed between my computer and MOTU, not when signals are running only through the MOTU.
    My system's a OSX 10.8.2 hackintosh with Sonnet Tango800 firewire PCIe card. This setup has worked fine for 2 years. The MOTU is much older though, 7 years or so. Does this sound like it's wearing out?
    I haven't run any software updates or installations that I could relate this to. Any ideas?

    • May 13 2013 | 11:47 am
      Does it work with an older hackitosh system? 10.8.2 is out since september 2012, so you must have upgraded at some point.
      This guy had similar issues. It turned out he had some ground loop problems:
      Maybe try a to reset the MOTU? Remove FireWire cable, 'Setup', turn right till end, 'restore factory defaults', 'select' and then 'value'.
    • May 13 2013 | 12:04 pm
      I meant I didn't upgrade recently. The problem started only a couple of days ago.
      I tried the reset already but the groundloop is a good idea. I did have a noise issue with that recently, had to tape off some ground connectors to get rid of hum in my speakers. There's more stuff plugged in here than usual for the project I'm working on currently.
    • May 13 2013 | 12:07 pm
      Actually that tonymac thread sounds exactly like the groundloop problem I had. Resolved it by taking the monitors off the ground.
      This time round it's definitely not the speakers but the interface.
    • May 13 2013 | 12:08 pm
      Actually, not 100% sure it's the interface... might be the firewire or PCI bus, or...
    • May 13 2013 | 12:19 pm
      Maybe the interface was affected by this and needs a repair now. I had similar issues a few years ago with my MOTU 828 MK1, altough i couldn't exactly reconstruct what went wrong. I sent it to the german distributor (Klemm). They checked it and said i probably plugged the FireWire cable upside down which led to overvoltage. I definitely didn't do that. Anyway, in the end i had to pay around €250.- for the circuit board replacement.
    • May 13 2013 | 12:55 pm
      Plugging FW upside down? Is that even physically possible?
      I was already contemplating buying a new Ultralite mk3. Portability is appealing and I have a gig on thursday so need to sort this quick. Issue: sold out at all major shops in the region. Are they launching a new version soon or what?
    • May 13 2013 | 1:30 pm
      This sounds exactly like a problem I have which I reckon is clock sync issues, maybe you can do a test? When it starts happening, go into the 'Audio Devices' window in 'Audio/MIDI setup' and change the clock to something else and then change it back, this always makes the problem temporarily go away for me as I guess it resets all the clocks for another hour or so.
      I run 2 UltraLites as an aggregate device and they are set up to use one device's clock and I have tried with drift enabled or disabled and have tried pretty much every setting without a fix. This setup was running fine on an older MacPro and then when I upgraded to a new one with Lion it started happening.
      On my setup creating sound directly from Max is fine, but when I have audio coming in through the MOTUs and going through Max this is when I have the problem.
    • May 13 2013 | 1:45 pm
      Alright, will try that!
      This sounds like it might be related to another oddity I experienced recently. Same kind of crackles when running audio from Ableton to Max through Soundflower. Audio generated in Max is fine but the signals form Ableton that I mix in get all crackled up, after a while.
    • May 13 2013 | 2:25 pm
      Changing the clock source isn't getting rid of it but the glitches it introduces while switching are totally of the same nature.
      Btw, perhaps I didn't notice this problem before because I haven't been using hardware synths in a long time, and definitely not in extended sessions.
    • May 13 2013 | 2:41 pm
      Luke, do you have this problem with the ultralites connected to FW, USB or both?
    • May 13 2013 | 2:45 pm
      I noticed my MOTU ultraLite interface went south with the 10.8 OSX upgrade (USB communication would cease soon as startup - havn't tried firewire yet, as my stable RME interface is on the firewire, :) ). Think there *might* be some USB issues in 10.8. Had to remove it from my aggregate device.
      does MOTU know of this, he asks?
    • May 13 2013 | 2:56 pm
      Not from me. Given my next gig on thursday I'm not planning to rely on MOTU's support with its terrible reputation.
      Not that I have experienced it 'cause this is the 1st time in all these years that my MOTU is letting me down. Damn it! I was already looking at the RME's. Though I don't doubt their quality they're more expensive but less flexible (front panel level monitoring and settings control). MOTU 's always been the perfect deal for me. I'd hate having to switch now.
    • May 13 2013 | 7:19 pm
      Ahh, ok. Yeah, I'm on Firewire.
      There were definitely several forums with posts of a similar nature when I looked into it, seemed MOTU were blaming Apple and were blaming them back. As I had new machine and new OS its tricky to pin down.
    • May 13 2013 | 9:30 pm
      I sent a message to MOTU support. We'll see.
      In the meantime, for my gig later this week, I don't need to process or mix audio in software. I just need to grab audio to jitter textures and generate visuals from them. So I'll route the audio signal straight out from the MOTU to the mixer, not passing through Max. Though it will not prevent crackles showing in the graphics if/when they occur, at least it will not sound like sh*t. The visuals are glitchy anyway so I can get away with that...
    • May 14 2013 | 7:30 am
      Hey, you'll probably fix it and then spend ages trying to recreate the effect!
      Let us know what MOTU say...
    • May 14 2013 | 7:41 am
      hi dtr,
      although my system consists of a windows pc and an old motu ultralite I think I have had similar issues. I havent solved these completley, but one thing helped a lot: I checked the PCI latency performance with the tool "DPC latency checker". It has shown some latency spikes which triggered the crackling issue of the ultralite. So I've tried to find the cause of the ocassional PCI latency spikes and have found that disconnecting the USB hub solved it. PCI lantency can also be caused by antivirus sw or other backround activities, I think.
      I dont know if there is a similar software for OSX....
    • Jul 13 2013 | 11:15 am
      Well what do you know... Before spending a grand on a new interface I bought a new €50 firewire card and it seems the problem went away. Looks like a problem between my hackintosh system and the Sonnett Tango800 card. The new one is a DawiControl DC-FW800 PCIe.
    • Oct 13 2013 | 2:17 pm
      Hmm... I'm now doing some long Ableton sessions and seems the problem didn't really go away. Just less frequent :(
      The lines are back open for ideas and experiences...
    • Nov 12 2013 | 4:38 pm
      Now get this... After testing my audio interface on multiple machines, after testing all kinds of software combos, after buying a new €1000+ audio interface, after getting a new FW PCI card, after completely reinstalling my system, after pulling out my PCI cards 1 by 1 and after the hundreds of hours of testing (issue only pops up after an hour or so...) I find out that simply clicking the wifi icon in the top menu bar makes the crackling go away (for a while). Just clicking it so the wifi menu shows. Not even turning wifi off or changing networks. Just showing the menu.
      And it seems I'm not the only one with weird OSX audio and freeze issues, lots of genuine mac user complaints here:
      Now have to confirm if simply having wifi off prevents the problem altogether.
    • Nov 13 2013 | 9:33 am
      That's pretty crazy, keep us posted!
    • Dec 08 2013 | 5:58 pm
      I'm hoping someone here may be able to offer a suggestion. I also recently upgraded to a new mac 10.8, and am having a hard time getting my MOTU Ultralite working properly. I purchased one used, and had issues with the unit (it wouldn't complete the start-up sequence, and froze my computer). I sent it into the factory for a refurbished replacement, but now my audio programs freeze upon launching. Audio Midi set-up recognizes the device ~ is there something obvious I'm missing?
      This technical stuff isn't that intuitive for me, so I really appreciate any advice you might have : )
    • Jan 07 2014 | 11:16 am
      Sounds like something 's way off on your system. OSX is updated to the last version, 10.8.5? No other stuff installed that could be messing with audio?
    • Jan 07 2014 | 11:25 am
      So here's a new episode in my audio glitch saga. Now I also noticed glitches while playing games in Windows 7 on the same machine. I took out the PCIe wifi card (D-Link DW-556) and tada... all glitches gone. I plugged in an old USB wifi dongle (D-Link DWA-131) that I had lying around. Have tested it for a couple of hours on both OSX and Win and no troubles so far.