audio interrupts when editing patch


    Jul 12 2013 | 11:45 pm
    Hello everyone,
    I experience short audio interruptions when I'm editing a patch, like adding or removing objects, while audio is running. I tried setting the IO vector to minimum (64 samples) and scheduler in overdrive to off, but I still have very short interruptions (though they slightly shortened). I have this problem when I'm using my external sound card and when I'm using built-in output, so it's not a sound card problem. Also I don't have this problem in PureData, which is running at a vector size of 64 too. Is it my computer that is getting too old ? :( Or is there any other trick that I'm unaware of ?
    Thank you,
    Hugo

    • Jul 13 2013 | 9:06 am
      Hi This is entirely normal behaviour, as MaxMSP recalculates the new DSP chain.
      A newer machine with a good audio driver will allow you to optimize the signal vector size.
      Brendan
    • Jul 13 2013 | 9:36 am
      Actually you're right and pd does it to, but only when you try to load external objects or your own abstractions. However when you add a new built-in object there's no click. How come I never noticed this before ? I'm still going to do some clean up on my computer because it has been a bit slow lately.
      Anyway, thanks for your answer Brendan.
      Hugo
    • Jul 13 2013 | 4:07 pm
      Look in the Max preferences (in the Max menu). "Enable Mixer Crossfade" should be on, to eliminate this dropout.