audiounit~ public beta 4

    Dec 10 2010 | 3:40 pm
    One of Santa's elves here... Yet another new version of audiounit~. This on solves problems that were reported when doing things like cycling through a lot of plug-ins triggered by a metro or delay.
    Thanks again for all your feedback!

    • Dec 10 2010 | 7:06 pm
      For some reason with this version and the previous the getpluginnames button in the audiounit~ help does not work - it doesn't generate a list of available plugins. I trashed the Max prefs but that didn't help. Suggestions?
    • Dec 12 2010 | 5:36 pm
      It has started working - creating an audiounit~ object somehow forced a scan this time and now all is well. Very strange but will continue to see if I can figure out what was failing.
    • Dec 13 2010 | 2:10 pm
      I suspect that maybe Max had been quit (or crashed) or something in the middle of doing the scan. If so then the database of plug-ins created by the scan would have been in a bad state. So then re-scanning fixed the problem.
      If you do find something else going on, please let me know, and thanks for the report! Tim
    • Jan 02 2011 | 11:22 pm
      It's really great to hear an updated audio unit extern for max.
      It's not working for me yet, though. I get this error in the Max window:
      audiounit~: unable to load object bundle executable 2011-01-02 17:14:59.294 MaxMSP[6003:207] Error loading /Applications/Max5/Externals/audiounit~.mxo/Contents/MacOS/audiounit~: dlopen(/Applications/Max5/Externals/audiounit~.mxo/Contents/MacOS/audiounit~, 262): Symbol not found: _jgraphics_get_resource_da ta Referenced from: /Applications/Max5/Externals/audiounit~.mxo/Contents/MacOS/audiounit~ Expected in: /Applications/Max5/
      Let me know if anyone has any ideas about what is wrong with my setup. I've been really excited about this opening this up since I saw this thread.
    • Jan 03 2011 | 2:34 am
      Ope. Looks like it was because I wasn't using the latest version.
      My Max is updated, and the error is gone.
      I'm so excited to get this up and running!
      Thanks, cycling74!
    • Jan 03 2011 | 5:46 am
      Here's a possible bug to report, though.
      Invoking "wclose" with an "open generic" window open causes Max to lock up for me. Not immediately, but within five seconds.
    • Jan 13 2011 | 3:31 pm
      Yikes. I can reproduce it and will fix. Thanks.
    • Jan 30 2011 | 5:51 pm
      So - I'm back trying to get Aalto by Madrona labs to work with audiounit~ - someone claimed to get it to work but I can not get it working. Here are some details. I'm currently using the demo version.
      In the audiounit~ help Aalto does not appear after using the getpluginnames button. However, in the 'misc' subpatch it appears near the bottom of my list with the following column data:
      Aalto aumu MLbs Aalt 2
      I'm wondering if the number 2 in the last column is part of the problem. It seems other plugins that I have that also have a 2 in this column do not show up in the same way.
      Is this a bug in Aalto or something audiounit~ can look for? Is it a resource tweak that I (as a user) can make to the Aalto component itself to make it show up?
      Thanks in advance for your help!
    • Jan 30 2011 | 9:17 pm
      Aha! Got it!
      audiounit~ 0 2 Aalto
      This works - need to specify 0 inputs and it works!
    • Feb 20 2011 | 10:19 pm
      hey, i'd like to report a bug. I think it's the right place, it's rather straightforward. So... Max freezes if : audiounit~ has loaded a plug in without a custom gui (includes all Apple default plugs) ; then user makes the plugin gui appear ; then closes the max patcher in wich is the audiounit~ host. You need to force Max to close then.
      The freeze doesn't occur when it's a plugin with its own gui. i'm on macbook pro osX 10.6.6 intel core i7, latest max, latest audiounit~.
      btw thanks for audiounit~, it's great job even with that :) and i have a feature request as well : would it be possible to have a way to display a plugin gui appear inside a patch, not in a floating window, like if inside a bpatcher ? same question for vst~ btw...
    • Apr 21 2011 | 8:06 am
      minor niggle with the helpfile: in the subpatch "midi", the audiounit doesn´t load because of the first argument (i think). if one replaces the 0 by 2, all is fine. seems audiounit~ doesn´t like to be without input. (max 517, mac 10.6.7.)
      otherwise greta to have that object! hans
    • Apr 21 2011 | 7:43 pm
      macbook 15" i7 quad. 10.6.7
      i got message error windows with a little terminal icon, about plugins for example " native saying memory is getting low" and then its impossible to close the error windows, the weirdest thing is that even if i close max i got the window is staying,even relaucnhing the finder doesn't help, only solution then is to logg off.
    • May 23 2011 | 4:21 pm
      would it be possible to let audiounit~ support Audiounit generator plugins, like aunetrecieve?
    • May 23 2011 | 5:16 pm
      It works well for me, using the format [audiounit~ 0 2 AUNetReceive].
    • May 23 2011 | 6:04 pm
      great, i didn't realise, since it didn't show up in the list
    • May 25 2011 | 2:00 pm
      audiounit~ only lists those plug-ins which fit the channel configuration of the instance. If you have an [audiounit~ 0 2] and the plug-in is not listed, then this could be a bug.
    • May 25 2011 | 2:06 pm
      if i connect aunetreceive in this patch, then close the max patch, max crashes:
    • May 25 2011 | 2:44 pm
      FWIW, the patch works well for me when used in MaxForLive. (I don't have a full MaxMSP license).
      Does it work for you if send and receive are in different patches?
    • Jul 07 2011 | 4:28 pm
      thanks for the auplugin patch!
    • Jul 22 2011 | 10:23 pm
      on my computer (mac10.6.8., max 5.1.8) when using the octogris au ( even in the simple 2X2 configuration, opening and operating the pluginwindow works fine, but sending a wclose message crashes max. would be nice to have these spatialisation plugins supported in max!
      thanks hans
    • Jul 26 2011 | 10:05 am
      I've noticed that 'getpresetnames' delivers the names in strange disorder.
      For example, with AUMatrixReverb I'm getting the list
      print: Large Room 2 print: Small Room print: Plate print: Medium Hall 2 print: Medium Room print: Medium Chamber print: Medium Hall 3 print: Large Room print: Large Chamber print: Large Hall 2 print: Medium Hall print: Cathedral print: Large Hall
      Similar disorder happens also with 3rd party plugins (eg. Pianoteq).
      It would be nice if this could be fixed.
    • Oct 05 2011 | 11:09 pm
      Hello, is this the last beta for au~? And is it enough stable?
      Thanks and best regards.
    • Oct 06 2011 | 7:59 am
      Not only is the order of the presets at random, I noticed for AUPitch that the enable .... (forgot what it is) corresponds to the pitch shift using an external controler.
      Could someone varify this, please.
    • Oct 06 2011 | 11:45 am
      Verify what exactly?
    • Oct 06 2011 | 4:49 pm
      Just did a quick test with AUPitch and can confirm that the assignment of parameter names is wrong. For example, to change the "pitch" value you actually need to use the "effect blend" parameter.
    • Oct 13 2011 | 12:54 pm
      today, I wanted to connect an Absynth 5 audiounits plug in to the object.
      Under recall presets, I get "disabled". I asked Brian Clevinger the designer of Absynth what to do. He instructed me to chose program and click on.
      I did it but there are no presets listed. When I click clear inside preset communication the menu is cleared, when I click recall preset $1 I get nothing back. Does anybody know what to do to get presets listed from Absynth?
    • Oct 13 2011 | 6:43 pm
      Same problem at here.
    • Oct 14 2011 | 2:08 pm
      Is there any way to use this with an AU where the number of inputs and outputs is not equal?
    • Oct 14 2011 | 2:22 pm
      @tjh, Yes -- in the help patcher, if you look at the [args_and_channels] subpatcher then it has an example of [audiounit~ 1 2 AUMatrixReverb].
    • Oct 14 2011 | 2:23 pm
      Note that in Max 6 there is support for hosting AudioUnit plugins with the vst~ object. Because of that, there will be no more updates to audiounit~.
    • Oct 14 2011 | 3:59 pm
      Thanks - a classic case of RTFM :) And thanks for the note about the vst~ object - that's good news.
    • Oct 14 2011 | 6:36 pm
      the audiount object is not included under Max6 right?
    • Oct 14 2011 | 6:44 pm
      The Max 6 vst~ object speaks audiounit now...
    • Oct 14 2011 | 7:45 pm
      To avoid confusion, maybe [plug~] as a synonym for [vst~] would be helpful.
    • Oct 15 2011 | 8:47 am
      I always like progress but I have just ported some patches from Max4 to 5 regarding the new audiounit object. Now, it has already changed again and when I look at the new vst/au object, it does not tell me more. I tried the Absynth plug in and try to load the presets but it could not do it. Maybe it is still the same problem like I found under Max5, but in any case I have to learn about this object again.......Maybe it is for the better though...
    • Oct 15 2011 | 11:41 am
      A major drawback of the vst/au "unification" seems to be that parameter values are restricted to the range 0-1. Also, from some quick tests I've got the impression that parameter names are not handled correctly.
    • Oct 15 2011 | 12:00 pm
      If there are bugs, please feel free to file an official report so that someone can look into it. We have a form @
    • Oct 15 2011 | 1:17 pm
      Ok, I've found that parameter changes are working, but the AU interface isn't updated accordingly while open.
      Now my question is: How can I set a parameter value >1, for example [pitch 1200] when using AUPitch?
    • Oct 15 2011 | 4:18 pm
      @broc do you want to control that parameter with a fader and need to set it in the menu? AuPitch is apparently going wrong, pitch corresponds to effect blend I think.
      For a fader, I use a scale object which scales it down between 1 -127. I gave the range of -2400 to 2400. For some peculiar reason it works. Do you get what I mean?
    • Oct 15 2011 | 5:21 pm
      In the Max6 version AUPitch seems to work correctly insofar as pitch actually corresponds to pitch. But the problem is that it accepts only values in the range 0-1 (which doesn't conform to the AU standard).
      Have you tried your scale object with the Max6 version?
    • Oct 16 2011 | 7:10 am
      @broc sorry, I did not know that you work under 6! I will try on Monday
    • Oct 17 2011 | 8:12 am
      Well, everything is different now but I can not get it to work. Even if I put a value in nothing moves.
      I think we should open a new thread and call it Max6 vst object
      What do you think?
    • Oct 17 2011 | 9:17 am
      hi Tim,
      I hope you will still read this thread.....
      I will make a report on Max6 beta bug about the vst/au object later.
      I HOPE that you still consider the au object of Max5 worth updating?!!! As I said earlier, I had a problem with chosing program preset from an Absynth 5 plug in. I can only say, regarding from what I saw the new object is like under 6, that it should have the same structure like au under 5. A list of programs, a list of plug ins, a list of parameters, hopefully inside an ubu menu. That was very elegant and easy to use.
      Let me know what your ideas about this are please.
    • Oct 17 2011 | 9:31 am
      It's good to find the bugs but why don't you use the vst version of absynth? vst support is more tried and tested
    • Oct 17 2011 | 10:15 am
      @ Hans
      Yes, please open a new thread. Currently I don't use the object in practice, but will try to contribute. Hopefully we get some comments from the developers.
      @ oll larkin
      I agree that vst versions are generally more supported. But on Mac there are many useful built-in AU plugins, not available as vst.
    • Oct 17 2011 | 12:58 pm
      I tried the vst. The prg names are there and I can switch between them. Unfortunately, the sound does not change. I tried the stand alone Absynth 5 and it is just like that too. I wrote to Brian and I hope he will tell me what the problem is. But yes, vst does the prg changes.
    • Nov 03 2011 | 12:37 am
      Is there an upper limit on number of channels? I'm trying to use an AU with 8 in, 16 out, and getting "plugin scan unsuccessful" with error code -1. The AU does pass auval, btw.
    • Nov 03 2011 | 9:53 am
      Sorry, I should probably have clarified that I'm talking about audiounit~, not vst~.
    • Nov 03 2011 | 3:21 pm
      where do we find the latest version of audiounit~
    • Nov 07 2011 | 12:18 pm
      There are no updates for audiounit~. Everything has shifted to vst~.
    • Mar 12 2012 | 8:45 pm
      Is there a version of this that runs on old Mac PowerPC's???
      I get this error: /Applications/Max5/Cycling '74/msp-externals/audiounit~.mxo/Contents/MacOS/audiounit~: mach-o, but wrong architecture
      I'm assuming this is b/c I'm using a PPC and not intel chip?
    • Mar 28 2012 | 4:30 pm
      can i clarify that the vst~ object accepts audiounits on MAC OS when using MAX 6?
    • Jul 12 2012 | 5:51 pm
      I still need to use Max5 for some production work. Where can I find the very latest (last) version of the audiounit~ .... I found several beta versions mentioned in various forum posts but it was never clear which one was the most recent.
    • Jul 12 2012 | 6:26 pm
      The latest audiounit~ beta for Max 5 is at the top of this thread. Please note that it is not supported.
    • Jul 12 2012 | 8:10 pm
      Understood completely that it's not supported --- but is it really reliable in its current incarnation? I.e, could one go in front of a live audience using it and not be worried that it might break?
    • Jul 12 2012 | 8:17 pm
      Hard to say. I'd definitely put it through its paces before using it in a live setting.
    • Sep 19 2012 | 3:33 pm
      So is there a way to handle the problem where AU parameter values don't range from 0 to 1 and in particular can have different ranges for different parameters?
    • Sep 19 2012 | 8:58 pm
      The message 'getparameternames' gives a list of all parameters including value ranges. The list can be stored in a [coll] and then used for scaling the individual parameters via [scale].
      This works for me with [audiounit~] but I'm not sure about [vst~] in Max6.
    • Sep 19 2012 | 9:23 pm
      I'll have to think about that --- not sure I want to have to create that on the fly every time I load an AU. That means I'll have to preprocess and save/reload mapping files.
      It would be a nice enhancement to the [vst~] object to do this kind of thing automatically. I'm struggling to find a homogenous way to manage both AUs and VSTs interchangeably from Max.
    • Oct 17 2012 | 11:19 pm
      Cheers Tim,
      Would you be open to releasing the source for this external? I've tried using ~vst in Max 6 but have found ~audiounit to be much more stable, and I prefer it's api. There are also some enhancements related to parameter processing that I'd like to bake into it, to avoid the messaging overhead.
      I don't really care about maintaining the source in a public repo, so if you'd prefer to just send it to me privately, I would be most grateful.
      Thanks for making it in the first place!
    • Oct 18 2012 | 12:53 am
      Cheers Tim. It works great! P
    • Oct 18 2012 | 1:43 am
      I would also love to get access to the source of this external. I'm desperately trying to switch to Max6 but I am still having problems with the [vst~] component sometimes causing Max to crash when a VST is freed. I've been contemplating writing my own VST wrapper but it's a lot of work and I'd love to have an existing external from which to start (or just use).
    • Oct 18 2012 | 12:10 pm
      I think the integration of VST and AU in [vst~] of Max6 is inherently problematic as both standards are using different parameter handling. Keeping a separate [audiounit~] object in Max6 would be cleaner IMO.
    • Oct 18 2012 | 5:27 pm
      Yes, at the least, the object should have normalized the parameters so that the range is always 0.0 to 1.0 no matter whether it's a VST or an AU.
    • Oct 19 2012 | 12:09 pm
      I know all this is history, but I try to port my Max5 patch to 6 and I find myself in trouble, because I do not find a way to control parameters from AU plug ins.
    • Mar 18 2013 | 5:08 am
      a little bit late, because I've some projects which are in progress (vc_fun_gen, compositions...) this message is in english and german partially
      Ich bin derzeit nicht an Max4Live interessiert: Software wie Samplitude Pro (Magix), die Portierung nach osx ist "ja" in Planung, erfüllen meine Ambitionen zielgerichteter (natürlich ist noch Einiges nachzuarbeiten gerade was MIDI, osc betrifft)
      in the last two years, I've began to developing several plugins and instruments which are ported as dll and vst to win (xp,w7) as osx (10.5.8, 10.6.8)
      now is the ver.6 of Max on my machines (the difficult design is another point - I prefer more the outfit by Max 4.6.3 a kind of "constructivism") and the ugly mistake in Max ver 5, 6 is the unavailability by these choices
      If somebody has a practicable solution to available the export of my developed stuff as vst etc please let me this know I've (and not myself) also interest for some howtos manuals or short guides about this tpoic (and others from the MaxMsp-world) in german (sure I understand english, but sometimes is it more useful to read and recapitrulate the readings in native language) thanks and regards
    • Sep 07 2015 | 1:20 pm
      hello I am usin the audiounit~ object in Max/msp 6.1.9 and I get this message in Max window: "you are using an older vwersion of audiounit~ (0.0.0) than was shipped with Max 6.1.9.....please verify your installation and your search paths" Note: I believe I have the latest version of this object (6.0.0) And not quite understand if there was an audiounit~ that came with max v. 6.1.9
      Any ideas why I get this message? Should I go through preferences or am I missing an update?
      Thanx in advance!
    • Sep 07 2015 | 5:24 pm
      Yes, don't use audiounit~ at all, use vst~ instead. audiounit~ is deprecated and all its functionalities have been embedded inside vst~.
    • Sep 08 2015 | 10:04 am
      thanx Vichug!