Automatic loading vst~plug-in


    Feb 05 2006 | 12:50 pm
    Hello,
    I'm building a patch with a Klaerhus Audio VST plug-in.
    When I load the plug manually, everything is ok.
    I know it must be possible to load the plug-in automatically, but i can't find it.
    I've tried preset and loadbang (maxmess. can't find the Classic delay).
    The plug-ins are in a folder known to Max.
    My study patch is based on GTaylor article section tutorials.
    If anyone have a suggestion i would really appreciate it.

    • Feb 05 2006 | 1:03 pm
      A quick look at the help file for vst~ will show you that you can include a vst filename as an argument. (ie. you can type that name into the vst~ object and it will look for that file)
      best,
      j.
    • Feb 05 2006 | 1:34 pm
      Thanks John for your reply.
      I've read the help file and did also what you've mentioned filling the object with 'Classic Delay'.
      Max gives me an error:
      vst~: cant find Delay
      May-be something wrong with my setup of File Prefences?
      It is called EetcVSTplugins that looks ok
    • Feb 05 2006 | 1:48 pm
      not sure what you are doing - but if the effect is named Classic
      Delay, and if you type in an object box [vst~ "Classic Delay"] it
      should work
      if it does not check if sending to the [vst~ ] object the message
      [plug "Classic Delay"] works - , or if your plug is not named
      "classic delay" (and not "Classic Delay")
      so far the ONLY plug-in i found which does not work when called
      directly by the vst~ object is "GuitarRig 2.vst" (by native
      instruments) - GuitarRig (1) works, as does absynth and reaktor - the
      NI people said they do NOT support maxMSP as host. (how nice)
      anyhow, all is in the help file, and more in the pdf
      best
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • Feb 05 2006 | 1:50 pm
      If there are spaces in your vst name, don't forget to surround the
      [vst~] argument with quotes.
      If it still doesn"t work, try to move a copy of your vst in the same
      folder as your patch.
      p
    • Feb 05 2006 | 1:54 pm
      i had always problems with vst plug-in names which include blanks. does your
      plug-in include blanks? if so, try to rename it...
      hope it helps,
      bests,
      jens
      jens doering:::::::::: http://www.jensdoering.com/:::::
      2av - media art::::: http://www.2av.de/ :::::::::::::::::::
      jerry lusion:::::::::::: http://www.jerry-lusion.com/::::::
      e.stonji:::::::::::::::::: http://www.estonji.com/:::::::::::::
      hp.stonji:::::::::::::::: http://hpstonji.estonji.com/::::::::
      e:gum:::::::::::::::::::: http://www.egum.net/::::::::::::::::
    • Feb 05 2006 | 9:04 pm
      Ok the vst~ did load the right plug-in.
      It's Jens's solution: clearing the blancs out by renaming the dll file.
      Everybody thanks a lot,
      jacques
    • Feb 05 2006 | 10:17 pm
      salut jacques,
      you may check which files max can reach when you go to the "file
      preferences" menu and let print all reachable files in the max- control
      window. if your plug-in is in the list, everything is alright...
      bests,
      jens
    • Feb 06 2006 | 9:17 am
      woah woah WOAH..
      renaming the file is NOT the right solution here. Going about that method will cause a lot of problems and shows a lack of understanding when working with symbols. The solution is....put quotes around the name and make sure the vst plugin is either A. in the directory of the patch you're working on or B. in your file path and it'll work FINE.
    • Feb 06 2006 | 9:29 am
      >woah woah WOAH..
      >
      >renaming the file is NOT the right solution here.
      i agree
      however in the OS9 time, on mac of course, this was a very practical trick
      I found it no so reliable on OSX - but since you talk about dll, i
      guess it's windows
      kasper
      --
      Kasper T. Toeplitz
      noise, composition, bass, computer
    • Feb 06 2006 | 11:27 am
      mac or pc ? version of vst~ ?
      If on pc : type the complete full name as an argument (ex: [vst~
      "Spectral Delay.dll"]). Note the double quotes if space inside the path...
      Best is to save your vst state as a .fxp, .fxb file compatible with
      cubase (depends on your max version), then to recall them on loadbang
      with a "read" message.
      f.e
    • Feb 06 2006 | 11:39 am
      ...and on windows, don't rename it, for god's sake, the uninstaller
      /updater will not be able to manage the plugin anymore. It could result
      in bad registry keys, lead to orphan files and such... If you really
      don't want to deal with symbols syntax in max, create a new folder
      inside max search path, copy the plugins you use a lot and rename them
      if you need. It works quiet good and leave your orginal installed plug
      in good shape.
      f.e