Bang single letters out of textedit box, a la typewriter


    Apr 18 2009 | 4:46 pm
    I'm working on a project in which I'd like to enter a body of text in one textedit box.
    After starting a metro, I'd like each letter of the body of text to flow into another textedit box. This way, I can get the ASCII numbers of each letter sequentially out of the second box to control some other stuff.
    Basically.... I kind of need a typewriter "effect" - any thoughts?
    Thanks!!

    • Apr 18 2009 | 6:19 pm
      Would something like this work?
    • Apr 19 2009 | 3:53 am
      Don't forget [zl queue].
      lh
    • Apr 19 2009 | 5:26 pm
      Thanks for the reminder about [zl queue]. With the right output of that object counting down, you can even streamline it a bit further.
    • Apr 21 2009 | 10:49 am
      This is my version of a type writer
    • Apr 21 2009 | 2:32 pm
      These are all fantastic! Thanks so much for your replies - These should work perfectly.
      Thanks again!
    • Apr 21 2009 | 5:22 pm
      stefantiedje wrote on Tue, 21 April 2009 03:49This is my version of a type writer
      Leroy Anderson would be proud!
    • Sep 15 2012 | 9:22 am
      Know this is an old thread but I've tried stefan patch and get a problem with it. If I type a new text, the first time I bang it out, the first lettre is repeated, and I don't find where this comes from.
    • Sep 17 2012 | 8:38 am
      Anyone ?
    • Sep 17 2012 | 11:32 am
      For me it works perfect. I think you send two bangs to textedit. how do you trigger it? try to trigger manually and see what happens.
      best
    • Sep 17 2012 | 4:20 pm
      Ok, so I've tried it again. It works perfectly in max 5 but in max 6, it exhibits the behaviour I describe. Can someone please confirm this please ? If I type a new text, the first time I bang it out, the first letter is repeated. From the second time on, it works ok.
    • Sep 17 2012 | 5:30 pm
      I see the same behavior with Max6 on a PC. The first character is repeated for next text.
      Best regards, Michael
    • Sep 17 2012 | 5:31 pm
      Whoops, I meant to type "new text."
      Best regards, Michael
    • Sep 18 2012 | 6:21 am
      Michael, please what is you version exactly ? I've sent a bug report to Cycling but they can't reproduce this with 6.07. Which I can't install because the installer doesn't work for my os.