Basic Question: No Input Audio!

    Jan 27 2013 | 9:44 pm
    I've used MaxMSP on and off for a while now. (I'm still on Max 5.1.) However, in the last three years or so, I've only ever used it within the context of Max for Live. I've gotten a new computer (Macbook Pro) since then and had to re-authorize Max. Today, for the first time in a while, I tried using MaxMSP without Live. And I found that Max just doesn't acknowledge any input audio anymore! I use a Focusrite Saffire audio interface. I checked the settings in DSP Status but that doesn't help. Live can hear my input audio just fine and all my Max for Live effects have no problem recognizing the input I send to them via Live. Also, MaxMSP has no problem with audio from e.g. oscillators. However, it doesn't seem to be able at all to recognize anything I send to it via the Saffire. In fact, when I set 'input device' to 'built-in microphone', it still doesn't even recognize e.g. when I clap my hands. It seems like the most basic thing on earth but I'm really stumped! Has anyone experienced this? Anyone know what to do?
    Edit: At the end of the day, I probably am going to mostly just use Max for Live anyway. Still, I'd like to understand why this is happening. When I'm just doing study/research, it's nice to be able to just use MaxMSP.

    • Jan 29 2013 | 3:57 am
      Hello sundar...i have expreriensed this problem in the past with saffire 6 usb.. .have you tried to switch the driver to ad_portaudio ASIO?
    • Jan 29 2013 | 6:01 am
      oh! i forgot that ad_portaudio ASIO is available only on max 6...
    • Jan 29 2013 | 5:00 pm
      Tech support helped me. My Input Mappings were not set to the right channels.