BEAP Sequencer won't save patterns


    Sep 01 2016 | 8:59 pm
    I've been digging around here but haven't cleared up the issue I'm having. I'm finding that the BEAP "Sequencer" to be really erratic when it comes to saving Patterns on the object's interface(write>Pattern dial). Sometimes it works, sometimes it doesn't. For example I can make a pattern and "write" it to pattern 1, then make a different one and write it to pattern 2, and sometimes it'll work. But not always. Sometimes, even after it works and I can switch between the patterns(either by using the dial or be entering the number), it just stops working after a while (while the patch is still open) and the saved patterns are gone. And it definitely won't save any of these patterns after I save and close it/re-open it. I've whittled it down to a test patch with basically nothing in it except the Sequencer - not dealing with a complex patch here. So, I experimented with using a preset object which seems to have no effect on BEAP objects at all (or at least the handful I tried in addition to the sequencer). Next I experimented with snapshots but the patterns are not saved in the sequencer that way, though every other setting on the sequencer saves with the snapshot (I have the BEAP Sequencer object embedded in the patch FWIW). Next I tried the Vizzie Starter object and same deal--everything else seems to save correctly to a preset with that approach EXCEPT whatever I've written (when it works) to the sequencer's "Pattern" dial. Any ideas? Thanks!
    Max 7.2.4, Mac OS 10.11.6