bpatcher - file and arguments greyed out means...?


    Nov 12 2012 | 1:51 pm
    (latest Max 6 and OSX)
    I have one specific patch that when I load it into a bpatcher, the Patcher File and Argument(s) options grey out. What does this mean?! (And how do I fix it?)
    I've tried copying the contents of the patcher into a new blanks patcher (in case it's something to do with the settings in the patcher inspector), but I get the same result with the new renamed patch.
    thanks
    David

    • Nov 15 2012 | 11:11 am
      "embed patcher in parent" checked on in the bpatcher inspector ?
    • Nov 20 2012 | 3:58 pm
      No, I checked that straight off.
    • Apr 04 2014 | 4:01 am
      Old news now, I know, but I am constantly plagued by variations on this problem -- especially when duplicating bpatchers -- but I can never get anything failing consistently enough to post here. It comes and goes in mysterious ways. I deal with it by putting my arguments in before I choose the patch to load, so if the args field locks, it won't matter. Ugly, I know...
      \M
    • Apr 04 2014 | 8:20 am
      agreed - i see this spuriously aswell. i tend to find closing everything down a restarting often cures it, but have no consistent way of reproducing.
    • Aug 23 2014 | 8:15 pm
      really annoying, yes.
      my workaround is to do a [script sendbox bpatchername args arguments] to a [thispatcher] object located in the bpatchers parent. haven't found a better solution as the bug is completely random.
    • Aug 25 2014 | 6:50 pm
      This bug has been around for some time -- C74 is aware of it, so it's on some to-do list somewhere....
      \M
    • Apr 07 2015 | 9:57 am
      This issue is still not resolved in Max 6.19 and is really annoying. It makes very difficult to do sets of voices using a model.
      Another solution is to copy the bpatchers with the initial args into a text editor, change manually the args and copy back the text into the patch.
      {
      "box" : {
      "maxclass" : "bpatcher",
      "name" : "Voice.maxpat",
      "args" : [ 12 ],
      "numinlets" : 0,
      "patching_rect" : [ 34.0, 198.0, 94.0, 236.0 ],
      "id" : "obj-4",
      "numoutlets" : 0
      }