buffer~ not loading audio (sfplay~ works, audio from exaples/sounds work...)

    Dec 08 2013 | 2:54 am
    I just started to use Max again on a new computer after taking 6 months "off." Buffer~ won't load audio, even in the play~.maxhelp file for instance. Sfplay~ loads audio fine, and any of Max's audio samples from "Max 6.1/examples/sounds" work. I thought this must be a file-tree problem, but the audio I'm trying to use is in the search path... I've also tried reinstalling Max... twice. Any ideas?

    • Dec 09 2013 | 4:27 am
      Sounds like a file preferences issue.
      Are you trying to read files into a buffer~ by sending a read or replace message with a filename or by using read to bring up a dialog?
      If the former, are you getting any error messages in the max window like "buffer~ mysound.aif: can't open."?
      If you haven't tried the latter try it, does audio still not load into the buffer?
    • Dec 09 2013 | 4:40 am
      Hey Ben,
      This is Daniel, Anthony's friend from Sydney in October! :) Nice to see you on here, and thanks for the help! I think I've fixed the problem.
      Max seems to want each file in the path to be referenced separately in File Preferences. So instead of "...documents/Max/Patches/my_sampler/" it wants four different entries "...documents/" "...documents/max/," "...documents/Max/Patches/" etc.
      It works with this setup. I don't recall this being an issue before though. Was I just oblivious to this requirement or is this unusual?
      Cheers, D
    • Dec 09 2013 | 5:02 am
      Wow - small world, Daniel!
      This is indeed unusual so there must be an issue at play. Have you checked the 'subfolders' check box so that it looks further down into the directory you listed?
    • Dec 09 2013 | 12:35 pm
      Yes, sub-folders are all checked...
      It might be totally unrelated, but I've also encountered some weird bugs tonight that I've never seen before. In particular [zl.delace] and [zl.lace] were changing the values of numbers on a list! (Not just reordering them!!) I was using them chained together in order to reverse the mathmatical parity of the list-members' order. I've found a workaround using CNMAT [interleave]/[deinterleave], but now I'm totally paranoid. :)
    • Dec 09 2013 | 12:42 pm
      Sounds odd - can you post a patch?
    • Dec 09 2013 | 1:13 pm
      I think that I have the same problem... I just can't load a file in a buffer, even in the buffer help patch, the max windows says: buffer~: cannot open parser for this file.
      OS 10.8.4 Max 6.1.5
    • Dec 09 2013 | 2:09 pm
      I can't seem to recreate the effect now. It was only happening in a particular sub-patch. However, this is basically all I was doing. The number list was coming out incremented from how the values went in. Very strange!
    • Dec 09 2013 | 2:40 pm
      I have Max 6.0.7 installed on the same computer, no problem with this version...
    • Dec 10 2013 | 9:03 am
      Krisloop, did you try adding every file in the file path to File Preferences as I did? Does that fix the problem for you?
    • Feb 06 2014 | 5:39 pm
      Not at all
    • Feb 07 2014 | 7:05 am
      I've put the buffer~.mxo from max 6.0 in the 6.1 folder and it's ok I've something in waveform~ in Max 6.1 with the 6.0 buffer~ object.
      So, maybe there's something wrong with the max 6.1 buffer~.mxo object?
    • Dec 01 2014 | 8:01 pm
      I've been having this problem quite a bit.
    • Feb 23 2015 | 8:33 pm
      I dont have a problem,but other people with my Live patches are reporting the buffer~ objects are not opening files.
    • May 25 2015 | 8:08 am
      Well this is a really dumb bug... Max just spits out a "can't open fine now" message in the Max window.
      The solution I've found is to initialize the buffer with a file from Max's included sounds:
      For example: buffer~ foo anton.aif
      Dragging and dropping (with [prepend replace] of course) works fine after this. Hope this helps.
      Cycling, please fix this!
    • Aug 14 2015 | 2:23 pm
      Hi, I'm working on a granular patch. I need to load an envelope in a buffer. I've generated different envelopes, I've got four wav files of 1024 samples. The env files and patch files are in the same folder but when use "read" message, max says: "buffer~ - expodec.wac: can't open". What happen? Why it doesn't work? I've tried putting the folder into the file preferences path. It didn't work. Thanks!
    • Oct 03 2015 | 9:34 am
      i had the same problem on win 7 64bits and fixed by using AIFF instead of wav... :s
    • Oct 03 2015 | 4:48 pm
      i had this problem with a loadmess not loading the sample into buffer~ when i installed the 7.06 update. the project folder was on my desktop for easy access and i tried saving it to the dedicated projects folder, this seemed to sort out the filepath issues and it now responds correctly from the desktop too.
    • May 24 2017 | 9:31 pm
      BRONZEBYGOLD, I just wanted to thank you because I spent 4 hours of my time trying to figure out why all of a sudden my [buffer~] objects couldn't load wav files. I was shocked to find I couldn't load wav files into the [buffer~] help file. I tried everything I could think of and eventually found this post. I did exactly what you suggested in the third comment of this thread and it worked! Thanks so much, dude!!!!
    • Oct 06 2017 | 6:59 am
      I have this problem on my Windows work-computer if I for example try to use a file from my user-directory. The exact same patch works just fine on the Macs.