Buffer Shuffler only works in edit mode

    Nov 23 2010 | 9:27 pm
    Dear M4Ler's (is that a term?)
    The title says it all... Everything else seems to be working but the shuffler... which works in edit mode with Max open., but not in Live. I don't seem to be getting anything out of chucker~
    Am I missing something?
    Max 5.1.6 Live 8.2.1
    Thanks all, tohm

    • Nov 23 2010 | 10:19 pm
      Sounds very odd to me. I simply pull in the device and it just works...
      How did you test this critter? Does it actually "run" (go over the buffers) when you start the global transport?
      Hmm, maybe important: what license do you got? M4L, Max (/MSP/Jitter) or both ?
      I just noticed that the eventual output object is both plugout~ as well as dac~. But the latter only works for M4L users whenever you have a M4L patch open in edit mode.
      So here's what you should try: Pull in a Max audio effect, click edit and keep it open in edit mode. NOW pull in the buffer shuffler and check if this works as expected.
      Does it?
    • Nov 24 2010 | 1:49 am
      Thanks for the reply... thats why I love the max boards...
      Been a Max user since the floppy version, (both MSP and Jitter as well). I just added the M4L a few months back, just haven't had much time to work with it yet
      And now nothing is working (I tried some simple filters as well as the buff). Midi effects seem fine...
      Other thing seem messed up as well... I open other tutorials... the delays work...but the buffer shuffler won't... autowah filter does not either...
      Any ideas? I just tried repairing my library and that din't help either
    • Nov 24 2010 | 2:47 am
      So, audio can actually be effected, but there seems to be some communication issue...
      Example: If I load the Autowah Preset (Max Audio Effect> Tools> Max Autofilter> Autowah) The filter itself works, but will not automate unless the patch is open in MSP
      If I turn preview off in MSP, the effect stops moving If I turn preview back on, it work as it should.. movement and all
      There must be something getting lost in the communication if Max is not open...
    • Nov 24 2010 | 3:32 am
      Also just tried a M4L uninstall-reinstall... that didn't do anything either
    • Nov 24 2010 | 6:11 am
      Drop a note to support at cycling 74 dot come, we will get you straightened out there.
    • Jan 30 2012 | 3:57 pm
      Did you solve your problem? I have a similar problem with the buffer shuffler too...
      if you have any clue how to solve the problem, that would be awesome...
    • Jan 30 2012 | 5:02 pm
      Are you using Max 6? If so, we recently found and fixed a bug with phasor~ in Max 6 MFL which was causing issues like this. This should be in the next update.
      Thanks, -Ben
    • Jan 30 2012 | 5:48 pm
      yes I'm using Max 6.
      Thanks for the info.