[bug] for a long line, the cursor of [text] is offset of 4 characters at the end


    Mar 27 2014 | 2:20 pm
    my conf
    {
    "version" : "Version 6.1.6 (307fb20)",
    "platform" : "mac",
    "arch" : "x86",
    "osversion" : "Mac OS X Version 10.6.8 i386",
    "samplerate" : 44100,
    "iovs" : 512,
    "sigvs" : 512,
    "scheduler_in_audio_interrupt" : "off",
    "audio_drivername" : "Core Audio",
    "audio_driver_subname" : "",
    "eventinterval" : 2,
    "overdrive" : "off",
    "mixerparallel" : "on",
    "mixercrossfade" : 2,
    "mixerlatency" : 30.0,
    "mixerramptime" : 5.0
    }
    using [text], when having a very long line and trying to edit it, the cursor  is offset of 4 characters at the end. There are 4 blank spaces, if you try to erase them you will erase the end of the line. Seen that with a line containing at least 4095 characters.

    • Mar 27 2014 | 2:22 pm
      oh also trying to paste that line in a [coll] got a max window error :
      typedmess: m: corrupt object
      typedmess: m: corrupt object
      typedmess: m: corrupt object
      typedmess: : corrupt object
    • Mar 27 2014 | 2:23 pm
      the c and the o of the last error line didn't even show on my computer
    • Mar 27 2014 | 2:27 pm
      trying to paste such a number of characters in a message box, got that in max window :
      atombuf_text
      in blue, all max windows messages i pasted are blue
      and i got a blues too
    • Mar 27 2014 | 2:29 pm
      oh and message box doesn't contain the whole mesage i sent it, just a list of the 256 last elements, which are 4 characters each (one is 5)