Bug? opening a patcher with filtergraph~ + cascade~ when the audio is on

    Apr 18 2012 | 5:11 pm
    When the audio is on and I open a patcher containing the couple filtergraph~ + cascade~, like this:
    I get a HUGE noise coming out of cascade~ (which really damaged my left ear this morning). Using Max 6.0.4 with Mac OS X 10.7.3 The weird thing is sometimes after this starting noise, one of the cascade~ object simply doesn't work and outputs ''nan'' Is there a way to make this work? It was totally working with the previous version of Max in February. Is there a way to re-install a previous version of Max? Thanks for your help.

    • Apr 18 2012 | 11:45 pm
      This has come up before, and I thought it was supposedly fixed. I had a patch where I put a [loadbang] going to a [line~] to save my ears.
      Does it also fix your [cascade~] to copy and paste replace it?
    • Apr 19 2012 | 1:13 am
      Thanks for your answer Mark. Actually I am also experiencing very weird behaviors in Max after this clic: MSP patch cords who don't carry signal but ''nan'', receive~ objects who don't receive what they're suppose to, MSP patch cords who turn audio off when connected to objects, no more left channel in dac~ ... Hmm...
    • Apr 19 2012 | 12:51 pm
      Hey Mark, I can't find infos about this bug on the forum. What were the tags for it?
      A mute when loading the patcher doesn't really work because from time to time the audio in the patcher becomes totally crazy (like what I described in my previous message) and I need to restart the patcher again. I tried with older patchers of mine who did work for 2 years and it is the same behavior... beginning to stress out a little for my concert tomorrow...
    • Apr 19 2012 | 2:38 pm
      Wow I really need help here. Just re-installed all Max and still the same story. The weird thing is that the huge noise coming out of one of these guys doesn't go through dac~ but directly to the output of the soundcard. I have clicks when turning audio on and off. It doesn't come from my soundcard, tried with another one.
      What does this message ''nan'' means when probing is on and mouse on patch cords? What does the message ''buffer~: can't read file now'' means in the Max window?
      I wish I never updated Max, it was working great before.
    • Apr 19 2012 | 3:07 pm
      Florent, this sounds quite strange to me!
      Are you sure you don't have abstractions in Max6's search pathes named like regular object (like a cascade~.maxpat file) ?
      BTW, you can run Max5 and Max6 (and Max4) on the same Mac. Just reinstall Max5.
      nan means "not a number", like when you try to divide by 0 ; clicks when turning the dac on/off happens when there is DC in the signal.
    • Apr 19 2012 | 4:10 pm
      Thanks Patrick. It seems all my issues came from cascade~ which seems to be very buggy in my setup. Thanks for the idea of using Max 5. I actually replaced cascade~ by the version from the Max 5 folder and, keeping fingers crossed, I had no issue so far. I hope I could help more and filling a bug report but I don't really understand what was going on. Nobody's experiencing weird behaviors with the updated cascade~ ?
    • Apr 19 2012 | 6:18 pm
      It was at 6.02:
      • cascade~: fixed noise on DSP initialization
      The thread:
      I experienced the noise problem but nothing more serious than that.
    • Aug 24 2012 | 10:44 am
      Yes, 6.0.2 does say "• cascade~: fixed noise on DSP initialization". But it still does it in 6.0.5. Seems like they need to try again.
    • Aug 27 2012 | 9:17 am
      Yes, cascade~ is broken on 6.0.5 too.
      Thanks god the Florent idea of using the Max5 cascade~ works.
      Do the people from Cycling read this forums or we have to open a support ticket to inform of this bug?
    • Aug 27 2012 | 1:56 pm
      Yes a bug form has been filled but they're having hard time to reproduce it. It is too elusive. Maybe you could fill another one explaining exactly what is your machine, what OS, when it appears and what happens exactly. Hopefully the Max 5 tricks works!
    • Aug 27 2012 | 2:16 pm
      Yes, the Max5 trick works here. I will fill another bug form.
    • Oct 05 2012 | 11:10 am
      I have also been having this problem in Max 6.0.7 using 8 parallel cascade~ units fed by one filtergraph~. A solution I found was to make sure that 'Output Coefficients on Load' in the filtergraph~ inspector, and to hard-wire it directly to the cascades rather than using a pvar.
      No more speaker blowing explosions!