bug: UI objects invisible/disappear in mira


    Nov 07 2016 | 3:44 pm
    hello all,
    i'm observing a strange bug in mira (running on my old iPad 2). occasionally and without any real consistency, objects disappear (eventhough they're in the mira frame). also sometimes, text (of e.g. live.text of live.tab objects) is not displayed. any clue what's going on?
    thanks

    • Feb 23 2017 | 9:14 pm
      I have this Problem, too. Text of live.text is simply not displayed after Mira has connected. Then I use the Mira menu to switch to patching view and back to presentation and the text of the buttons is back. After some weeks with Mira It feels so wrong to tell others to get the app and pay. Buggy as hell and probably no longer maintained by a developer.?
      O.
    • Feb 23 2017 | 9:31 pm
      to my knowledge, mira is very well maintained and quite some tricky piece of software. i do observe these bugs, too – but i think we can be optimistic that this stuff will be fixed sometime :)
      what ipad-generation are you on? just out of curiosity.
    • Feb 23 2017 | 9:41 pm
      Ipad 2. Hmm. I mean it doesn't look like it's up to date. It's not even reflecting the design change of Max 7. (Max 6 Dials and so on)
    • Feb 23 2017 | 10:11 pm
      same ipad here :) ... well – mira on the appstore was updated late 2016 (and it's been around since aaaaages!). i'm not sure if the bugs are on that side, or if its actually the max-side that's still a little clumsy (and here, even the latest 7.3.2 release fixed some mira bugs).
      as for the UI elements – i don't think this is due to being out of date. to my knowledge, mira doesn't really "mirror" the actual max UI – you can't think of it as a secondary screen. so or so – i'll continue using and building up on it :) i'm optimistic that mira and/or miraweb will continue to progress.
    • May 16 2017 | 2:17 pm
      I've been using Mira successfully with an older project but now I get the same inconsistent behaviour that you're describing, i.e. disappearing objects such as live.text, slider etc. I'm using iPad Air 2 connected to Mac with USB.
    • Sep 03 2017 | 9:49 pm
      Hey, just got going with Mira and running into the same problems. Also iPad2. Any updates?
    • Sep 04 2017 | 5:49 am
      At least, it is possible to find workarounds for the most problems.
    • Feb 24 2018 | 6:03 am
      I bought an iPad Air 2 specifically to use MIRA, as I was optimistic about it being more usable by this point (I was one of those suckers who payed $50 for this when it was released, still a bit sore about that). Working hard on a patch that's only about 80-90% visible in MIRA, so I'm wondering if I'm just pushing it too hard, or using it 'incorrectly'? Questions for the forum / developers:
      1) Are some objects are more consistent at appearing than others? (seems to me live. objects are buggiest) 2) Are some objects/combinations of objects more taxing than others? (multitouch?) 3) Is there an object limit that is known, or estimated? e.g. objects within a single frame, or across multiple active frames 4) Any general tips anyone can share for anyone working with Mira.
      It's such a cool parter to Max, and seems to actually perform significantly better than ever (hasn't crashed on me in months). I can handle the limited selection and buggy appearance of objects if they would at least show up to do their jobs.
      @11OLSEN - mind sharing your work arounds? (whether the pertain to these specific questions or not)
      Thank you all :]
    • Feb 27 2018 | 9:09 am
      I've had constant issues with things disappearing in MIRA, most bad things happen when I try to show/hide things from the patch or dynamically change things. I have scripted things to reload before to work around, like a screen refresh, but I have found lately that MIRAweb is a bit more stable using Safari on an iPad.
    • Feb 27 2018 | 6:22 pm
      @ terenceformer unfortunately i don't remember every step i took. i still have the patcher but can't post it here. from a quick look into it and from what i remember hiding and showing things dynamically didn't work reliably by using "hidden 0/1" messages to objects. Instead i used attributes of the object like bgcolor, ignoreclick and displayed text.
      e.g. this patcher i used before every live.text to make "hidden 1/0" message reliable.
      Don't use message boxes, use comments to display text.
    • Feb 27 2018 | 10:12 pm
      The state of Mira has caused me to lose some respect for C74. Poorly designed/implemented/supported
    • Jul 30 2019 | 6:10 pm
      I can add that on the current versions of Mira/max, message boxes consistently do not appear on the screen, and text in live.text and live.tab appear when they feel like it on an iPad 2.
    • Apr 23 2021 | 12:17 pm
      Hi, sorry to resurrect this thread - but I wanted to check in on the status of this situation? I'm trying to do some layered kslider stuff for visual feedback - specifically differentiating between active notes on a quantizer and notes that are actually playing. Unfortunately it seems that opacity does not properly work in Mira. Or is there a trick to this that I am missing?
      Everything looks as it should on the actual computer.