C74 problems

    Feb 11 2010 | 8:17 pm
    I recently got C74 from the app store for my Ipod Touch 2G (3.12). I also got the Max object required to communicate with it. When I launch C74 on my iPod it appears to connect (spinning icon goes away on the iPod and the C74 object status toggle goes on.) I also get about 50 "connected to client" messages in the Max window. On the iPod I've got a blank screen.
    When I open the creating_objects patcher and click on the various interface building messages nothing happens on my iPod (the screen just stays blank)
    Anyone got an idea what I'm doing wrong?

    • Feb 11 2010 | 9:02 pm
      Here's an update to my last posting.
      I tried quitting c74 on the ipod and quitting Max (5.02) Then I relaunched Max and created a new c74 object. Then I launched c74 on my iPod. It connected just fine and I was able to create some objects, change the background etc. Then Max crashed. So I went through the same quitting, relaunching etc. process and now I'm back to not being able to get any objects to appear on the iPod screen when I click on the messages in the creating_objects patcher.
      I've tried quitting and relaunching Max and the c74 app multiple times. Now it doesn't seem to have any effect. Interface objects no longer appear in the C74 app no matter what I do.
    • Feb 12 2010 | 1:07 am
      hi there!
      that c74 app you are talking about is not a Cycling '74 app. It is from another company, that I assume is not related to Cycling '74. Maybe you could contact them concerning your issue, although I suppose some people on this forum might be using it already and can be of assistance!
      Cheers Panos
    • Feb 12 2010 | 11:38 am
      The C74 app requires Mac OS Leopard to work. Are you on 10.5 or higher?
    • Feb 12 2010 | 1:44 pm
      First, Sorry to all if it's considered inappropriate to post questions about 3rd party externals, but it's something people seem to do all the time (in fact the forum is where I learned about C74!)
      As for Leopard, yes I'm 10.5.8. Is there anyone else who's run into problems like this? Now I'm wondering if it's my wireless and not the app.
      This app is REALLY cool (when it runs!) so I'm hoping I can get this figured out.
    • Feb 13 2010 | 1:58 pm
      Hi there, I had the same problem but changing the order in which to start up things helped me. Thirst open the iphone/touch app (you'll see it searching) then open the c74 maxhelp patch. Im on osx 10.6 with an iphone Hope this helps you. Mark
    • Feb 13 2010 | 4:46 pm
      Hi leo from nr74 here, I'm working on this particular crash and it'll be fixed in a soon to be released update. Follow http://www.twitter.com/c74app or its RSS channel for news about updates etc.
    • Feb 13 2010 | 6:12 pm
      anyone know if therell be tiger support or even firstgen ipod touch support added, wouldnt mind picking up some first gen ipod touchs for cheap if it worked with em
    • Feb 13 2010 | 6:51 pm
      I would not mind first generation compatibility as well, since I had the good idea to read the info while waiting for the app to be downloaded. Just to see first gen were not supported... :-) Stupid me.
    • Feb 14 2010 | 4:35 am
      yep, almost got it but noticed no firstgen touch support, wouldnt mind im still on tiger so it wouldnt work, but plan on upgradding soon, just had an idea for lots of cheap ipodtouch firstgens, in a custom mount cheap lemur/ipad kinda thing
    • Feb 14 2010 | 10:34 pm
      About 1st gen iPod support : It's up to Apple, c74 requires a microphone or at least according to the iTunes approval process... Tried to solve the issue but seems to be hard.
      About Max crashing : An update will be released soon, there seemed to be a huge issue with the external on computers running 10.5 (I'm on 10.6). This issue has been solved, since I'm also adding multiple device support in the update it also requires an updated version of the iPhone app itself which will require Apple's approval process again. So it'll take some time.
      When 1st gen iPod will keep on giving the microphone error I might as well use the microphone on devices that do have support and create an option to send the average (avg~) microphone value to Max/MSP as well as an extra wireless sensor...
    • Feb 15 2010 | 3:30 am
      hey thanks for responding, apples rules seem to make no sense, thanks apple again for a great app not being allowed..
      perhaps releasing the app for jailbroken phones? but i wouldnt wanna jeopardise anything, guess i may have to get a 2nd gen touchy :(
    • Feb 19 2010 | 4:10 pm
      I'm sorry to be a pain, but how do I connect the iPhone to the computer in the first place? Is it WIFI or bluetooth? I can't get a connection at all.
    • Feb 19 2010 | 4:28 pm
      Hi Sepp Ultura, you connect via WiFi, make sure both devices are on the same network and have both devices point at the same channel (in Max it uses default channel 1 and it will communicate over port 8001 so that shouldnt be blocked as well) The c74 app itself broadcasts on channel 1 by default, but these numbers can be changed in the menu of the app.
    • Feb 20 2010 | 4:43 pm
      Thanks very much Leo!
      The hint to the port number solved my problem.
      I have built a Max 4 Live patch now that lets you access 4 parameters in any Live device. I thought I might as well share it. If anyone owns Live and M4L, you can download it here:
      Load the M4L device into any track in a Live set. There are four sections, one for each parameter you want to control. Click 'Initialize' to scan the available tracks in the Live set. Select the track, then the device, and finally, select the parameter you want to control. Click confirm.
      Then start the c74 app on your iPhone. The screen controls on the phone will load and you'll see 4 big sliders (one for each parameter). Underneath the big ones are 8 small sliders (always a pair) to scale the output (some of the Live parameters have to be scaled down or up).
      The top sliders range from 0-127, the bottom sliders range from 0-1. You'll see the feedback in the number boxes in the M4L device (labeled 'Max').
      Have fun! And thanks again for your help Leo!
    • Feb 21 2010 | 5:25 am
      c 74 is not a strange or reactions?
    • Feb 21 2010 | 8:22 am
      I'm having trouble with version 1.3 of the C74 app. Everything seems to be ok except for the imge functions. In the help file image subpatch, whenever I click the message box [image myself leo.jpg] Max crashes.
      Any suggestions?
      MacBook Pro OSX 10.6.2; MaxMSP 5.1.3; iPhone 3GS OS 3.1.3
      Edit: I also get errors in the Max window when trying to use the read and grab functions: Error writing file...
    • Feb 21 2010 | 11:48 am
      Hi Steven,
      there seems to be an issue with filepaths in the v1.3 external, I'll look into this, the c74 external,when initialised looks for the filepath where the Max patch is saved and somehow this causes some problems every now and then. This might also cause the grab and read errors.
    • Feb 21 2010 | 12:17 pm
      @Sepp Ultura: I have tried your patch, but unfortunately my iPhone does not want to connect to it. When I launch the maxhelp patch that comes with the c74 app, I am able to connect to this patch, but not to yours. Did you perhaps use the previous version in your patch?
      Many thanks in advance for your reply!
    • Feb 21 2010 | 1:51 pm
      Hi Vincent. My patch connects on channel 15 by default. Strangely enough, my c74 app automatically tries to connect on channel 15 when I connect my iPhone to my WiFi. That's why I set the default channel to 15 in the M4L patch itself.
    • Feb 21 2010 | 2:02 pm
      Try that one:
      I don't know if you were able to access the c74 object-structure, as I've imported it as an external patch. I've corrected that now; the whole c74-structure is now contained fully and editable in the patch.
      But default channel 15 is still on. I have also added an Accelerometer-section. It only works when Proximity is on and if you touch the upper part of the phone (gated, so to speak).
      I hope it works.
    • Feb 21 2010 | 3:12 pm
      Hi Leo, thanks for the reply - I look forward to hearing about it when you've solved the issue. The folder with the photo, external, and help file was in the Max search path, if that helps.
      Also, it could just be my imagination, but it seems like this version is significantly slower to respond, in both directions, than the previous version. There is a variable lag-time between actions on one end (either computer or iPhone) and the corresponding result at the other end.
    • Feb 21 2010 | 7:53 pm
      Hi Sepp Ultura,
      Thanks, that worked! I still cannot open the c74 object structure, though (I think I could learn a lot from looking at the way you incorporated the c74 patch in yours!).
      Thanks again, Vincent
    • Feb 21 2010 | 10:23 pm
      Hi Vincent,
      That's strange. You can't open the subpatcher named "p iPhone5Control" in the main patcher? When I open the M4L edit window and switch to edit mode, I can open and edit it. You should be able too. It's not an external anymore.
    • Feb 22 2010 | 2:32 pm
      It's the year of the Tiger, any prospect of a Tiger external, Leo ? Anyone care to adapt the source ? I tried and failed ...
    • Feb 22 2010 | 7:06 pm
      I'd love to see a Tiger version too. Unfortunately I can't help with the port, sorry!
    • Feb 22 2010 | 7:52 pm
      would love tiger and 1st gen ipod touch too..
    • Feb 23 2010 | 2:52 am
      Unfortunately I'm still unable to connect, I have port forwarded 8001 as I thought this may be the problem, but still no luck. I'm on OSX 10.5.8 and iPhone 3.1 Any help would be much appreciated.
    • Feb 23 2010 | 5:04 am
      Ignore my previous message, it seems there was a hiccup in the network, but a simple reset solved the problem. The only issue I have had is that Max crashes and closes after a few minutes, but I'm sure you are aware of this.
    • Feb 23 2010 | 1:15 pm
      I can't confirm this behaviour. I'm on the exact same setup as you are (iPhone version 3.1.3) and I haven't had any issues.
      That doesn't solve your problem, though. But I thought I might give some feedback.
    • Feb 23 2010 | 2:04 pm
      if I'm correct, this only works if you have a wifi internet connection to connect to, right?
    • Feb 23 2010 | 7:05 pm
      i m sorry, under windows c74 it is necessary to wait or not?
    • Feb 23 2010 | 7:59 pm
      @ Sepp Ultura: I can now open the subpatcher (I did something stupid which prevented me from being able to open it).
      Thanks again! Vincent
    • Feb 27 2010 | 7:45 am
      Do not get a searching spinning icon - just see c74 logo for 10 seconds then it crashes out. IPod Touch latest version hard and software. MacBook Pro + Snow Leopard.
      Help please.
    • Feb 28 2010 | 4:16 pm
      Further to previous post. Have just noticed that I can see the searching spinning icon if my wi-fi is off. Checked (as above) that c74 channel is set to 1 as is my wi-fi (and MAX default). So why can't I connect or even start the connection process?
      Help please
    • Aug 10 2010 | 2:24 pm
      HI all can somebody please explain step by step how to connet the iphone to max with c74 its still not clear to me :) thanks alot nehad
    • Aug 24 2010 | 12:38 pm
      Hello, The same for me please, it does not work, still searching for connection =( Thanks a lot, Mathieu
    • Aug 24 2010 | 1:05 pm
      have you done your network setup correctly? you have to create one, and then choose that one in your iphone... it´s not very complicated, but have you done that first?
      after that you choose the same channel in c74 and max patch and it should connect with no problem.
      (using max5)
    • Aug 25 2010 | 3:03 pm
      Yes I created a network on my MacBook then connected my Ipod. Dafault Channel : 11.
      Then channel 11 in C74 too but it does not work.
      My ipod is a very first version, maybe its the problem because on the website its said it might not work with first versions. (in fact its said c74 won't be launched on first versions, here the application starts but no connection at all :( ) (I am using max 5)
      I don't understand, I have troubles making TouchOSC work too :(
    • Aug 26 2010 | 12:51 pm
      it may be a problem of the version of your ipod, because I´ve heard before that it doesn´t work in early versions.
      regarding to touchosc it maybe the same problem, those apps are done for modern versions of the machines.
      sorry but you´ll have to make apple crew happy by buying a new one if you want it to work.
    • Sep 02 2010 | 12:36 pm
      Oh yes I tried with a modern IPhone and TouchOSC works. So it comes from my Ipod touch ! damned ! =/
    • Sep 03 2010 | 8:22 am
    • Sep 03 2010 | 12:59 pm
      It looks great ! But does it work with Ipod first versions ?
    • Sep 03 2010 | 1:04 pm
      Yes i tried it, it works with ipod V1 !
    • Sep 03 2010 | 1:23 pm
      Awesome ! "i" Five =)
    • Sep 07 2010 | 7:50 am
      Okay here is my report :
      I tried (with iPod 1st version) : - C74 : not working - OSCtouch : works on freebox config, MacBook + Iphone on freebox server. does not work on local server MacBook iPod - Fantastick : works on freebox wifi config does not work on local config (didn't try MMF yet)
      When I am working on local config, I let the IP adress be chosen with DHCP. Is that the reason it does not work ? When it works with macbook and ipod on freebox wifi server, it should work on local config, no ? Maybe I have to set the Ip adress manually ?
      Thanks for your help, I really need to make it work =)
      Have a nice day,
    • Sep 07 2010 | 8:16 am
      Fantastick (and also TouchOSC) is working perfectly on my local computer network on ipod V1. didn't you forget to: -put your computer ipv4 address in the Fantastick settings on your ipod -put your ipod on your computer network in the wifi setting of your ipod. - sometimes i forgot this :-)
    • Sep 07 2010 | 9:55 am
      Nope I unfortunately didn't forget =(
      Do you set your ipv4 adress for local network via DHCP or on manual mode ?
      If find something weird and maybe its the problem : when i try local network (DHCP) the LED of the airport in network advanced settings (macbook) is orange. When i try it on freebox wifi, the airport led is green. Has it something to deal with the problem in your opinion ?
      Thanks for your help alexandre, I have been using a mac for only 1 month so your advice are precious.
    • Sep 07 2010 | 10:37 am
      True that these network config can be a bit boring.
      With me the led gets green after two second... (when it create the ip address)
      see attached picts.
      Also : i don't check the password option when i create the network. (And did i read somewhere Fantastick works better without password on the network?)
    • Sep 07 2010 | 11:19 am
      Ok with me it stays orange..., I think its the problem.
      The Ip adress is created, but the LED is still orange.
      (Maybe it just means that its a local network, so without internet connexion?).
      Thanks a lot for your picts =)
    • Sep 07 2010 | 11:49 am
      Je me permets de te parler en FR Alexandre,
      Pour créer le réseau à la base, tu utilises bien l'option "créer un réseau" en cliquant en haut sur l'icône du air port ?
      J'ai fait ça, je ne mets pas de mot de passe, je régle tout comme il se doit, l'adresse IP est affectée en DHCP, mais la LED reste orange. Je ne connais pas la signification de cette LED, peut-être que ça n'a rien à voir avec mon problème en fait.
      Je ne comprends pas pourquoi elle devient verte chez toi alors qu'elle reste orange chez moi ^^
    • Sep 07 2010 | 12:02 pm
      Ok it seems that Orange Led means : connexion but no Internet ..
    • Sep 07 2010 | 12:25 pm
      [.....] OK it works, fire wall ....
      Thanks Alexandre
      Have a nice day
    • Nov 22 2010 | 8:48 pm
      does anyone know if c74 works ok with ios 4 with iphone 3gs? I won´t upgrade if I can´t work with this app.
      thanks a lot.
      www.davidfernandez.org lllllllllllll llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll
    • Nov 26 2010 | 3:22 pm
    • Nov 26 2010 | 3:50 pm
      Hey gamuso, my girlfriend have an iphone 3gs just upgraded with ios4, if you want i can have a look if c74 works when she comes back tonight.
    • Nov 29 2010 | 9:50 am
      alexandre, you´re very kind...
      let me know if you have good or bad news about ios4.
      thanks a lot!
      by the way, so good to know about "dvorak" keyboard layout reading that comic. thanks a lot for that also.
      http://www.en.davidfernandez.org lllllllllllll llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll
    • Dec 02 2010 | 4:18 pm
      :( ' ' '
    • Dec 02 2010 | 6:47 pm
      Sorry for the delay, It looks ok : Everything in "c74.maxhelp" seem to work fine with the c74 app under ios4.2 on a iphone3gs.
    • Dec 02 2010 | 8:59 pm
      don´t worry alexandre... (I suppose one has somethings more important to do with his girlfriend when he comes at night than to try a friki app in her iphone!!).
      even when I´m not sure 100% it will work totally ok I will upgrade, as I really want to try ios4.
      leo says within a month there will be an upgrade, so I hope ios4 compatibility will be total.
      I´m tired saying it, this app is so powerful and looks like a real bridge between the computer and an iphone or mac. I just love it... its a shame that support and development aren´t really up to what it should be expected.
      say thanks to your girlfriend too!
      http://www.en.davidfernandez.org lllllllllllll llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll
    • Dec 03 2010 | 2:06 pm
      i´ve checked out the c74 patch with which i use to work and it seems everything is ok with ios4!
    • May 31 2013 | 2:00 am
      Helo i am new on the forum, i have a problem with c74, i build my patch and everything works fine,then i export my patch as an application and i can't load the interface on my ipad, any ideas?
    • May 31 2013 | 9:14 am
      Did you copy the c74.mxo external into your app? 'Show package contents'..
    • Nov 16 2013 | 12:06 am
      Hi, my C74 app and the new mxo 1.5.2 are not more working on Max 6.1.5 32bit. On the iPhone I'm running the old 6.1.3 iOS, on the Mac I'm on Snow Leopard 10.6.8 OSX. Regards