cant build standalone - app crashes on launch

    Jun 13 2012 | 1:08 pm
    I cant seem to build a standalone patch from this basic test patch. Having looked through the reference files and documentation on building standalones, I've tried a back to basics approach - and am trying to build up from the simplest elements. I am working on a MacBookPro on Lion, with Max 6.0.4.
    Every time I go to launch the app that I have built, it crashes and I get this report:
    Crashed Thread: 0 Dispatch queue:
    Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS at 0x00000000412f736e
    VM Regions Near 0x412f736e: MALLOC_LARGE 000000000c300000-000000000c341000 [ 260K] rw-/rwx SM=PRV --> __TEXT 000000008fec7000-000000008fefa000 [ 204K] r-x/rwx SM=COW /usr/lib/dylOk
    Here is the patch that I am attempting to build into a standalone - to test what's going wrong:
    And here is the the build script that I am using:
    open thispatcher open "Macintosh HD:/Users/georgepoonkhinkhut/Desktop/basic.maxpat"
    I have included a standalone object in the patch, and checked its properties in Inspector, pretty ordinary.
    If anyone at C74 could test this for me - perhaps I have an issue with my computer?
    I HAVE built standalones before - but its always been touch and go - now I am trying to understand what makes them work or not.
    Attached is the crash report in text form. Thanks

    • Jun 13 2012 | 4:45 pm
      Works fine here: Max 6.0.4 and OSX 10.6.8.
      My only command was "open thispatcher".
    • Jun 16 2012 | 5:06 am
      Thanks for testing SeeJay
      Tom Hall emailed me with the suggestion to completely remove my existing install and reinstall Max. I removed Max, then booted into the Lion Recovery HD - did a Repair Permissions, Repair Drive (just in case - as I've had a lot of issues with permissions lately), then reinstalled Max6, Then I tried building the standalone of my very complex patch - and it worked straight off! Brilliant!
      Here's Tom's instructions for de-installing Max, so you can do a clean install:
      To clean out Max 6 entirely, remove these items:
      1. ~/Library/Application Support/Cycling '74 2. /Applications/Max6
      In Mac OS 10.7, the Application Support/Cycling '74 folder is hidden. You can find it using the 'Go' Menu in the Finder. From there, choose 'Go To Folder...' and enter:
      ~/Library/Application Support
      then navigate to the Cycling '74 folder and delete it.
      All the best