Can't create a standalone .app, only .mxf created

    Feb 13 2011 | 10:29 am
    Hi everyone,
    OS: Mac OS 10.6.6 MAX Version: 5.1.7
    I'm just at the stage where I need to create my standalone and have run into a couple of issues. Initially, I did manage to build when I removed the v1.4 from the file name I was giving the application, and everything built fine, the application ran fine and everything was great. I have made some minor graphical changes (window sizes, corrected some spelling mistakes) and now I can't create an application.
    I've done a quick screencast to show what's happening:
    To summarise - when selecting "Application" in the dropdown in the build window, the extension does not change from .mxf. When I select "Collection" a classic application is built, which I can't open but it is only 1.7MB or there abouts so probably wouldn't work anyway. The .mxf which is created does seem to open and run fine in MAX.
    If any one can offer me any help it would be appreciated, as I am stumped as to what could be going wrong. It feels like some kind of bug but I know the most buggy thing here is usually me!

    • Feb 13 2011 | 10:38 am
      The first thing that could be recommended is to trash the preferences and try again...
    • Feb 13 2011 | 11:15 am
      weird. In addition to trashing the preferences, make sure that you have MaxMSP Runtime properly located next to the MaxMSP application and that the permissions for the /Applications/Max5 folder are correct.
    • Feb 13 2011 | 11:51 am
      Thanks for the replies. I've had a look and didn't specifically have read and write access to everything in the MAX5 folder. I gave myself (and all enclosing files and folders) read and write permissions but this didn't fix the problem.
      I'm going to repair permissions and try again.
      Where are the max preferences located? I did have a quick google and a trawl through the library without finding anything obvious but I probably should make sure I'm going to trash the right thing really!
    • Feb 13 2011 | 12:10 pm
      They can be found in the folder users/user_name/library/preferences/max 5 preferences folder. You can trash the entire folder. However, color schemes and object defaults are also stored there; if you have gone through great labor making you own schemes, don't forget to export them first.
    • Feb 13 2011 | 12:50 pm
      Sorted! Thanks for your help both of you. I repaired permissions, trashed the preferences and still could not build the application but then I saved as and changed the file name and the build worked straight away with the new version!
      It was probably a combination of everything that fixed it but the name change was certainly the most obvious change to get results.
      Hopefully this may be useful to anyone else who encounters this problem (unless it was just me being special, and it never crops up again - I'd hope so!)
    • Dec 03 2012 | 2:15 am
      If anyone is still struggling with this on Max 5, perhaps this may also help -
      In addition to trashing the Preferences folder from users/user_name/library/preferences/max 5 preferences, you should also check whether your patch contains any "."
      After following all the instructions above, I was still having issues with not being able to build .app. After I renamed my patch to not include any periods, it seemed to work fine.