cant get max to see any HID's/ tried everything/ need some help ! :)

    Oct 12 2011 | 9:22 am
    Hi there,
    Ive been trying to get a dataline wacom usb tablet to control parameters in max msp 5. basicelly i want to control an external osc (arduino) with an x/y controller. Ive been testing it with the tutorial patches and the HID tester in max. But max does not detect any devices. Ive tried the hi object. Then i found the hidin object but that isnt available anymore and the wacom object is not available for windows. someone told me I could also use the serial object but that was a bit beyond me. so im not sure if that is an option. Ive tried detection with installed and not installed drivers for the tablet. Windows does reckognize it in the hardware section..
    I keep getting 0 devices printed and an umenu that stays empty..
    Im on a win7 machine using max/msp 5.1 ..with the extended object library. "everything for win"
    I have no idea what i can do next to solve this issue, as the entire projects is allready failing at this first step im kinda hoping someone in here can enlighten me.
    Many thanks!

    • Oct 12 2011 | 4:30 pm
      I've found that some USB devices with custom drivers "hijack" the USB data from the device, with the result that the data is simply not made available to the HID protocol. I've had this experience with several some touchscreens and interactive whiteboards. The result is what you're experiencing: the device doesn't show up in menu lists generated by the [hi] object.
      The only workaround I've found is to remove the device drivers from your machine. For most situations this is not a viable alternative, but I don't have anything better to offer. Sorry.
      Note also that not all USB devices are necessarily HID-compliant. I don't know if your Wacom is an HID-compliant device. Presumably you checked this before embarking on your project.
    • Oct 17 2011 | 1:37 pm
      Thanks for your reply!
      Ive tested it on a mac with the same patch and device. On mac max did detect the tablet. So it is compliant. Im guessing its a win7 issue? I can imagine windows hijacking the driver communication data?
      Also tried id through udp receive/send objects but im having a hard time finding the right ports and ip adress of the device :p
      Any thoughts on this?
    • Oct 17 2011 | 3:37 pm
      Yes, we've also seen that Windows seems to eat USB/HI data for some drivers. It's a bummer.
      The only idea I have is to write a custom Max external object that talks to the device driver and passes the information through its outlets. I would expect Wacom to provide sufficient documentation that this would be reasonably straight forward to someone with experience in writing Max externs.
    • Oct 18 2011 | 12:26 pm
      I think I should be off finding someone that can write me that external then.Or take on a crash course and try doing it myself :) Still hoping for an easier solution though because I need this to work in a couple of weeks for a school project.
      I could also do the project on a mac but I still need this to work on my own win machine for future adventures aswell :)
      I made contact with support about max & win7 issues.. They also told me that using the hi object is a very unconsistent and tricky thing on windows.. They sayd theyd get back to me about it.
      I thank you again for your input on my issue Peter! Hopefully all will be solved soon.
    • Dec 30 2011 | 9:54 am
      Hello, I'm looking for some object (or solution) to connect the Wacom tablet to Max6 in Windows XP. Did you, woosasa, find finally some solution?
      Thank you very much in advice.