Can't switch to edit mode-MaxMsp 6

    Dec 22 2011 | 12:43 am
    Hi, I was moving around some parts of my big patcher and suddenly maxmsp stopped working, and I haven't been able to switch to edit mode since. I can open the patcher, but it crashes when I try to quit presentation mode(which is default state). It only happens with that patcher. What is wrong? anyone know anything about this? Thanks in advance. Paco

    • Dec 22 2011 | 6:22 am
      Try copying your compressed text above into a new patcher. Does that work?
    • Dec 22 2011 | 1:56 pm
      Thanks for your reply, I tried that, but as I'm only allowed to see the patcher in presentation mode, when I copy and paste it, only the objects shown in presentation mode are copied, WITHOUT the conections made. Which is obviously non convenient, as most of my patcher is not shown in presentation mode. It is really strange, because the patcher works, the audio works, everything works, but when I switch to edit mode... crash. I tried to change it in the inspector, not to open in presentation mode(a copy of the patcher with another name), and it simply won't open. It is a shame as the patcher was quite advanced and the last copy I have that works is missing a lot of work. One of the times it crashed I had a "6025 runtime" error, but not anymore?? Does this happened to anyone before?
      *When it crashed I was moving around a bunch of toogles, I was "organising" my edit window, which was quite messy.
    • Dec 22 2011 | 4:03 pm
      Is there any way of checking the code? Because I can open the patcher as text, but don't know where the "mistake" could be, if there is one I can fix. any ideas?
    • Dec 22 2011 | 5:20 pm
      If you can open it as text, look for the following line:
      "openinpresentation" : 1,
      Change the 1 to a 0 and save. See if it will open now.
    • Dec 22 2011 | 6:03 pm
      Thanks #bkshepard, I could change that in the inspector, but the patcher won't open, I tried it already. I formatted my hard drive, made a clean install of windows 7, installed max 6.0.2 and now evrything is fine!!! apparently at least. Thanks anyway, you know, for big troubles, big solutions;)
      what a relief man!