carriage returns in objects?

    Aug 29 2012 | 9:22 pm
    Can anyone explain why this isn't possible? Or maybe it is and I haven't figured out the secret yet? Many of my frustrations in organizing max patches come from long object boxes that would look and fit better if they were resized to multiple lines. You'd think simply resizing them and letting line-wrap do its thing would help, but as soon as you edit an object it snaps back to a long single line. (I've finally submitted a bug report on this issue.)
    Being able to organize an object a little better such as placing attributes on separate lines would make many items a lot easier to read and edit. You can type a carriage return when editing an object ([Cmd]+[Return],) but once you enter the object all line breaks are removed and it snaps back to a single line.

    • Aug 30 2012 | 1:11 am
      you can simply resize the object by dragging the right side of it to the left, if that's what you mean
    • Aug 30 2012 | 4:05 am
      If you option click out of an object it will not resize. You can turn the resizing off globally, too. (Auto FIx Width)
    • Aug 30 2012 | 2:13 pm
      Turning off Auto Fix Width does indeed keep the manually resized line wrap, but then EVERY object has manual sizing all the time, not just the ones i've manually re-sized. This moves the extra work from an occasional object to almost every object I create.
      Manually sizing the box just solves the outer dimension problem. In most cases, it actually makes the legibility of it's contents worse thanks to arbitrary line wrap. This is why I really want to manually set the line breaks by entering carriage returns.
      Chris: Do you mean option clicking out of a manually resized object with Auto Fixed Width turned on should keep the manual sizing? That would be a nice little work-around for autosizing. I just tried this and it didn't appear to work. With AFW enabled, I edited a manually resized line-wrapped object. The moment I type anything or change a character it snaps back to a single line. While still in editing mode of the now single line object, Option+Clicking blank canvas deselects the object but it still remains a single line. It doesn't appear to save carriage returns either. Perhaps I am misunderstanding? I also tried Option+Return, which just enters another carriage return. I'm on 6.0.5
      Edit: I've continued trying Option+ClickAway and actually got it to preserve sizing once or twice, but in most cases it doesn't seem to work. Not certain why, il continue to test.
    • Aug 30 2012 | 2:40 pm
      Ok, it seems entering carriage returns before attributes is indeed saved if you Option+ClickAway, but only while creating a new object. If you then edit that object, the moment you type anything it snaps back to a single line (as mentioned above,) and entering carriage returns where they once successfully resided are not saved if you Option+ClickAway from an edit instead of an original creation.
      Great to know there IS something saving carriage returns! It just seems to have a few bugs right now. Might anyone have a moment to verify before I start submitting reports?
      I've also verified that Option+Return doesn't seem to be the same as Option+ClickAway. Any idea if there is a keyboard friendly command to "commit edits with formatting?"
    • Dec 29 2012 | 11:11 am
      XedMada: Did you ever get anywhere with this? I'm still dreaming of being able to do something like the attached...