Changing the preset on a BCR2000 from Max via sysex


    Sep 07 2014 | 1:42 pm
    the topic pretty much tells what I am trying to achieve. Since I stayed away from sysex so far I have still hard times to get my head around it, instead I was poking in the internet to see if I find some solution. I found one in the ableton forum that supposedly works and tried to put it into a max patch without understanding each single element of the sysex strings. However, it doesn't seem to work. Does anyone know what's wrong?

    • Sep 13 2014 | 8:04 pm
      no one any hint?
    • Sep 14 2014 | 7:36 pm
      No BCR here to test with, but you have to convert the hex list to decimal first. Then I'd use [sxformat] to send the sysex messages.
    • Sep 14 2014 | 9:16 pm
      thanks. i figured the hex-decimal mistake already after i posted here. I built my own converter since i couldn't find any object but I still didn't get it to work. when sent to the BCR you version produces the "Er22" error in the BCR display like many of my tries. I compared the lengths of your decimal string (85) with my hex (71) - why does your version have 14 more values?
    • Sep 14 2014 | 10:35 pm
      " why does your version have 14 more values? " Copy and paste error on my part
    • Sep 15 2014 | 10:24 am
      hm, this version gives at least an error message I haven't got so far - according to a pdf I downloaded it means: Error 14 BC-EDIT identifier: wrongnumberofargs BC-EDIT message: wrong number of arguments Meaning: Invalid number of arguments (too few or too many).
      so it seems that the string length is a problem now but wasn't before?
      the meaning of Err22 is: Error 22 BC-EDIT identifier: sequence BC-EDIT message: sequence error Meaning: Invalid message index. Compare error 6.
      Error 6 BC-EDIT identifier: missingrevision BC-EDIT message: missing revision Meaning: No block defined. This error occurs for a section selector, command or dot statement outside a block (i.e. when no $rev has been sent in the same message chain, or when $end has been sent after the last $rev in the same chain). This error has precedence over error 13. This error also occurs if you send $rev R1 with a correct BCL message index of 0, followed by $preset with an incorrect BCL message index of 0 (should be 1).
      I am still lost...
    • Sep 15 2014 | 12:40 pm
      Hello, I'm giving an input here... I remember trying to use behringer beta software under OSX to import and export presets from the computer to the BCF2K and there was a kind of bug in the midi language. I remember we had to download a midi file converter to clear this language interpretation error
      If you are able to read french there are more infos on
      HTH Hubert
    • Sep 15 2014 | 1:12 pm
      thanks for the input, Hubert. i downloaded debehringer and will have to see if it is of use to me. however i am not trying to upload presets via sysex - I am looking for a way to change the presets on a BCR via sysex message - but maybe debehringer is still necessary for this... I based my patch on infos from this thread in the ableton live forum: https://forum.ableton.com/viewtopic.php?t=46302 where someone seems to have figured it out. unfortunately the sysex files mentioned in the thread aren't online anymore. I could probably ask around there - just didn't expect this to become so complicated.
    • Feb 21 2016 | 12:01 am
      In case someone still wants to make it happen ... Here it is.
    • Feb 21 2016 | 10:52 am
      thanks. looks great but doesn't work here (bcr with firmware 1.10). i tried all 4 USB and standalone modes on the bcr through usb and midi in. the red midi in leds light up when i send the sysex string but nothing happens afai can tell. but i also dont get any error message. i cant find anything in the manual about specifically opening the bcr for sysex or so. it should just work. still a mystery. hmm...