CNMAT externals not being found

    Jun 19 2013 | 3:46 pm
    I just tried to install the CNMAT externals but Max isn't finding the objects. It is in a file path which is in the Max5 file paths, and I have 'subfolders' checked. The external objects such as OSC-Route are not found. Any ideas? I've been using Max for a while and have never had problems with it finding externals before. I'm on OSX 10.6.8

    • Jun 19 2013 | 5:27 pm
      You can get the functionality of OSC-Route with standard Max objects, in particular using 'regexp' to replace slashes by spaces, ie. [regexp / @substitute " "]. There are some related threads on the forum.
    • Jun 19 2013 | 5:32 pm
      Thanks, that's useful to know, i'll probably go that route instead.
      Although, I would still like to know why these externals are not registering...
    • Jun 20 2013 | 8:42 am
      yes, it's a bit odd. Did you try double clicking objects/patchers in the package ? also, did you check the objects are not currently compiled for max 6 only ? in that case, you should download a slightly earlier version of the package.
    • Nov 01 2013 | 11:43 pm
      I'm going to mention it here in case someone else gets to this thread by web search: CNMAT silently stopped supporting several objects a few revisions ago. As it says on the downloads page:
      Please note that analyzer~, pitch~, loudness~, and brightness~ have been intentionally left out of this release. They will reappear in a subsequent release.
      This not is itself out of date. The combination object analyzer~ seems to be back (haven't done a thorough check of functionality yet) although you'd obviously have to rewrite some patches to use it.
      In anycase, if you are missing pitch~, loudness~ etc, now you know.
    • Mar 20 2014 | 5:14 am
      Although, I would still like to know why these externals are not registering…
      Sorry to revive an old thread again, but after updating my CNMAT externals, I am now having them not show up either. As far as I can see though, it’s to do with the objects showing up as folders, as opposed to bundles:
      Vade’s post (and David Butler’s comment), here:
      …has fixed it for me.