Compiling Xcode Examples

    Apr 20 2012 | 4:00 pm
    So I'm new to the SDK and have been spending the last few days running through xcode tutorials. I have successfully compiled a max object following this tutorial:
    My problem is compiling the example xcode projects provided in the sdk. I get the errors "jit.common.h: no such file or directory" or "ext.h:no such file or directory". I have edited the paths in the maxmspsdk.xcconfig document to reflect my filesystem, and I have re-added the frameworks to the project. Still no success. I don't get these errors when I make a new project and set all the target settings from scratch.
    I've attached my xcconfig document. It's entirely possible that I made a mistake somewhere. I'm a total beginner!
    Thanks for your help.

    • Apr 24 2012 | 9:55 am
      Hi vanille,
      It's a little difficult to follow your conversation with moali, but I took away the message that I should redownload the SDK, change nothing, and see if the examples compile.
      I redownloaded the SDK, put it on my harddrive, and tried to build one of the example patches. I got two easily fixable errors: 1. There is no SDK at specified SDKROOT path '/Developer/SDKs/MacOSX10.6.sdk' . 2. Invalid value '' for GCC_VERSION.
      I changed both these values in the xcconfig document to match my setup, and all runs smoothly.
      The problem came from the suggestion in the tutorial that the c74support folder should be moved to the Application Support file. I probably missed some paths when I was changing the xcconfig document to reflect this move. Thanks for the help.