corrupt file!?

    Oct 19 2010 | 4:14 pm
    so iv been working on this project for about 9 months now and I was working on this patch yesterday just pasting in objects that I thought might be useful as a reference (I did not patch these objects to anything). Everything was working fine yesterday, and I didn't even save the last changes that I made to the patch but now it doesn't want to open. Quite stupidly I have misplaced my backups of this patch on a long lost harddrive. I'v tried going through the max code in text edit to see if I accidentally patched something together that shouldn't be but I can't find anything wrong with it. I have attached the file to this post and if anyone can get this patch to open please let me know. Thanks!

    • Oct 19 2010 | 5:11 pm
      It looks like the end of this file has gotten cut off. Not sure how that happened. I was able to salvage what was there, but it probably is missing some stuff. Copy-paste this into a new patcher:
    • Oct 19 2010 | 5:14 pm
      It does not seem to be well-formed, the code ends right in the middle of an object definition.
    • Oct 19 2010 | 5:56 pm
      Ah yes, that was very strange. Thanks Ben, it looks like most of the stuff is there, only a few patch cords missing and the bpatchers needed to be reassigned. I'll be sure to post a detailed bug report if I run into this problem again. thanks again!
    • Oct 19 2010 | 6:46 pm
      for the record, i have had this problem twice since upgrading to max 5.1.5 - i just did exactly as ben did above, except was lucky enough to have my obsessive backups so could paste in some missing text from them, then the closing brackets. i remember having to do this in max 4 a couple of times. perhaps i should have posted a bug report sorry. osx intel 10.5.8, mmj 5.1.5. my computer is rubbish and falling apart and continuously crashing and corrupting things so i always assume these issues are peculiar to me.
    • Oct 19 2010 | 7:06 pm
      For the record, this is not a known issue with Max. If you do think you have some steps to repro, please send them along to support.
      Thanks! -Ben